Results 1 to 5 of 5

Thread: OpenSuSE 13.2 User Authentication password length

  1. #1

    Default OpenSuSE 13.2 User Authentication password length

    Unfortunately the suse documentation isn't up with the screens in opensuse 13.2 so this very simple thing, changing the allowed max. password length I can't find.

    So far I can change it by:
    • Clicking: User and Group Manangement
    • Clicking: Configure User Management Settings
    • Selecting: userconfiguration
    • Clicking: suseMaxPasswordLength
    • Changing the value to whatever, let's say 20
    • Clicking: OK
    • Clicking: OK (again)

    And here it says: "A problem occurred while writing to the LDAP server."

    • Clicking: OK

    Now clicking: "Configure User Management Settings" again gives:
    If you reread settings from the server all changes will be lost.
    And sure enough it does.

    I've left as much as possible at the defaults when setting up LDAP as I have never used it before so you can assume a very barebones non-customized setup done with the screens in YaST's GUI, no hand editing of text files yet.

    So my question is where in the server can I change this so the setting takes?

    Thanks!

  2. #2

    Default Re: OpenSuSE 13.2 User Authentication password length

    I guess you can ignore this, I did make one change I forgot about so it wasn't logging in so I put the name of the LDAP administrator back to it's default and then it worked.

    Funny, it let's you go to the page and make edits even though you haven't logged into the server... that threw me for a moment until I clicked on "Details" and saw that it wasn't connecting to LDAP because the credentials didn't match.

  3. #3
    Jim Henderson NNTP User

    Default Re: OpenSuSE 13.2 User Authentication password length

    On Sat, 18 Apr 2015 00:26:01 +0000, Reg gie wrote:

    > Unfortunately the suse documentation isn't up with the screens in
    > opensuse 13.2 so this very simple thing, changing the allowed max.
    > password length I can't find.
    >
    > So far I can change it by:
    >
    > - Clicking: User and Group Manangement - Clicking: Configure User
    > Management Settings - Selecting: userconfiguration - Clicking:
    > suseMaxPasswordLength - Changing the value to whatever, let's say 20 -
    > Clicking: OK - Clicking: OK (again)
    >
    > And here it says: "A problem occurred while writing to the LDAP server."
    >
    >
    > - Clicking: OK
    >
    > Now clicking: -"Configure User Management Settings"- again gives:
    >> If you reread settings from the server all changes will be lost.

    > And sure enough it does.
    >
    > I've left as much as possible at the defaults when setting up LDAP as I
    > have never used it before so you can assume a very barebones
    > non-customized setup done with the screens in YaST's GUI, no hand
    > editing of text files yet.
    >
    > So my question is where in the server can I change this so the setting
    > takes?
    >
    > Thanks!


    Do you have an LDAP server configured? The error you're getting seems to
    indicate that you may not.

    For standard non-LDAP authentication, this will probably be useful:

    https://www.novell.com/support/kb/doc.php?id=7008156

    While this is SLES, it should work just fine on openSUSE as well (SLES is
    downstream from openSUSE).

    Jim



    --
    Jim Henderson
    openSUSE Forums Administrator
    Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

  4. #4
    Jim Henderson NNTP User

    Default Re: OpenSuSE 13.2 User Authentication password length

    On Sat, 18 Apr 2015 00:36:01 +0000, Reg gie wrote:

    > it wasn't connecting to LDAP because the
    > credentials didn't match.


    That'd do it - glad you got it sorted out.

    Jim



    --
    Jim Henderson
    openSUSE Forums Administrator
    Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

  5. #5

    Default Re: OpenSuSE 13.2 User Authentication password length

    Thanks Jim,

    Reg

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •