Page 1 of 3 123 LastLast
Results 1 to 10 of 25

Thread: Java - IntelliJ - Problem

  1. #1

    Default Java - IntelliJ - Problem

    Hi everybody. I've tried to install Opensuse 13.2. Everything wa perfect, till i tried to install IntelliJ IDEA.

    i get this error, wenn i start install.sh

    'tools.jar' seems to be not in IDEA classpath.
    Please ensure JAVA_HOME points to JDK rather than
    when i try to install rpm JDK packages from sun internet site, i get this error:

    nothing provides /usr/sbin/alternatives needed by jdk1.8.0_40-2000:1.8.0_40-fcs.x86_64


    I didn't find any information about it. If you know something, please help to start this programm. Thanks. (Sorry for my English)

  2. #2

    Default Re: Java - IntelliJ - Problem

    https://intellij-support.jetbrains.c...will-run-under

    He link to his own answer on stackoverflow from "Check this answer if you need to install the JDK manually on Linux."

    http://stackoverflow.com/a/8384111

    Their site is also confusing and you can easily download JRE instead of the JDK (which will not work as IntelliJ IDEA needs tools.jar that is missing from JRE package).
    so you installed JRE instead of JDK?

    Check support links at their site if no one know details of this. They are very good, same with their forum.

  3. #3

    Default Re: Java - IntelliJ - Problem

    I installed JDK in YaST, but it seems only JRE installed. Can i fix it?

  4. #4

    Default Re: Java - IntelliJ - Problem

    I see problem was not what I thought it was.

    So had to test and it works.

    When installing just break stuff

    Code:
    Problem: nothing provides /usr/sbin/alternatives needed by jdk1.8.0_40-2000:1.8.0_40-fcs.x86_64
     Solution 1: do not install jdk1.8.0_40-2000:1.8.0_40-fcs.x86_64
     Solution 2: break jdk1.8.0_40-2000:1.8.0_40-fcs.x86_64 by ignoring some of its dependencies
    When you run "update-alternatives --config java" you wont see new Java but does it matter?

    It installs even if it says not really. Look in /usr/java/jdk1.8.0_40

    You can use special IntelliJ environement variable in idea.sh so add

    Code:
    export IDEA_JDK=/usr/java/jdk1.8.0_40
    to /whereyouputIntelliJ/bin/idea.sh

    Not a system wide Java I guess and install failed, not too good. But "zypper info jdk1.8.0_40" looks fine and IntelliJ does not complain.

    Start it up, check Help, about and there I see Oracle http://imgur.com/n5xDpZs

    If all fails just use openJDK, works as well even if they say hmmm.

    Tried also with openJDK http://imgur.com/VLKtE9F

    I looked difference up on stackoverflow long time ago. An Oracle guy said ZERO performance diff. between openJDK and Oracle version except a few bits here and there. So the dramatic words from JetBrains might be from old stories. On the other hand they know more than any of us

  5. #5

    Default Re: Java - IntelliJ - Problem

    Is ugly either way.

    This helps in phpStorm and also IntelliJ

    Code:
    export _JAVA_OPTIONS='-Dawt.useSystemAAFontSettings=lcd'
    put it in ~/.bashrc file and reload bash, run ". ~/.bashrc" I think.

    Menus look nicer, less cramped - not perfect though.

    Probably more tips here https://youtrack.jetbrains.com/issue/IDEA-57233 - is old problem.

  6. #6
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,866

    Default Re: Java - IntelliJ - Problem

    Why don't you just install the alternatives package It is in the repository just do a search in yast. It wants the alternative package so install it.

  7. #7

    Default Re: Java - IntelliJ - Problem

    Is installed but Oracles installer does not seem to find it properly so it stops and ask questions.

    Ignoring/breaking seem to be fine in this case because IntelliJ can be told to use a specific Java version. Since Oracle Java does get on hd it works.

    There is a "/usr/sbin/update-alternatives" file - have no idea if that is what installer wants.

    If there are no special features for Java programming in Oracle Java using openJDK might be the best. I googled some old benchmark finding a few advantages of Oracle Java. Newer versions should be identical, is also what Oracle says. openJDK is upstream or something. JetBrains still hang on to those old warnings though. Their forum should have more info if there are meat on them in 2015.

    Code:
    Information for package update-alternatives:
    --------------------------------------------
    Repository: openSUSE-13.2-Oss
    Name: update-alternatives
    Version: 1.16.10-8.1.2
    Arch: x86_64
    Vendor: openSUSE
    Installed: Yes
    Status: up-to-date
    Installed Size: 65.8 KiB
    Summary: Maintain symbolic links determining default commands
    Description: 
      update-alternatives creates, removes, maintains and displays
      information about the symbolic links comprising the alternatives
      system. It is possible for several programs fulfilling the same or
      similar functions to be installed on a single system at the same time.
      For example, many systems have several text editors installed at once.
      This gives choice to the users of a system, allowing each to use a
      different editor, if desired, but makes it difficult for a program to
      make a good choice of editor to invoke if the user has not specified a
      particular preference.
    suse:/home/jsdk/TempJunk/99 # 
    suse:/home/jsdk/TempJunk/99 # zypper install jdk-8u40-linux-x64.rpm
    Loading repository data...
    Reading installed packages...
    Resolving package dependencies...
    
    Problem: nothing provides /usr/sbin/alternatives needed by jdk1.8.0_40-2000:1.8.0_40-fcs.x86_64
     Solution 1: do not install jdk1.8.0_40-2000:1.8.0_40-fcs.x86_64
     Solution 2: break jdk1.8.0_40-2000:1.8.0_40-fcs.x86_64 by ignoring some of its dependencies
    
    Choose from above solutions by number or cancel [1/2/c] (c): 2

  8. #8

    Default Re: Java - IntelliJ - Problem

    Thank you for your answers. A solved the problem after i installed jdk 1-7 u75 from sun site. It is strange,
    i can't install anther version. Only 1-7! 1-8 won't work.

    Then i changed the pass in install.sh and that was it.

  9. #9

    Default Re: Java - IntelliJ - Problem

    Try Google "oracle java manual install update-alternatives" or something.

    Seems you need to manually install the *.tar.gz file from Oracle.

    Then manually register new Java with update-alternatives.

    Tons of tutorials for Ubuntu, like http://blog.manishchhabra.com/2012/0...-ubuntu-linux/ but should be similar.

    Remember you can force IntelliJ to use a specific Java version like

    Code:
    export IDEA_JDK=/usr/java/jdk1.8.0_40
    Put line in idea.sh in /bin/ folder under IntelliJ install.

    Not sure where you get install.sh from? JetBrains only talk of idea.sh I think.

    Is what worked for me with IntelliJ, after I went with "breaking" install of Oracle Java. Gets placed in /usr/java/jdk1.8.0_40 folder and seems to work.

    Other fix: use openJDK unless you have real reasons not to

  10. #10
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    12,149
    Blog Entries
    2

    Default Re: Java - IntelliJ - Problem

    Read the references to Linux compatibility (requires) posted previously (reposted here)
    https://intellij-support.jetbrains.c...will-run-under

    Note the reference to openJDK, although the reasoning in the link is incorrect.

    The casual User will not know that openjdk is <not> equivalent to Oracle's SE JDK. openjdk is a jdk in name only and provides <only> a JRE with no JDK functionality. If you want JDK functionality, you must either compile the missing openjdk parts (somewhat difficult) or install the Oracle SE JDK (should be very much easier).

    TSU

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •