Results 1 to 9 of 9

Thread: Zypper problem

  1. #1

    Default Zypper problem

    I installed "mlocate" and since Zypper hasn't worked well. When I try to search with zypper it says "bus error" and when I try to install it says "reading installed packages" and stops.

    There was some rpm error messages when I installed mlocate but I can't remember what it said.

  2. #2

    Default Re: Zypper problem

    I'm on OpenSUSE 13.2 64 bit with Gnome 3

  3. #3
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,769

    Default Re: Zypper problem

    Maybe uninstall it?? Try Yast

  4. #4

    Default Re: Zypper problem

    Quote Originally Posted by gogalthorp View Post
    Maybe uninstall it?? Try Yast
    TY, I figured I'll try do a rollback. I did
    Code:
    sudo snapper rollback
    and rebooted, then everything worked.

  5. #5
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    4,070

    Default AW: Zypper problem

    There was some rpm error messages when I installed mlocate but I can't remember what it said.
    See in /var/log/zypp/history

    Or as root in /var/log/zypper.log

  6. #6

    Default Re: AW: Zypper problem

    Quote Originally Posted by Sauerland View Post
    See in /var/log/zypp/history

    Or as root in /var/log/zypper.log
    Checked and there's no "mlocate" intallation log. Other changes are there.

    HEre's the error message
    Code:
    carlos@linux:~> sudo zypper in mlocate
    Loading repository data...
    Reading installed packages...
    Resolving package dependencies...
    
    The following 2 NEW packages are going to be installed:
      mlocate mlocate-lang 
    
    The following recommended package was automatically selected:
      mlocate-lang 
    
    2 new packages to install.
    Overall download size: 111.7 KiB. Already cached: 0 B  After the operation, additional 389.3 KiB will be used.
    Continue? [y/n/? shows all options] (y): y
    Retrieving package mlocate-0.26-15.1.2.x86_64                                                                    (1/2),  62.9 KiB (143.3 KiB unpacked)
    Retrieving: mlocate-0.26-15.1.2.x86_64.rpm .....................................................................................................[done]
    Retrieving package mlocate-lang-0.26-15.1.2.noarch                                                               (2/2),  48.8 KiB (246.0 KiB unpacked)
    Retrieving: mlocate-lang-0.26-15.1.2.noarch.rpm ...................................................................................[done (51.7 KiB/s)]
    Checking for file conflicts: ...................................................................................................................[done]
    (1/2) Installing: mlocate-0.26-15.1.2 ..........................................................................................................[done]
    Additional rpm output:
    Updating /etc/sysconfig/locate...
    
    
    (2/2) Installing: mlocate-lang-0.26-15.1.2 .....................................................................................................[done]
    Problem occured during or after installation or removal of packages:
    Failed to cache rpm database.
    Please see the above error message for a hint.r
    Again there are problems wit zypper.

  7. #7

    Default Re: Zypper problem

    I discovered that a simple reboot solves the issue.

  8. #8

    Default Re: Zypper problem

    Hi,

    zypper can be more verbose if you add

    Code:
    -vv
    as the global option. Also when it comes to rpm database you might want to rebuild it and see if it helps.

    Code:
    rpm --rebuilddb
    "Unfortunately time is always against us" -- [Morpheus]

    .:https://github.com/Jetchisel:.

  9. #9
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    4,070

    Default AW: Zypper problem

    Checked and there's no "mlocate" intallation log. Other changes are there.
    When you have done a rollbach, this might be before you have got this Problem. And so there is no Information about this Installtion of mlocate and the Error.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •