Results 1 to 3 of 3

Thread: opensuse repeatedly asks for root password while accessing NTFS partitions on internal HDD

  1. #1

    Default opensuse repeatedly asks for root password while accessing NTFS partitions on internal HDD

    It's kinda annoying.
    I type the root password, it lets me access those partitions. But if I restart the computer and try to access the same NTFS partition again, it asks for the root password again.


    As you can see above, "Remember Authorization" is checked, and "For this session only" is unchecked. But it still doesn't remember the authorization after a restart.
    How do I solve this? Please help..

  2. #2

    Default Re: opensuse repeatedly asks for root password while accessing NTFS partitions on internal HDD

    Quote Originally Posted by johnwinchester View Post
    As you can see above, "Remember Authorization" is checked, and "For this session only" is unchecked. But it still doesn't remember the authorization after a restart.
    Yes, that's by design.
    Polkit remembers the password for a maximum of 5 minutes, just like sudo does. But the dialog might be a bit misleading regarding this...

    How do I solve this?
    You basically have two options:
    - add an entry to /etc/fstab to mount your partitions

    You can do this in YaST->System->Partitioner, select the partition, click on "Edit", enable "Mount partition", and choose your preferred mount point, or add a line similar to this to /etc/fstab manually:
    Code:
    /dev/sdb1            /windows/C           ntfs-3g    defaults              0 0
    The partition is then mounted during boot already, and always accessible by any user.

    - allow users to mount system partitions without a root password, by adding the following line to /etc/polkit-default-privs.local :
    Code:
    org.freedesktop.udisks2.filesystem-mount-system yes
    Then run "sudo set_polkit_default_privs" to apply the change.
    Last edited by wolfi323; 07-Apr-2015 at 07:41.

  3. #3

    Cool Re: opensuse repeatedly asks for root password while accessing NTFS partitions on internal HDD

    hii wolfi,
    Of all the methods you posted, "YaST->System->Partitioner, select the partition, click on "Edit", enable "Mount partition", and choose your preferred mount point" looked easiest to me.
    I tried it, and it worked!
    The system no longer asks me for the root password while mounting my Windows partitions.
    Thanks for your help, issue resolved

    PS: I'm having another problem, opensuse refuses to play certain video files. I'm starting a new thread, please see if you can help me with that..

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •