Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Forcing Use of Correct Graphics Driver

  1. #1
    Join Date
    Nov 2008
    Posts
    2,161
    Blog Entries
    1

    Default Forcing Use of Correct Graphics Driver

    Using nvidia G720 graphics card on openSUSE 13.2 with KDE desktop. With help from wolfii et al. I found and installed the nvidia correct drivers and all was well until today when kernel update required a re-boot.

    I now have VGA only resolution and nouveau kernel modules loaded instead of nvidia...G04 modules.
    How can I force the system to use the Nvidia drivers at boot time?
    Should I uninstall nouveau modules?
    Budge

  2. #2

    Default AW: Forcing Use of Correct Graphics Driver

    Quote Originally Posted by Budgie2 View Post
    How can I force the system to use the Nvidia drivers at boot time?
    It is possible, but it doesn't make sense.
    nvidia is preferred when it is available, so the most likely reason why nouveau is used is that the nvidia driver is not working.
    If you _force_ Xorg to use nvidia in this case, it will just fail to start and you would only be able to use text mode.

    Should I uninstall nouveau modules?
    No. You cannot uninstall the nouveau kernel module (it should be blacklisted by the nvidia driver packages anyway, so shouldn't cause the problem). And there's no need to uninstall the Xorg driver (and it won't help at all).

    I'd say you should start by posting the file /etc/X11/Xorg.0.log and the list of installed kernel and nvidia packages.
    Code:
    rpm -qa | egrep "kernel|nvidia"
    You might also try to just reinstall the nvidia kernel module:
    Code:
    sudo zypper in -f nvidia-gfxG04-kmp-desktop
    Maybe the kernel module built for the older kernel does not work on the new one...

    Btw, a similar thread is also here:
    https://forums.opensuse.org/showthre...n-kernel-x-509
    (note that the subject is misleading, the message about not being able to load the in-kernel x.509 certificate is definitely unrelated IMHO)
    So you're not the only one for whom the nvidia driver does not work after today's kernel update.
    Last edited by wolfi323; 13-Apr-2015 at 10:03.

  3. #3

    Unhappy Re: Forcing Use of Correct Graphics Driver

    Same problem. After update "openSUSE-SU-2015:0713-1", "openSUSE 13.2", only one low resolution possible. HW info is showing correct screen and screencard.

  4. #4
    Join Date
    Nov 2008
    Posts
    2,161
    Blog Entries
    1

    Default Re: AW: Forcing Use of Correct Graphics Driver

    Quote Originally Posted by wolfi323 View Post
    It is possible, but it doesn't make sense.
    nvidia is preferred when it is available, so the most likely reason why nouveau is used is that the nvidia driver is not working.
    If you _force_ Xorg to use nvidia in this case, it will just fail to start and you would only be able to use text mode.


    No. You cannot uninstall the nouveau kernel module (it should be blacklisted by the nvidia driver packages anyway, so shouldn't cause the problem). And there's no need to uninstall the Xorg driver (and it won't help at all).

    I'd say you should start by posting the file /etc/X11/Xorg.0.log and the list of installed kernel and nvidia packages.
    Code:
    rpm -qa | egrep "kernel|nvidia"
    You might also try to just reinstall the nvidia kernel module:
    Code:
    sudo zypper in -f nvidia-gfxG04-kmp-desktop
    Maybe the kernel module built for the older kernel does not work on the new one...

    Btw, a similar thread is also here:
    https://forums.opensuse.org/showthre...n-kernel-x-509
    (note that the subject is misleading, the message about not being able to load the in-kernel x.509 certificate is definitely unrelated IMHO)
    So you're not the only one for whom the nvidia driver does not work after today's kernel update.
    Hi Wolfii,
    Glad its not just me and thanks for your instant reply.

    Strange but I have no /etc/X11/Xorg.0.log. Must be somewhere else but Dolphin "find" didn't come up with anything yet.

    Here is the result of rpm search:
    Code:
    alastair@x3400:~> rpm -qa | egrep "kernel|nvidia"
    nvidia-uvm-gfxG04-kmp-default-346.35_k3.16.6_2-4.1.x86_64
    kernel-macros-3.16.7-13.1.noarch
    kernel-syms-3.16.7-13.1.x86_64
    kernel-source-3.16.7-7.1.noarch
    kernel-firmware-20141122git-5.1.noarch
    kernel-pae-devel-3.16.7-13.2.i686
    kernel-default-devel-3.16.7-7.1.x86_64
    kernel-default-devel-3.16.7-13.3.x86_64
    nvidia-uvm-gfxG04-kmp-desktop-346.35_k3.16.6_2-4.1.x86_64
    kernel-desktop-3.16.7-7.1.x86_64
    nvidia-gfxG04-kmp-default-346.35_k3.16.6_2-4.1.x86_64
    kernel-source-3.16.7-13.1.noarch
    x11-video-nvidiaG04-346.35-4.1.x86_64
    kernel-syms-3.16.7-7.1.x86_64
    kernel-desktop-3.16.6-2.1.x86_64
    nvidia-gfxG04-kmp-pae-346.35_k3.16.6_2-4.1.i586
    kernel-xen-devel-3.16.7-7.1.x86_64
    kernel-desktop-devel-3.16.7-13.2.x86_64
    kernel-devel-3.16.7-7.1.noarch
    kernel-xen-devel-3.16.7-13.2.x86_64
    nvidia-computeG04-346.35-4.1.x86_64
    kernel-desktop-devel-3.16.7-7.1.x86_64
    kernel-devel-3.16.7-13.1.noarch
    kernel-pae-devel-3.16.7-7.1.i686
    nvidia-gfxG04-kmp-desktop-346.35_k3.16.6_2-4.1.x86_64
    kernel-desktop-3.16.7-13.2.x86_64
    nvidia-glG04-346.35-4.1.x86_64
    .

    and here is look at installed kernel modules:

    Code:
    alastair@x3400:~> /sbin/lspci -nnk | grep VGA -A2
    10:00.0 VGA compatible controller [0300]: NVIDIA Corporation GK208 [GeForce GT 720] [10de:1288] (rev a1)
            Subsystem: eVga.com. Corp. Device [3842:2722]
            Kernel modules: nouveau
    --
    1c:04.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] ES1000 [1002:515e] (rev 02)
            Subsystem: IBM Device [1014:0305]
            Kernel modules: radeon
    The radeon driver is there for the on-board graphics adaptor which I cannot disable from BIOS.

    I have no reason to believe the G04 driver has been corrupted but will try a new install as you suggest. Meanwhile how do I back out of the kernel update as machine is unuseable with VGA ONLY?
    Many thanks once more.
    Budge

  5. #5

    Default Re: Forcing Use of Correct Graphics Driver

    Quote Originally Posted by Budgie2 View Post
    Strange but I have no /etc/X11/Xorg.0.log. Must be somewhere else but Dolphin "find" didn't come up with anything yet.
    It's /var/log/Xorg.0.log, sorry for the typo.

    [QUOTE]
    Here is the result of rpm search:
    Code:
    alastair@x3400:~> rpm -qa | egrep "kernel|nvidia"
    nvidia-uvm-gfxG04-kmp-default-346.35_k3.16.6_2-4.1.x86_64
    kernel-macros-3.16.7-13.1.noarch
    kernel-syms-3.16.7-13.1.x86_64
    kernel-source-3.16.7-7.1.noarch
    kernel-firmware-20141122git-5.1.noarch
    kernel-pae-devel-3.16.7-13.2.i686
    kernel-default-devel-3.16.7-7.1.x86_64
    kernel-default-devel-3.16.7-13.3.x86_64
    nvidia-uvm-gfxG04-kmp-desktop-346.35_k3.16.6_2-4.1.x86_64
    kernel-desktop-3.16.7-7.1.x86_64
    nvidia-gfxG04-kmp-default-346.35_k3.16.6_2-4.1.x86_64
    kernel-source-3.16.7-13.1.noarch
    x11-video-nvidiaG04-346.35-4.1.x86_64
    kernel-syms-3.16.7-7.1.x86_64
    kernel-desktop-3.16.6-2.1.x86_64
    nvidia-gfxG04-kmp-pae-346.35_k3.16.6_2-4.1.i586
    kernel-xen-devel-3.16.7-7.1.x86_64
    kernel-desktop-devel-3.16.7-13.2.x86_64
    kernel-devel-3.16.7-7.1.noarch
    kernel-xen-devel-3.16.7-13.2.x86_64
    nvidia-computeG04-346.35-4.1.x86_64
    kernel-desktop-devel-3.16.7-7.1.x86_64
    kernel-devel-3.16.7-13.1.noarch
    kernel-pae-devel-3.16.7-7.1.i686
    nvidia-gfxG04-kmp-desktop-346.35_k3.16.6_2-4.1.x86_64
    kernel-desktop-3.16.7-13.2.x86_64
    nvidia-glG04-346.35-4.1.x86_64
    .
    Why do you have the kernel modules for kernel-default and kernel-pae installed?
    Remove them, they might cause the kernel-desktop ones from not being updated correctly.

    Code:
    sudo zypper rm nvidia-gfxG04-kmp-pae nvidia-gfxG04-kmp-default nvidia-uvm-gfxG04-kmp-default
    I have no reason to believe the G04 driver has been corrupted but will try a new install as you suggest.
    It's unlikely to be "corrupted".
    But the version for the old kernel just might not work with the new kernel.


    Meanwhile how do I back out of the kernel update as machine is unuseable with VGA ONLY?
    You can select any installed kernel in "Advanced Options" in the boot menu.
    Or you can even uninstall the kernel update (via YaST's "Versions" tab e.g.), but that shouldn't be necessary.
    Last edited by wolfi323; 13-Apr-2015 at 10:56.

  6. #6
    Join Date
    Nov 2008
    Posts
    2,161
    Blog Entries
    1

    Default Re: Forcing Use of Correct Graphics Driver

    Hi Wolfii,
    I removed the default and pae modules by running your command and received a warning message. Here is the result:-
    Code:
    here are some running programs that might use files deleted by recent upgrade. You may wish to check and restart some of them. Run 'zypper ps' to list these programs.
    alastair@x3400:~> zypper ps
    No processes using deleted files found.
    
    Note: Not running as root you are limited to searching for files you have permission to examine with the system stat(2) function. The result might be incomplete.
    alastair@x3400:~> su -
    Password: 
    x3400:~ # zypper ps
    The following running processes use deleted files:
    
    PID | PPID | UID | User | Command       | Service | Files                               
    ----+------+-----+------+---------------+---------+-------------------------------------
    482 | 1    | 0   | root | systemd-udevd |         | /lib/modules/3.16.7-13-desktop/mod->
        |      |     |      |               |         | /lib/modules/3.16.7-13-desktop/mod->
        |      |     |      |               |         | /lib/modules/3.16.7-13-desktop/mod->
        |      |     |      |               |         | /lib/modules/3.16.7-13-desktop/mod->
    
    You may wish to restart these processes.
    See 'man zypper' for information about the meaning of values in the above table.
    x3400:~ #
    No idea what this is telling me.

    BTW I tried the re-installation of the nvidia driver as you suggested and received a couple of thousand lines of text, too much to post here and grave warnings that there was a mismatch. I have saved all my console text with all the recent commands and results to one file and can upload if you remind me where please.


    Meanwhile should I try a reboot or wait until you have seen file

  7. #7

    Default Re: Forcing Use of Correct Graphics Driver

    Quote Originally Posted by Budgie2 View Post
    No idea what this is telling me.
    This is telling you that some files were updated. But some processes that are already running are still using the old versions.
    Nothing to worry about. This should disappear if you reboot.

    BTW I tried the re-installation of the nvidia driver as you suggested and received a couple of thousand lines of text, too much to post here and grave warnings that there was a mismatch.
    Well, this doesn't really sound good.
    Warnings should not matter, but if the build failed, the driver will not work.

    I have saved all my console text with all the recent commands and results to one file and can upload if you remind me where please.
    Yes, please. Upload it to any pasting/sharing site (susepaste.org e.g.) and post a link.

    Meanwhile should I try a reboot or wait until you have seen file
    Well, you could try a reboot, the worst thing that can happen is that the nvidia driver still doesn't work. It doesn't work at the moment anyway, so no real loss.
    PS: If the nvidia driver works after the reboot, there is of course no need any more to provide the output.
    Last edited by wolfi323; 13-Apr-2015 at 11:42.

  8. #8
    Join Date
    Nov 2008
    Posts
    2,161
    Blog Entries
    1

    Default Re: Forcing Use of Correct Graphics Driver

    Quote Originally Posted by wolfi323 View Post
    This is telling you that some files were updated. But some processes that are already running are still using the old versions.
    Nothing to worry about. This should disappear if you reboot.


    Well, this doesn't really sound good.
    Warnings should not matter, but if the build failed, the driver will not work.


    Yes, please. Upload it to any pasting/sharing site (susepaste.org e.g.) and post a link.


    Well, you could try a reboot, the worst thing that can happen is that the nvidia driver still doesn't work. It doesn't work at the moment anyway, so no real loss.
    PS: If the nvidia driver works after the reboot, there is of course no need any more to provide the output.
    Here is the file of the console massages:-
    http://susepaste.org/11750888

    I shall send this and then try a re-boot. Fingers crossed!!!

  9. #9
    Join Date
    Nov 2008
    Posts
    2,161
    Blog Entries
    1

    Default Re: Forcing Use of Correct Graphics Driver

    Quote Originally Posted by Budgie2 View Post
    Here is the file of the console massages:-
    http://susepaste.org/11750888

    I shall send this and then try a re-boot. Fingers crossed!!!
    Hi Wolfii,
    SUCCESS!!!
    The last re-boot has restored my system to how it was before the kernel update, thanks to you once more.

    It would however be good to understand what exactly was wrong, particularly as others seem to have the same problem. Could it have been that the default and pae modules were causing the problem?

    Many thanks once more.
    Budge

  10. #10

    Default Re: Forcing Use of Correct Graphics Driver

    Quote Originally Posted by Budgie2 View Post
    SUCCESS!!!
    The last re-boot has restored my system to how it was before the kernel update, thanks to you once more.
    ]
    Good to hear.

    Just installing the kmp package also fixed it for two other people already...

    It would however be good to understand what exactly was wrong, particularly as others seem to have the same problem.
    I don't really know, as I don't use the nvidia driver myself.

    There might be a bug in the packages so that the kernel module is not registered with the new kernel after the update, e.g.
    If there really is such a problem, somebody hopefully will create a bugreport though so that it gets fixed until the next kernel update.

    Could it have been that the default and pae modules were causing the problem?
    Maybe, maybe not.
    But that would be rather specific to your system I'd say.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •