Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 21

Thread: No sound from speakers or headphone port.

  1. #11
    Join Date
    Apr 2015
    Posts
    19

    Default Re: No sound from speakers or headphone port.

    Quote Originally Posted by oldcpu View Post
    I also noted this in your script output:
    Code:
    !!Advanced information - PCI Vendor/Device/Subsystem ID's
    !!-------------------------------------------------------
    
    00:03.0 0403: 8086:0c0c (rev 06)
        Subsystem: 1558:6557
    --
    00:1b.0 0403: 8086:8c20 (rev 05)
        Subsystem: 1558:6557
    Further to the above, likely, I will ask you to place the following at the start of that /etc/modprobe.d/50-sound.conf file (before the other lines). I am guessing that pid=08c20 is your ALC892 and the pid=0c0c is the HDMI
    Code:
    options snd_hda_intel index=0 vid=8086 pid=8c20 
    options snd_hda_intel index=1 vid=8086 pid=0c0c
    Then after making the edit, do a reboot and see if that succeeds in reversing the cards order.
    How exactly do I edit the file? Sorry, I'm such a noob

  2. #12
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    16,255

    Default Re: No sound from speakers or headphone port.

    Use any text editor. In Linux there are dozens LOL.

    I think either nano or joe is installed by default for the command line vi is always available and then ther is kate and kwriter in KDE also nice but needs to be installed is midnight commander (mc).

    In this case you need to be root to edit the file so become root in a console

    su -

    note the dash

    type the root password note the characters do not eco any thing just type the password

    then
    nano /etc/modprobe.d/50-sound.conf

    if that does not work you can either install nano or try

    joe /etc/modprobe.d/50-sound.conf

    either is a nice simple text editor with obvious help
    type exit to stop being root or just close the console

  3. #13
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,938
    Blog Entries
    40

    Default Re: No sound from speakers or headphone port.

    Quote Originally Posted by Cake View Post
    options snd slots=snd-hda-intel,snd-hda-intel
    # 3hqH.ePW4OJM81O1:Haswell HD Audio Controller
    alias snd-card-1 snd-hda-intel
    # u1Nb.R9o2zE_xLv2:Lynx Point High Definition Audio Controller
    alias snd-card-0 snd-hda-intel

    This is what shows up when I type the code in.

    In addition to gogalthorp's instruction rather than adding the two lines I suggested you could try replacing the entire content of the 50-sound.conf file with the two lines I provided.

  4. #14
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,938
    Blog Entries
    40

    Default Re: No sound from speakers or headphone port.

    Quote Originally Posted by Cake View Post
    I honestly don't know which one would be better. I'm guessing the Realtek ALC card would be better?
    Yes the Realtek is most likely better, as the HDMI is intended to drive audio on external devices (such as a TV ) if your laptop is connected to such.

  5. #15
    Join Date
    Apr 2015
    Posts
    19

    Default Re: No sound from speakers or headphone port.

    Quote Originally Posted by oldcpu View Post
    In addition to gogalthorp's instruction rather than adding the two lines I suggested you could try replacing the entire content of the 50-sound.conf file with the two lines I provided.
    Ditto. Replaced whole text with those two lines that you gave me before.

  6. #16
    Join Date
    Apr 2015
    Posts
    19

    Default Re: No sound from speakers or headphone port.

    Quote Originally Posted by gogalthorp View Post
    Use any text editor. In Linux there are dozens LOL.

    I think either nano or joe is installed by default for the command line vi is always available and then ther is kate and kwriter in KDE also nice but needs to be installed is midnight commander (mc).

    In this case you need to be root to edit the file so become root in a console

    su -

    note the dash

    type the root password note the characters do not eco any thing just type the password

    then
    nano /etc/modprobe.d/50-sound.conf

    if that does not work you can either install nano or try

    joe /etc/modprobe.d/50-sound.conf

    either is a nice simple text editor with obvious help
    type exit to stop being root or just close the console
    Nano wasn't built in but joe was. I successfully edited the file and saved it. Thanks for the instructions.

  7. #17
    Join Date
    Apr 2015
    Posts
    19

    Default Re: No sound from speakers or headphone port.

    Quote Originally Posted by Cake View Post
    Ditto. Replaced whole text with those two lines that you gave me before.
    Al-right, After I typed the two lines in I saved the file and restarted my laptop. When I pulled up yast>Hardware>Sound I saw that both cards were un-configured. So I decided to configure the Realtek card first in order to make it my first card and then I tried to test the sound of both cards and only got the "trumpets" on the second card (1). Then I went on youtube and souncloud to test the audio again, and nothing

  8. #18
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,938
    Blog Entries
    40

    Default Re: No sound from speakers or headphone port.

    Quote Originally Posted by Cake View Post
    Al-right, After I typed the two lines in I saved the file and restarted my laptop. When I pulled up yast>Hardware>Sound I saw that both cards were un-configured. So I decided to configure the Realtek card first in order to make it my first card and then I tried to test the sound of both cards and only got the "trumpets" on the second card (1). Then I went on youtube and souncloud to test the audio again, and nothing

    Do not use Yast in this case.


    Just because Yast does not recognize the configuration does not mean the sound will not work. As soon as you went to Yast and saved a configuration it will likely remove the custom entry that I had you apply. Please reapply the change to the 50-sound.conf file, reboot and test your audio in an application or with an alsa test command WITHOUT using Yast.

  9. #19
    Join Date
    Apr 2015
    Posts
    19

    Default Re: No sound from speakers or headphone port.

    Quote Originally Posted by oldcpu View Post
    Do not use Yast in this case.


    Just because Yast does not recognize the configuration does not mean the sound will not work. As soon as you went to Yast and saved a configuration it will likely remove the custom entry that I had you apply. Please reapply the change to the 50-sound.conf file, reboot and test your audio in an application or with an alsa test command WITHOUT using Yast.
    It worked on youtube and soundcloud. I now have functioning speakers. The problem is that pulseaudio won't connect to it, and I don't have a volume setting on the bottom right of my desktop bar. I only control volume through my function keys and online video/music player settings.

  10. #20
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,938
    Blog Entries
    40

    Default Re: No sound from speakers or headphone port.

    Quote Originally Posted by Cake View Post
    It worked on youtube and soundcloud. I now have functioning speakers. The problem is that pulseaudio won't connect to it, and I don't have a volume setting on the bottom right of my desktop bar. I only control volume through my function keys and online video/music player settings.
    Sound works! Good news.

    OF course pulse will not connect. Pulse is not running on your system. I pointed that out in post # 6 above.

    Wrt a volume control, you stated (?) you were using XFCE and that is an XFCE desktop issue and you need an XFCE desktop user to help you there!

Page 2 of 3 FirstFirst 123 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •