Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Getting wireless to work under IceWM, or when not logged in.

  1. #1

    Default Getting wireless to work under IceWM, or when not logged in.

    When I log in using KDE, wireless works fine, but when I log in using IceWM (which I prefer), I've no wireless. All of the information I can find on the net says to open NetworkManager in the system tray, but this option doesn't appear under IceWM.

    For that matter: my Linux box is also a Samba server, and I'd like for Wifi to be configured and active whenever the box is up and can find the Wifi router, even if I'm not logged on.

    --
    James Kanze

  2. #2

    Default Re: Getting wireless to work under IceWM, or when not logged in.

    Quote Originally Posted by kanze View Post
    When I log in using KDE, wireless works fine, but when I log in using IceWM (which I prefer), I've no wireless. All of the information I can find on the net says to open NetworkManager in the system tray, but this option doesn't appear under IceWM.
    You should be able to use the KDE or GNOME applets in IceWM too. Either run "plasma-windowed org.kde.networkmanagement" or "nm-applet" respectively.
    And there are text mode clients: nmtui and nmcli.

    For that matter: my Linux box is also a Samba server, and I'd like for Wifi to be configured and active whenever the box is up and can find the Wifi router, even if I'm not logged on.
    That's easy: just configure the connection as "system connection", i.e. enable the option "Allow all users to connect". The connection will then be established during boot already, and should be available when you login even in text mode.

    Another option would be to switch to Wicked Service instead of NetworkManager. But then you have to set up the connection in YaST.

    Both options would also apply to IceWM of course.
    Last edited by wolfi323; 03-Apr-2015 at 05:55.

  3. #3
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    11,794
    Blog Entries
    3

    Default Re: Getting wireless to work under IceWM, or when not logged in.

    Quote Originally Posted by kanze View Post
    When I log in using KDE, wireless works fine, but when I log in using IceWM (which I prefer), I've no wireless. All of the information I can find on the net says to open NetworkManager in the system tray, but this option doesn't appear under IceWM.
    I'm not sure if I have tested this with 13.2.

    My file "$HOME/.icewm/startup" (runs automatically on icewm startup) contains, among other lines:

    Code:
    /usr/lib/polkit-gnome-authentication-agent-1 &
    
    nm-applet &
    That gives me an icon in the tray for configuring wifi. You would probably have to install those. Maybe you can do the equivalent with the KDE applet. While I normally use KDE, I prefer the Gnome applet for NetworkManager, because the KDE applet is going to open "kdewallet".

    "nm-applet" comes from the package NetworkManager-gnome, and the polkit program comes from polkit-gnome.
    openSUSE Leap 15.0; KDE Plasma 5;
    testing Leap 15.1.

  4. #4

    Default Re: Getting wireless to work under IceWM, or when not logged in.

    Quote Originally Posted by nrickert View Post
    I'm not sure if I have tested this with 13.2.

    My file "$HOME/.icewm/startup" (runs automatically on icewm startup) contains, among other lines:

    Code:
    /usr/lib/polkit-gnome-authentication-agent-1 &
    
    nm-applet &
    That gives me an icon in the tray for configuring wifi. You would probably have to install those. Maybe you can do the equivalent with the KDE applet. While I normally use KDE, I prefer the Gnome applet for NetworkManager, because the KDE applet is going to open "kdewallet".

    "nm-applet" comes from the package NetworkManager-gnome, and the polkit program comes from polkit-gnome.
    Thanks. This works for IceWM. (I had to chmod -x the file. I hadn't realized this, and lost a little time figuring out why it wasn't getting executed.) I still have to enter the password each time, however. There must be some way of getting the system to memorize it.

    --
    James Kanze

  5. #5

    Default Re: Getting wireless to work under IceWM, or when not logged in.

    Quote Originally Posted by kanze View Post
    Thanks. This works for IceWM. (I had to chmod -x the file. I hadn't realized this, and lost a little time figuring out why it wasn't getting executed.) I still have to enter the password each time, however. There must be some way of getting the system to memorize it.
    AFAIK, nm-applet uses gnome-keyring to store the password, so you probably have to start this too first.

    Or, set up the connection as "system connection" as I already suggested, then the password will be stored by NetworkManager itself in /etc/NetworkManager, and you don't even need a NetworkManager frontend (or login at all) to connect.

  6. #6

    Default Re: Getting wireless to work under IceWM, or when not logged in.

    Quote Originally Posted by wolfi323 View Post
    You should be able to use the KDE or GNOME applets in IceWM too. Either run "plasma-windowed org.kde.networkmanagement" or "nm-applet" respectively.
    And there are text mode clients: nmtui and nmcli.
    Adding the commands in .icewm/startup seems to solve this issue.

    [QUOTE=wolfi323;2702964]
    That's easy: just configure the connection as "system connection", i.e. enable the option "Allow all users to connect". The connection will then be established during boot already, and should be available when you login even in text mode.
    /QUOTE]

    I don't seem to have any such option. I do have an option to store the password either for just this user, or for all users, but regardless of what I select, the password isn't stored, and I have to enter it each time.

    Getting it to connect on start-up isn't essential; I don't use the samba server that much, and I can just log in when I want to use it. (To tell the truth, I'm not happy about the idea of running a server of any kind over Wifi, which can come and go.) On the other hand, I would very much like to not have to re-enter the password each time.

    --
    James Kanze

  7. #7

    Default Re: Getting wireless to work under IceWM, or when not logged in.

    Quote Originally Posted by kanze View Post
    I don't seem to have any such option. I do have an option to store the password either for just this user, or for all users, but regardless of what I select, the password isn't stored, and I have to enter it each time.
    The option is called "All users may connect to this network" in nm-applet. If you enable this the password should be stored system-wide and the connection will be established during boot already.
    I have the wireless connections on all my systems configured that way, works fine since years...

    You might have to enter the password in nm-applet's connection editor directly for it to be saved, no idea. I always use KDE's applet to setup my connections.
    You could use that as well, in particular for a system connection it doesn't matter anyway how you set it up. You can use all the NetworkManager frontends interchangeably (only the password storage for user connection is handled by the applet itself and different between them).

  8. #8
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    11,794
    Blog Entries
    3

    Default Re: Getting wireless to work under IceWM, or when not logged in.

    Quote Originally Posted by wolfi323 View Post
    AFAIK, nm-applet uses gnome-keyring to store the password, so you probably have to start this too first.
    Actually, no. It used to do that. But at present it is stored in "/etc/NetworkManager/system-connections" but flagged to be for the particular user (unless set as a system connection). And the polkit agent seems to handle the permissions needed, without any special authentication prompts.

    I have not checked this with the newest NetworkManager for Gnome 3.16.
    openSUSE Leap 15.0; KDE Plasma 5;
    testing Leap 15.1.

  9. #9

    Default Re: Getting wireless to work under IceWM, or when not logged in.

    Quote Originally Posted by nrickert View Post
    Actually, no. It used to do that. But at present it is stored in "/etc/NetworkManager/system-connections" but flagged to be for the particular user (unless set as a system connection).
    Well, when I last used nm-applet in IceWM on 13.2 and tried to connect to a VPN (which I configured as user connection in KDE), ot asked me for the gnome-keyring password... (and it didn't accept my user password nor an empty one so I had to cancel and use KDE's plasmoid instead)

    But you are talking about Tumbleweed, right?

    And the polkit agent seems to handle the permissions needed, without any special authentication prompts.
    Yes, polkit is desktop-agnostic. And the "authentication agent" is mainly needed for presenting a (root) password dialog I think.
    Anyway, you could also run /usr/lib64/kde4/libexec/polkit-kde-authentication-agent-1 if you prefer the KDE dialog, even if you intend to use nm-applet...

    I have not checked this with the newest NetworkManager for Gnome 3.16.
    Me neither.

  10. #10
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    11,794
    Blog Entries
    3

    Default Re: Getting wireless to work under IceWM, or when not logged in.

    Quote Originally Posted by wolfi323 View Post
    But you are talking about Tumbleweed, right?
    My most recent test was with Tumbleweed, but before the latest NetworkManager release.

    In practice, I set my connections to be system-connections, so I don't see the problems that people. However, in earlier trials in Tumbleweed, in opensuse 13.1, and I think in 13.2, after setting up a connect in Gnome, I see the network key saved in "/etc/NetworkManager/system-connections", with a tag indicating the user that set it up. I don't see anything related in Gnome keyring. And, if I set it up in Gnome (for just the one user), it continues to work for that user in Icewm and (I think) in KDE. But that isn't the way that KDE normally sets it up. Normally, KDE puts the key in kwallet.

    I can't really compare what I am doing with the OPs problem, because I do have Gnome installed and maybe there's an additional part of Gnome needed that I wasn't aware of.
    openSUSE Leap 15.0; KDE Plasma 5;
    testing Leap 15.1.

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •