Page 2 of 2 FirstFirst 12
Results 11 to 18 of 18

Thread: Remote Administration help

  1. #11

    Default Re: Remote Administration help

    PS: in particular you should have the option "-securitytypes none" on the server command line, if you want to connect without a password.
    But as mentioned, that should be there by default in /etc/xinetd.d/vnc. I just checked and 12.3 shipped with this:
    Code:
    service vnc1
    {
        type        = UNLISTED
        port        = 5901
        socket_type    = stream
        protocol    = tcp
        wait        = no
        user        = nobody
        server        = /usr/bin/Xvnc
        server_args    = -noreset -inetd -once -query localhost -geometry 1024x768 -depth 16 -securitytypes none
    }
    If you have something different, change it accordingly, either in /etc/xinetd.d/vnc directly, or via YaST->Network Services->Network Services (Xinetd) as mentioned.

    If that doesn't help, you should probably tell how you are actually starting the VNC server for further help.

  2. #12

    Default Re: Remote Administration help

    Quote Originally Posted by wolfi323 View Post
    If you just enabled "Allow Remote Administration" in YaST, you should not be asked for a VNC password. You should be able to connect to port 5901 via VNC, or 5801 via HTTP, and get a normal login screen.

    If that doesn't work, have a look at the server options for vnc or vnchttpd1 in YaST->Network Services-> Network Services (Xinetd).
    But it should work like that (without a root password) with the defaults shipped in openSUSE, even on 12.3 (which is out of support since January btw).

    I've tried a bunch of different things so far including adding securitytypes=none, the vncpasswd and combo's of both. Firewall is off also.

    Where/how did you do that?

    Used vncpasswd command

    Well, you didn't really tell what you actually did...
    Sorry, just enabled the service in yast like the documentation tells you to do and as you mention above.

    Not sure what else to try on this except I've read a few posts stating that 12.2 worked fine until upgrade to 12.3.

  3. #13

    Default Re: Remote Administration help

    Quote Originally Posted by wolfi323 View Post
    If you just enabled "Allow Remote Administration" in YaST, you should not be asked for a VNC password. You should be able to connect to port 5901 via VNC, or 5801 via HTTP, and get a normal login screen.

    If that doesn't work, have a look at the server options for vnc or vnchttpd1 in YaST->Network Services-> Network Services (Xinetd).
    But it should work like that (without a root password) with the defaults shipped in openSUSE, even on 12.3 (which is out of support since January btw).


    Where/how did you do that?


    Well, you didn't really tell what you actually did...
    Quote Originally Posted by wolfi323 View Post
    PS: in particular you should have the option "-securitytypes none" on the server command line, if you want to connect without a password.
    But as mentioned, that should be there by default in /etc/xinetd.d/vnc. I just checked and 12.3 shipped with this:
    Code:
    service vnc1
    {
        type        = UNLISTED
        port        = 5901
        socket_type    = stream
        protocol    = tcp
        wait        = no
        user        = nobody
        server        = /usr/bin/Xvnc
        server_args    = -noreset -inetd -once -query localhost -geometry 1024x768 -depth 16 -securitytypes none
    }
    If you have something different, change it accordingly, either in /etc/xinetd.d/vnc directly, or via YaST->Network Services->Network Services (Xinetd) as mentioned.

    If that doesn't help, you should probably tell how you are actually starting the VNC server for further help.
    That is what the conf file looked like with the exception of -securitytypes none was not entered. I entered that myself and I got further in the process, to the gnome gui screen where I can login. It doesn't matter if I choose and existing user or not listed, either browser based or tightvnc, I never get a password prompt. I had the setting set to -securitytypes=none (with the = sign)!

  4. #14

    Default Re: Remote Administration help

    Quote Originally Posted by shesser View Post
    That is what the conf file looked like with the exception of -securitytypes none was not entered.
    Well, that's a config file.
    If you (or some program, including YaST) modified it earlier, it will not be updated, and the options might not be ok for the current version.

    It doesn't matter if I choose and existing user or not listed, either browser based or tightvnc, I never get a password prompt. I had the setting set to -securitytypes=none (with the = sign)!
    Ok. So you get the login screen now, but login itself doesn't work?
    Just to make sure: you cannot login with a user that's already logged in. Maybe that's the problem now?

  5. #15

    Default Re: Remote Administration help

    This was a fresh install of 12.3. I org. enabled vnc via yast. Yes I do get to the gui login. There are no other users logged in when I connect. I have used both root and another user that's on this box. I never get a login prompt on either user when attempting. I've seen others on the forum with the same issue with this version. Never had an issue with ver. 11. Tried 13.2 which didn't seem to work. Hardware is an HP desktop 6000. I can't imagine it's hw related. About the only thing is from the netwok standpoint, It's on a vlan segment that's routed to the main segment where the ws I'm using to vnc from is located. All ports are open from one segment to the other. Going to try the 12.2 version. The other posts referred to .2 working fine.

  6. #16

    Default Re: Remote Administration help

    Quote Originally Posted by shesser View Post
    This was a fresh install of 12.3. I org. enabled vnc via yast. Yes I do get to the gui login. There are no other users logged in when I connect. I have used both root and another user that's on this box. I never get a login prompt on either user when attempting. I've seen others on the forum with the same issue with this version. Never had an issue with ver. 11. Tried 13.2 which didn't seem to work. Hardware is an HP desktop 6000. I can't imagine it's hw related. About the only thing is from the netwok standpoint, It's on a vlan segment that's routed to the main segment where the ws I'm using to vnc from is located. All ports are open from one segment to the other. Going to try the 12.2 version. The other posts referred to .2 working fine.
    Should be I never get a password prompt on either user when attempting

  7. #17

    Default Re: Remote Administration help

    Just got done installing 12.2, patched it up and VNC works fine by just enabling it during the install. So what ever changes they did in 12.3, for some reason for some of us, it does not function correctly.

  8. #18

    Default Re: Remote Administration help

    Quote Originally Posted by shesser View Post
    Should be I never get a password prompt on either user when attempting
    ???
    Of course you don't get a password prompt after you logged in.
    Or do you not even get a password prompt on the login screen?

    What display manager are you even using? Sounds like GDM.
    You might try something different, but the login screen is working now, right?

    Quote Originally Posted by shesser View Post
    Just got done installing 12.2, patched it up and VNC works fine by just enabling it during the install. So what ever changes they did in 12.3, for some reason for some of us, it does not function correctly.
    Well, "they" didn't change anything regarding this AFAIK.
    But of course 12.2 and 12.3 ship with different software versions (not only VNC but also Xorg and so on).

    Why don't you just stay with 12.2 if it is working there? 12.3 is old and out of support already too as mentioned, so I don't really see a point in using that instead.

    And try to login to a different desktop session (IceWM should be installed by default).
    I know for a fact that KDE (and other Qt4 based applications) can have problems via VNC.
    Also if one of the involved hosts has some proprietary driver installed, this can lead to problems as well, as that breaks Mesa and the software 3D renderer (would definitely break GNOME I suppose, but can lead to problems with KDE as well).

    Your problem might be that the DE crashes, not directly something wrong with VNC itself.
    Last edited by wolfi323; 02-May-2015 at 08:38.

Page 2 of 2 FirstFirst 12

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •