Results 1 to 7 of 7

Thread: I can't update

  1. #1

    Exclamation I can't update

    hey, opensuse noob here. How do I get rid of this message so I can update? http://i.imgur.com/UJScKmF.png

  2. #2

    Default Re: I can't update

    Quote Originally Posted by youyouryoursyourself View Post
    hey, opensuse noob here. How do I get rid of this message so I can update? http://i.imgur.com/UJScKmF.png
    You apparently installed libfreetype from some 3rd party repo, so you cannot install the libfreetype patch.
    Deselect it, and you should be able to install the other updates.

    Please run "zypper patch" and post the output to get more information about the conflict.

    And please post your repo list as well:
    Code:
    zypper lr -d

  3. #3

    Default Re: I can't update

    Quote Originally Posted by wolfi323 View Post
    You apparently installed libfreetype from some 3rd party repo, so you cannot install the libfreetype patch.
    Deselect it, and you should be able to install the other updates.

    Please run "zypper patch" and post the output to get more information about the conflict.

    And please post your repo list as well:
    Code:
    zypper lr -d
    zypper lr -d
    Code:
    #  | Alias                     | Name                               | Enabled | Refresh | Priority | Type   | URI                                                                         | Service---+---------------------------+------------------------------------+---------+---------+----------+--------+-----------------------------------------------------------------------------+--------
     1 | Google-Chrome             | Google-Chrome                      | Yes     | No      |   99     | rpm-md | http://dl.google.com/linux/chrome/rpm/stable/x86_64                         |        
     2 | ftp.gwdg.de-suse          | Packman Repository                 | Yes     | Yes     |   99     | rpm-md | http://ftp.gwdg.de/pub/linux/packman...openSUSE_13.2/                    |        
     3 | google-chrome             | google-chrome                      | Yes     | Yes     |   99     | rpm-md | http://dl.google.com/linux/chrome/rpm/stable/x86_64                         |        
     4 | openSUSE-13.2-0           | openSUSE-13.2-0                    | Yes     | No      |   99     | yast2  | cd:///?devices=/dev/disk/by-id/ata-MATSHITADVD-RAM_UJ8B0_YL98_426674        |        
     5 | opensuse-guide.org-repo   | libdvdcss repository               | Yes     | Yes     |   99     | rpm-md | http://opensuse-guide.org/repo/13.2/                                        |        
     6 | repo-debug                | openSUSE-13.2-Debug                | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/debug/d...13.2/repo/oss/              |        
     7 | repo-debug-update         | openSUSE-13.2-Update-Debug         | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/debug/update/13.2/                             |        
     8 | repo-debug-update-non-oss | openSUSE-13.2-Update-Debug-Non-Oss | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/debug/update/13.2-non-oss/                     |        
     9 | repo-non-oss              | openSUSE-13.2-Non-Oss              | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distrib.../repo/non-oss/                |        
    10 | repo-oss                  | openSUSE-13.2-Oss                  | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distrib...13.2/repo/oss/                    |        
    11 | repo-source               | openSUSE-13.2-Source               | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/source/...13.2/repo/oss/             |        
    12 | repo-update               | openSUSE-13.2-Update               | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/update/13.2/                                   |        
    13 | repo-update-non-oss       | openSUSE-13.2-Update-Non-Oss       | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/update/13.2-non-oss/                           |        
    14 | subpixel                  | subpixel                           | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/reposit...nSUSE_Factory/ |

  4. #4

    Default Re: I can't update

    And nothing happened when I pressed "run zypper patch"

  5. #5
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,742

    Default Re: I can't update

    it is zypper patch not run zypper patch



    You could go into yast - software management search for libfreetype and see what is what in the version tab at bottom right

    BTW that is a FONT and as such general not considered critical.

  6. #6

    Default Re: I can't update

    Quote Originally Posted by gogalthorp View Post
    it is zypper patch not run zypper patch



    You could go into yast - software management search for libfreetype and see what is what in the version tab at bottom right

    BTW that is a FONT and as such general not considered critical.
    Ah, apparently we access the zypper patch in the terminal because the application launcher had "run zypper patch" and not "zypper patch."
    It's finally updating again. Thank you guys for your help!

  7. #7

    Default Re: I can't update

    Quote Originally Posted by gogalthorp View Post
    BTW that is a FONT and as such general not considered critical.
    libfreetype is not a font at all.
    It is a library that applications (and the system) use to load fonts.

    And that error is of course also preventing the installation of all other updates...

    Quote Originally Posted by youyouryoursyourself View Post
    Ah, apparently we access the zypper patch in the terminal because the application launcher had "run zypper patch" and not "zypper patch."
    ??? I don't understand that.
    The "application launcher" does not have zypper at all.

    And the update applet doesn't run zypper either (and definitely not "run zypper patch"... ).

    As I already said, you probably installed libfreetype from some other repo, likely #12 in your list ("subpixel").
    The problem is that this repo contains a lower version of libfreetype (2.4.11 vs. 2.5.3 in the standard repos), so that patch is trying to be installed, which fails because your packages are from another repo (an update doesn't switch packages to versions from another repo by default).

    If you still get that error message, you should probably lock that patch. Please ask again in that case, and I'll explain to you how.
    Last edited by wolfi323; 02-Apr-2015 at 02:29.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •