Results 1 to 10 of 10

Thread: Yast2 problem

  1. #1

    Default Yast2 problem

    Hello community,

    i am having a problem for a long time and i want to fix it. Whenever i try to run the "boot loader" or the "partitioner" i'm getting following error message:

    Out of memory!
    YaST got signal 11 at YCP file Storage.ycp:1842
    /sbin/yast2: line 431: 4827 Segmentation fault $ybindir/y2base $module "$@" "$SELECTED_GUI" $Y2_GEOMETRY $Y2UI_ARGS
    My system is up-to-date and i have 20gigs of free space.

    Also an other question just popped up: whenever i try to update there is a message which says
    "The following package updates will NOT be installed: package X, package Y..."
    Are there no updates or are there updates and zypper just don't want to install them?

    cheers

  2. #2
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,703

    Default Re: Yast2 problem

    Well second question first

    That is normal that some package my no be upgraded because it would require a vendor change. ie your current vendor (repo) for the may not have the newest package available.

    As to the first it sounds like you may have mixed packages of something. Maybe show us your repos. zypper lr -d

  3. #3

    Default Re: Yast2 problem

    zypper lr -d output:

    Code:
    #  | Alias                         | Name                              | Enabled | Refresh | Priority | Type   | URI                                                                                     | Service
    ---+-------------------------------+-----------------------------------+---------+---------+----------+--------+-----------------------------------------------------------------------------------------+--------
     1 | KDE:Extra                     | KDE:Extra                         | No      | Yes     |   99     | rpm-md | http://download.opensuse.org/reposit...openSUSE_12.3/                     |        
     2 | devel:languages:perl          | devel:languages:perl              | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/reposit...openSUSE_13.1/         |        
     3 | devel:languages:perl:CPAN-B   | devel:languages:perl:CPAN-B       | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/reposit...openSUSE_13.1/ |        
     4 | download.opensuse.org-Extra   | openSUSE BuildService - KDE:Extra | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/reposit...openSUSE_13.1/                     |        
     5 | download.opensuse.org-KDE3    | openSUSE BuildService - KDE:KDE3  | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/reposit...openSUSE_13.1/                      |        
     6 | download.opensuse.org-games   | openSUSE BuildService - Games     | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/reposit...openSUSE_13.1/                          |        
     7 | download.opensuse.org-non-oss | Main Repository (NON-OSS)         | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distrib.../repo/non-oss/                            |        
     8 | download.opensuse.org-oss     | Main Repository (OSS)             | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distrib...13.1/repo/oss/                                |        
     9 | download.opensuse.org-oss_1   | Main Repository (Sources)         | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/source/...13.1/repo/oss/                         |        
    10 | download.opensuse.org-update  | Main Update Repository            | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/update/13.1/                                               |        
    11 | ftp.gwdg.de-suse              | Packman Repository                | Yes     | Yes     |   99     | rpm-md | http://ftp.gwdg.de/pub/linux/packman...openSUSE_12.3/                                |        
    12 | games                         | games                             | No      | Yes     |   99     | rpm-md | http://download.opensuse.org/reposit...openSUSE_12.2/                          |        
    13 | games:tools                   | games:tools                       | No      | Yes     |   99     | rpm-md | http://download.opensuse.org/reposit...openSUSE_12.3/                   |        
    14 | google-chrome                 | google-chrome                     | Yes     | Yes     |   99     | rpm-md | http://dl.google.com/linux/chrome/rpm/stable/x86_64                                     |        
    15 | hardware                      | hardware                          | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/reposit...openSUSE_13.1/                       |        
    16 | home:4144                     | home:4144                         | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/reposit...openSUSE_12.2/                     |        
    17 | home:Kieltux:Netbeans         | home:Kieltux:Netbeans             | No      | Yes     |   99     | rpm-md | http://download.opensuse.org/reposit...openSUSE_12.3/        |        
    18 | home:NarkoZ:Nightlies         | home:NarkoZ:Nightlies             | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/reposit...openSUSE_13.1/        |        
    19 | hom:opensuse_zh              | home:opensuse_zh                  | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/reposit...openSUSE_13.1/              |

  4. #4
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Yast2 problem

    On 2015-05-02 21:46, CosmicAlien wrote:
    >
    > zypper lr -d output:
    >
    >
    > Code:
    > --------------------
    > # | Alias | Name | Enabled | Refresh | Priority | Type | URI | Service
    > ---+-------------------------------+-----------------------------------+---------+---------+----------+--------+-----------------------------------------------------------------------------------------+--------
    > 1 | KDE:Extra | KDE:Extra | No | Yes | 99 | rpm-md | http://download.opensuse.org/reposit...openSUSE_12.3/ |
    > 2 | devel:languageserl | devel:languageserl | Yes | Yes | 99 | rpm-md | http://tinyurl.com/mz5f7j6 |
    > 3 | devel:languageserl:CPAN-B | devel:languageserl:CPAN-B | Yes | Yes | 99 | rpm-md | http://tinyurl.com/q7xvfkb |
    > 4 | download.opensuse.org-Extra | openSUSE BuildService - KDE:Extra | Yes | Yes | 99 | rpm-md | http://download.opensuse.org/reposit...openSUSE_13.1/ |
    > 5 | download.opensuse.org-KDE3 | openSUSE BuildService - KDE:KDE3 | Yes | Yes | 99 | rpm-md | http://download.opensuse.org/reposit...openSUSE_13.1/ |
    > 6 | download.opensuse.org-games | openSUSE BuildService - Games | Yes | Yes | 99 | rpm-md | http://download.opensuse.org/reposit...openSUSE_13.1/ |
    > 7 | download.opensuse.org-non-oss | Main Repository (NON-OSS) | Yes | Yes | 99 | yast2 | http://download.opensuse.org/distrib.../repo/non-oss/ |
    > 8 | download.opensuse.org-oss | Main Repository (OSS) | Yes | Yes | 99 | yast2 | http://download.opensuse.org/distrib...13.1/repo/oss/ |
    > 9 | download.opensuse.org-oss_1 | Main Repository (Sources) | Yes | Yes | 99 | yast2 | http://download.opensuse.org/source/...13.1/repo/oss/ |
    > 10 | download.opensuse.org-update | Main Update Repository | Yes | Yes | 99 | rpm-md | http://download.opensuse.org/update/13.1/ |
    > 11 | ftp.gwdg.de-suse | Packman Repository | Yes | Yes | 99 | rpm-md | http://ftp.gwdg.de/pub/linux/packman...openSUSE_12.3/ |
    > 12 | games | games | No | Yes | 99 | rpm-md | http://download.opensuse.org/reposit...openSUSE_12.2/ |
    > 13 | games:tools | games:tools | No | Yes | 99 | rpm-md | http://download.opensuse.org/reposit...openSUSE_12.3/ |
    > 14 | google-chrome | google-chrome | Yes | Yes | 99 | rpm-md | http://dl.google.com/linux/chrome/rpm/stable/x86_64 |
    > 15 | hardware | hardware | Yes | Yes | 99 | rpm-md | http://download.opensuse.org/reposit...openSUSE_13.1/ |
    > 16 | home:4144 | home:4144 | Yes | Yes | 99 | rpm-md | http://download.opensuse.org/reposit...openSUSE_12.2/ |
    > 17 | home:Kieltux:Netbeans | home:Kieltux:Netbeans | No | Yes | 99 | rpm-md | http://tinyurl.com/mroybaf |
    > 18 | home:NarkoZ:Nightlies | home:NarkoZ:Nightlies | Yes | Yes | 99 | rpm-md | http://tinyurl.com/nua7vzn |
    > 19 | hompensuse_zh | homepensuse_zh | Yes | Yes | 99 | rpm-md | http://tinyurl.com/lu2t9zv |
    >
    >
    > --------------------


    Something wrong with your paste, because some of the URLs got
    shorthened. But I see that some of them point to 12.3, 12.2... Some I
    can not even see.


    --
    Cheers / Saludos,

    Carlos E. R.

    (from 13.1 x86_64 "Bottle" (Minas Tirith))

  5. #5
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,144
    Blog Entries
    2

    Default Re: Yast2 problem

    First,
    I recommend you do some housekeeping, it looks like you upgraded from 12.3 and are now running 13.1.

    It's probably time to remove your 12.3 and 12.2 repos, but you may first want to determine if you want to enable the 13.1 versions of those repos.
    The benefit to simply disabling and not removing a repo when upgrading is that you can "try" new paths to repos that contain correct packages for your upgraded openSUSE without risk and with only minimal effort.

    So, for example your KDE:Extra repo currently has a path that points to 12.3 packages. Using the path described for that repo, enter into a web browser but change from "12.3" to 13.1" and see if the path is good. Typically the path will be good and you can create your new repo (the following is the zypper syntax to create a repo)
    Code:
    zypper ar <path> <Your human readable name of the repo>
    After you're done adding your new working repos for 13.1,
    The following command removes your old repos that might cause problems
    Code:
    zypper rr 1 11 12 13 16 17
    HTH,
    TSU

  6. #6

    Angry Re: Yast2 problem

    wtf
    it updated automatically to 13.1 and then i have to adjust the repos on my own....


  7. #7
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,144
    Blog Entries
    2

    Default Re: Yast2 problem

    Quote Originally Posted by CosmicAlien View Post
    wtf
    it updated automatically to 13.1 and then i have to adjust the repos on my own....

    In openSUSE (unlike many other distros) there is a big difference between "upgrade" and "update."
    Upgrade = Major change to a different major OS version. Typically to latest stable but in general whatever repos are configured.
    Update = You don't leave the current OS version. You replace individual packages, libraries and apps with whatever is latest but only within the restriction of your current OS version which doesn't change.

    So, "automatically" in this case suggests a mistake. If you are maintaining your system using zypper (command line) the difference is a single letter...

    Simple Maintenance updating only the packages and not your OS version
    Code:
    zypper up
    Major upgrade changing OS versions. Generally requires manual repo revisions.
    Code:
    zypper dup
    If your "automatic" accident happened some other way... I dunno...

    TSU

  8. #8
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Yast2 problem

    On 2015-05-02 22:56, CosmicAlien wrote:
    >
    > wtf
    > it updated automatically to 13.1 and then i have to adjust the repos on
    > my own....
    >
    >>


    :-?

    Repositories can not change automatically.

    --
    Cheers / Saludos,

    Carlos E. R.

    (from 13.1 x86_64 "Bottle" (Minas Tirith))

  9. #9
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,703

    Default Re: Yast2 problem

    That's what I thought you have mixed repos and there by have mixed program versions. All repos must point to the correct version. I don't think that the instruction on the page you reference goes far enough and assume you understand about repos.

    When moving to a new OS version it is best to do things in 2 steps first disable all except the base repos being sure all point to the new version. Do the zypper dup to move the system to the new then re-enable any addition repos again being sure they point to the correct version and do a zypper up This should bring all over and not drag in unwanted/needed stuff.


    Note: in Linux you are in charge the programs will only do exactly what you tell them. You tell them to do something wrong or forget to tell them everything you will not be where you expected to be.

  10. #10

    Default Re: Yast2 problem

    zypper dup solved my problem, thank you.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •