Results 1 to 2 of 2

Thread: opensuse 13.2 - ocfs2 problem - node disconnects

  1. #1

    Default opensuse 13.2 - ocfs2 problem - node disconnects

    Hi,
    I'm running out of an ideas. I've two machines with opensuse 13.2, drbd replication to /srv and /imap (primary/primary).
    On 1st node all works fine. I prepared 2nd node, drbd works fine, connected, synced or so.
    So I decided to mount /srv and /var/spool/imap on node 2. And I couldn't to. In the syslog I see an error about disconnecting node from cluster and node 2 restarted. After many attempts and self reboot I thought that there is a bad instalation, bad disk, bad PC, ...
    So I've restarted both nodes and mounted and started the service only on node 2. On this node 2 now all works fine and the problem described above moved to node 1 . So what did i missed ? I use ocfs from standard suse's repo:

    rpm -qa | grep ocfs
    ocfs2-tools-1.8.2+git.1361836695.ff84eb5-11.1.4.x86_64
    ocfs2-tools-o2cb-1.8.2+git.1361836695.ff84eb5-11.1.4.x86_64


    A message :
    [ 241.169712] o2net: Accepted connection from node email52 (num 2) at 192.168.112.107:7777
    [ 244.612832] o2net: Connection to node email52 (num 2) at 192.168.112.107:7777 shutdown, state 8
    [ 244.613195] o2net: No longer connected to node email52 (num 2) at 192.168.112.107:7777
    [ 244.613258] (mount.ocfs2,1416,0):dlm_send_nodeinfo:1294 ERROR: node mismatch -112, node 2
    [ 244.613341] (mount.ocfs2,1416,0):dlm_try_to_join_domain:1681 ERROR: status = -112
    [ 244.613411] (mount.ocfs2,1416,0):dlm_send_one_join_cancel:1399 ERROR: Error -107 when sending message 512 (key 0x666c6172) to node 2
    [ 244.613486] (mount.ocfs2,1416,0):dlm_send_join_cancels:1433 ERROR: Error return -107 cancelling join on node 2
    [ 244.613549] (mount.ocfs2,1416,0):dlm_send_join_cancels:1440 ERROR: status = -107
    [ 244.613625] (mount.ocfs2,1416,0):dlm_try_to_join_domain:1718 ERROR: status = -107
    [ 244.613676] (mount.ocfs2,1416,0):dlm_join_domain:1951 ERROR: status = -112
    [ 244.613812] (mount.ocfs2,1416,0):dlm_register_domain:2209 ERROR: status = -112
    [ 244.613877] (mount.ocfs2,1416,0)2cb_cluster_connect:368 ERROR: status = -112
    [ 244.613928] (mount.ocfs2,1416,0)cfs2_dlm_init:3001 ERROR: status = -112
    [ 244.615066] (mount.ocfs2,1416,0)cfs2_mount_volume:1860 ERROR: status = -112
    [ 244.615156] ocfs2: Unmounting device (147,0) on (node 0)
    [ 244.615166] (mount.ocfs2,1416,0)cfs2_fill_super:1234 ERROR: status = -112





    cluster config :
    cluster:
    node_count = 2
    name = o2cb

    node:
    ip_port = 7777
    ip_address = 192.168.112.107
    number = 2
    name = email52
    cluster = o2cb

    node:
    ip_port = 7777
    ip_address = 192.168.112.106
    number = 1
    name = email51
    cluster = o2cb


    Thanks for the anothers ideas
    Best regards
    J.Karliak

  2. #2

    Default Re: opensuse 13.2 - ocfs2 problem - node disconnects [SOLVED]

    Hi there,
    problem was in the kernel - after downgrading to 3.14.33x all works fine
    Best regards
    J.Karlliak

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •