Results 1 to 5 of 5

Thread: wrong printing with gutenprint driver

  1. #1
    Join Date
    Sep 2009
    Posts
    48

    Default wrong printing with gutenprint driver

    I'm running openoffice 4.1.1 with opensuse 13.2, using the kernel 3.16.7-7-default. When I try to print an A4 page it is printed on two pages , the left half of the page first and the right half of the page on the following sheet. However, if I choose the format 'letter' it is printed correctly. Has anyone else had this problem and found a solution? The printer is an Epson Stylus C110.
    It also doesn't print any color pictures, only in gray shades.

  2. #2
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,163
    Blog Entries
    1

    Default Re: wrong printing with gutenprint driver

    Quote Originally Posted by gm40 View Post
    I'm running openoffice 4.1.1 with opensuse 13.2, using the kernel 3.16.7-7-default. When I try to print an A4 page it is printed on two pages , the left half of the page first and the right half of the page on the following sheet. However, if I choose the format 'letter' it is printed correctly. Has anyone else had this problem and found a solution? The printer is an Epson Stylus C110.
    It also doesn't print any color pictures, only in gray shades.
    Did you set the default paper size for the printer? FWIW, this gets set in the .ppd file in the /etc/cups/ppd/ directory. You can check this via the CUPS web interface to

    http://localhost:631/printers

    Select the printer concerned > Administration > Set Default Options (It depends on the PPD as to the available options)

  3. #3

    Default Re: wrong printing with gutenprint driver

    And try to reinstall cups-filters-ghostscript.
    Code:
    sudo zypper in -f cups-filters-ghostscript
    AFAIK there can be problems like you describe if that has been installed _before_ cups.

  4. #4
    Join Date
    Sep 2009
    Posts
    48

    Default Re: wrong printing with gutenprint driver

    Sorry for responding so late. I'm having endless problems with either my hardware or KDE 4.14.6. It was never that unstable, particularly at boot time.
    Anyway, following your advice I deinstalled cup-filter-ghostscript and reinstalled it without any change in the outcome. When page format is set to A4 it's only printing half of a page on two pages while it woks correctly when page format is set to 'letters'. There is also no way it would print in color. All this was no issue under 13.1. Thanks for any comments!

  5. #5
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,163
    Blog Entries
    1

    Default Re: wrong printing with gutenprint driver

    1. Can you confirm that a printing a test page is successful with colour printing?
    http://localhost:631/printers
    Select printer, then Maintenance > Print Test Page

    2. Is it only when printing from LO that this printing issue exists? If so, check page format settings via Format > Page... > Page > Format (A4 set?)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •