Results 1 to 2 of 2

Thread: 13.2 VNC is not working - only displays black box with x11 3 check boxes

  1. #1

    Default 13.2 VNC is not working - only displays black box with x11 3 check boxes

    Hi,
    I believe I have followed all the setup items I need to setup VNC. The things I used to do with 12.x WORKED - but all I get is a black box with 3 checkboxes
    "Accept clipboard from viewers'
    "Send clipboard to viewers"
    "Send primary select to viewers"

    when I follow the same scripts.

    The log has the following:
    startkde: starting up...
    klauncher(9122) kdemain: Waiting for already running klauncher to exit.
    klauncher(9122) kdemain: Another instance of klauncher is already running!
    kdeinit4: Communication error with laucher. Exiting!
    kdeinit4_wrapper: Warning: connect(/root/.kde4/socket-pesweb/kdeinit4__3) failed: : Connection refused
    Could not register with D-BUS. Aborting.

    I did not find any google ref's to the above that made sense to me. I need some help.

    Johnf

  2. #2

    Default Re: 13.2 VNC is not working - only displays black box with x11 3 check boxes

    Quote Originally Posted by John_fabiani View Post
    Hi,
    I believe I have followed all the setup items I need to setup VNC. The things I used to do with 12.x WORKED - but all I get is a black box with 3 checkboxes
    Please explain _how_ you setup VNC, and how you are trying to connect. Nobody can know what "the things I used to do with 12.x" are...

    It works fine here by just enabling "Remote Administration" in YaST->Network Services->Remote Administration (VNC), without doing anything else.

    Try to disable the Firewall completely on the remote host as a test, this might be in the way.

    And in the default config, only one connection per user is allowed, so make sure you are not logged in locally on the remote host.
    So to be clear: if you try to connect to localhost as the same user, it _won't_ work and give exactly the same symptoms as you describe.
    You can allow that by removing the option "-once" in /etc/xinet.d/vnc though (or in YaST->Network Services->Internet Services (xinet)).

    And if your remote host is a 13.2 system, make sure you installed all updates. There were some problems with the VNC server version shipped with 13.2 that have been fixed with updates.
    Last edited by wolfi323; 21-Mar-2015 at 10:45.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •