Results 1 to 9 of 9

Thread: Akonadi makes computer unusable

  1. #1

    Default Akonadi makes computer unusable

    On my computer I connect to the NAS at login and my emails are stored there as well. For this I modified the line folders in the file kmail2rc to "folders=/home/uli/ulimnt/.kmail/mail". For years this worked without any problems. For a few month now the computer gets completely unusable as it takes minutes even to switch from one window to the other. The top command yields the following:
    How do I post the screenshot?
    There you can see that akonadi_baloo_i uses 44.41%CPU, akonadi_agent_1 uses 7.895% CPU, akonadiserver uses 5.592%CPU, akonadi_notes_a uses 3.289%CPU .
    Additional mysqld uses 14.14% CPU - I don't use mysql but I assume akonadi uses it?

    Any ideas how this can be fixed? Any help would be appreciated.
    Cheers
    Uli

  2. #2

    Default Re: Akonadi makes computer unusable

    Quote Originally Posted by fuerstu View Post
    On my computer I connect to the NAS at login and my emails are stored there as well. For this I modified the line folders in the file kmail2rc to "folders=/home/uli/ulimnt/.kmail/mail".
    This option does not have any effect since years.
    You have to configure the location of your mail folders in the akonadi maildir resource's settings. E.g. "Configure Desktop"->Personal Infromation->Akonadi Resource Configuration, "kcmshell4 akonadi", or KMail's settings->Accounts->Receiving.
    The default is ~/.local/share/local-mail/, but if you migrated from earlier versions, the old settings should have been taken over.

    There you can see that akonadi_baloo_i uses 44.41%CPU, akonadi_agent_1 uses 7.895% CPU, akonadiserver uses 5.592%CPU, akonadi_notes_a uses 3.289%CPU .
    Baloo seems to take the most while it is apparently indexing your emails.
    Try to uninstall baloo-pim as a test.
    Maybe this is what actually causes your problems.

    Additional mysqld uses 14.14% CPU - I don't use mysql but I assume akonadi uses it?
    Yes, by default at least.

    Do I understand you correctly that your /home is on the NAS?
    It's not at all recommended to use Akonadi with an internal MySQL server on a remote /home AFAIK. Try switching to the SQLite backend (but this might have other problems), or use an external MySQL server (you need to start a system-wide mysql server for that, can be on a remote machine as well though).
    Use "kcmshell4 akonadi_server" (or "kcmshell4 akonadi" and switch to the "Server Settings" tab) to change the backend.
    Last edited by wolfi323; 13-Mar-2015 at 18:51.

  3. #3

    Default Re: Akonadi makes computer unusable

    Quote Originally Posted by fuerstu View Post
    There you can see that akonadi_baloo_i uses 44.41%CPU, akonadi_agent_1 uses 7.895% CPU, akonadiserver uses 5.592%CPU, akonadi_notes_a uses 3.289%CPU .
    Additional mysqld uses 14.14% CPU - I don't use mysql but I assume akonadi uses it?
    And the problem is probably worse than you think - cpu percentages under-represent the extent to which this thing renders your computer a doorstop that wastes electricity.


    If you are happy living without it - and given the pain of living with it, living without it should seem blissful - then turning it off seems sensible. i think something like


    system settings > (search for 'akonadi')


    should get you there, but it may be dependant on which version of kde you are running.

  4. #4

    Default Re: Akonadi makes computer unusable

    Thank you wolfi323 and Obscurant for your answers.
    I have just checked in the System Settings -> Akonadi resources -> local Folders ( or mail) and there is the path as /home/uli/ulimnt/.kmail/mail/ which is what I wanted. Wolfi323 the /home/uli folder is still on the computer and when I log in - the NAS is mounted at the mount point ulimnt. Would my system (where the stored emails are on the NAS) still work when baloo-pim is uninstalled?
    Obscurant - I think I need akonadi when I use kmail on a different location?
    BTW I am using the version 13.2 (latest version with the default KDE desktop on a 586 machine).
    Cheers
    Uli

  5. #5

    Default Re: Akonadi makes computer unusable

    Quote Originally Posted by Obscurant View Post
    If you are happy living without it - and given the pain of living with it, living without it should seem blissful - then turning it off seems sensible. i think something like
    You don't have to turn it off.
    It is only started if some application uses it.

    system settings > (search for 'akonadi')
    You cannot turn it off there. To really disable it, you'd have to edit a config file directly, or uninstall it (this will uninstall all applications using Akonadi as well, like the whole KDE-PIM suite).
    But again, this is not necessary. Just don't use any Akonadi-based applications, and it won't run.

    Quote Originally Posted by fuerstu View Post
    I have just checked in the System Settings -> Akonadi resources -> local Folders ( or mail) and there is the path as /home/uli/ulimnt/.kmail/mail/ which is what I wanted.
    Yes. As I mentioned, this was probably configured by the Akonadi-Migrator and taken from the old KMail1 config.

    Wolfi323 the /home/uli folder is still on the computer and when I log in - the NAS is mounted at the mount point ulimnt.
    So the NAS mount is irrelevant. Akonadi's cache (i.e. the MySQL database) is in ~/.local/share/akonadi/. If this is on your local hard disk, you should be fine.

    Would my system (where the stored emails are on the NAS) still work when baloo-pim is uninstalled?
    Yes.
    Baloo is KDE's indexing/search system.
    If you uninstall baloo-pim, it just won't index any PIM data like Mails.
    You can still search via the search bar though, it's just not using the baloo index obviously.

    Obscurant - I think I need akonadi when I use kmail on a different location?
    You need Akonadi if you use KMail at all. KMail is based on Akonadi, like KAddressbook, KOrganizer, KNotes, KJots, KAlarm, ...

    BTW I am using the version 13.2 (latest version with the default KDE desktop on a 586 machine).
    Right. Baloo is new there. In earlier openSUSE versions, Nepomuk was included. That was replaced by Baloo in KDE 4.13 (13.2 comes with 4.14), which actually should work better. But Nepomuk's indexing was disabled completely by default in openSUSE, including the PIM-Indexer.
    Maybe the problem would disappear after the initial indexing?
    You can disable indexing on a per-folder basis too. Just right-click on the folder, choose "Folder Properties" and switch to the "Maintenance" tab.
    Last edited by wolfi323; 13-Mar-2015 at 19:33.

  6. #6

    Default Re: Akonadi makes computer unusable

    Thank you very much, wolfi323, I had a few things to do yesterday evening and to get to this thread I turned off the NAS and Kmail because then this machine works like a normal computer. Since this computer is a laptop and was used away from my network for 3 Months I didn't notice when it started having problems. I only investigated it yesterday. It makes sence that it is since the new install since I remember Nepomuk and I never had problems with it. You said the indexing was turned off by default there. I uninstalled baloo-pim and now so far (for approx 45 minutes) everything works fine. I have the console with top open and whenever I check I don't see akonadi mentioned with any CPU usage at all. So everything is back to normal for me - although I think the developer need to put a bit more work in baloo.
    Thanks again, wolfi323, I come back if something creeps up with this setting now. I tried to click your star but got only "You must spread some Reputation around before giving it to wolfi323 again."
    Cheers
    Uli

  7. #7

    Default Re: Akonadi makes computer unusable

    Hi wolfi323, after deleting baloo-pim everything seemed to work fine but every online update installs it again. Since I don't want to uninstall it constantly - is there a way to disable it?
    Cheers
    Uli

  8. #8

    Default Re: Akonadi makes computer unusable

    Quote Originally Posted by fuerstu View Post
    Hi wolfi323, after deleting baloo-pim everything seemed to work fine but every online update installs it again.
    Right-click on the package in YaST and choose "Taboo - Never Install".

    Since I don't want to uninstall it constantly - is there a way to disable it?
    You can enable/disable indexing for each mail folder separately in "Folder Properties" (available in a folder's right-click contect menu)->Maintenance.

    To disable the indexer completely, I suppose you could edit ~/.config/akonadi/agent_config_akonadi_baloo_indexer and set "DesiredOnlineState=false" in there, or just put it offline in akonadiconsole (right-click on the "Akonadi Baloo Indexing Agent" and select "Toggle Online/Offline").
    Last edited by wolfi323; 20-Mar-2015 at 17:08.

  9. #9

    Default Re: Akonadi makes computer unusable

    Thank you very much, wolfi323, I didn't know this YAST feature. I uninstalled and just to be sure I edited ~/.config/akonadi/agent_config_akonadi_baloo_indexer and set that to false too. Hopefully my problems are no solved.
    Cheers
    Uli

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •