Page 3 of 3 FirstFirst 123
Results 21 to 27 of 27

Thread: 13.2 and hibernate amnesia

  1. #21
    Join Date
    Mar 2015
    Location
    PH
    Posts
    23

    Default Re: 13.2 and hibernate amnesia

    Removing "splash=silent quiet showopts" broke resume again. Putting "showopts" as the last without "splash=silent quiet" doesn't work either. Having "splash=silent quiet" and leaving out "showopts" worked. Everything else was left alone.

    Off to Bugzilla then.

    Thank you so much for your time and help! I can finally hibernate in peace and comfort ^o^

    ---

    For those who come across this thread in the future, TL;DR:

    If you removed "splash=silent quiet" from the kernel command line, put that back in.

    On 2015-03-13 03:06, wolfi323 wrote:
    >
    > gjie;2699407 Wrote:
    >> Resume works when "splash=silent quiet" before "showopts" was added.
    >> Just to make sure, I removed those two options and put
    >> "elevator=deadline" back in and resume broke again. So, yes, anything it
    >> seems.

    >
    > Wow. This would sound like a (kernel?) bug to me.
    >
    > Just OOC, would specifying those additional parameters _before_
    > "showopts" work?
    > Or removing "showopts" completely? This doesn't really make sense with
    > grub2 any more anyway I think. It was used with grub1 to specify which
    > part should be displayed in the editable boot options line in the boot
    > menu.
    >
    >


  2. #22
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,865
    Blog Entries
    15

    Default Re: 13.2 and hibernate amnesia

    On Thu 12 Mar 2015 07:06:02 PM CDT, wolfi323 wrote:


    gjie;2699407 Wrote:
    > Resume works when "splash=silent quiet" before "showopts" was added.
    > Just to make sure, I removed those two options and put
    > "elevator=deadline" back in and resume broke again. So, yes, anything
    > it seems.


    Wow. This would sound like a (kernel?) bug to me.

    Just OOC, would specifying those additional parameters _before_
    "showopts" work?
    Or removing "showopts" completely? This doesn't really make sense with
    grub2 any more anyway I think. It was used with grub1 to specify which
    part should be displayed in the editable boot options line in the boot
    menu.


    Hi
    One wonders if it's tied in with plymouth? I normally remove and delete
    all the packages and run mkinitrd, I don't use suspend or hibernate
    either so can't really verify.

    --
    Cheers Malcolm °¿° LFCS, SUSE Knowledge Partner (Linux Counter #276890)
    SUSE Linux Enterprise Desktop 12 GNOME 3.10.1 Kernel 3.12.36-38-default
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!


  3. #23

    Default Re: 13.2 and hibernate amnesia

    Quote Originally Posted by malcolmlewis View Post
    One wonders if it's tied in with plymouth?
    Might be possible I suppose. I had that thought as well.
    You can disable it by adding "plymouth.enable=0" to the kernel command line.

    On my system here, resume just hangs when plymouth is active, while it works just fine on another system (with btrfs as only filesystem... ).
    Uninstalling pm-utils or setting SLEEP_MODULE="kernel" in /usr/lib/pm-utils/defaults helps here as well though.

    But I haven't ever tried without "splash=silent quiet" I think.
    Normally I don't use suspend/hibernate at all either.

  4. #24
    Join Date
    Mar 2015
    Location
    PH
    Posts
    23

    Default Re: 13.2 and hibernate amnesia

    Alright, uninstalled plymouth, ran `sudo mkinitrd` and rebooted.
    Tried a hibernate with "splash=silent quiet" and resume worked. Removed that and resume broke.

    On 2015-03-13 04:26, wolfi323 wrote:
    >
    > malcolmlewis;2699426 Wrote:
    >> One wonders if it's tied in with plymouth?

    > Might be possible I suppose. I had that thought as well.
    > You can disable it by adding "plymouth.enable=0" to the kernel command
    > line.
    >
    > On my system here, resume just hangs when plymouth is active, while it
    > works just fine on another system (with btrfs as only filesystem...
    > ).
    > Uninstalling pm-utils or setting SLEEP_MODULE="kernel" in
    > /usr/lib/pm-utils/defaults helps here as well though.
    >
    > But I haven't ever tried without "splash=silent quiet" I think.
    > Normally I don't use suspend/hibernate at all either.
    >
    >


  5. #25
    Join Date
    Mar 2015
    Location
    PH
    Posts
    23

    Default Re: 13.2 and hibernate amnesia

    Following up:
    https://bugzilla.opensuse.org/show_bug.cgi?id=922157

    Thank you everyone!

  6. #26

    Default Re: 13.2 and hibernate amnesia

    Hm, but this doesn't seem to be a general problem either.

    I tried now with the following kernel command line (which should trigger the problem AIUI), and resume worked just fine:
    Code:
    BOOT_IMAGE=/boot/vmlinuz-3.16.7-7-desktop root=UUID=e2c9b751-d87b-4dbd-b240-391e01dbd8cd resume=/dev/sdb2 showopts elevator=deadline
    Well, let's hope the kernel developers have more ideas what could cause this or what more to investigate...

  7. #27
    Join Date
    Mar 2015
    Location
    PH
    Posts
    23

    Default Re: 13.2 and hibernate amnesia

    Tried again. Removed "splash=silent quiet" and resumed.
    It worked, for some reason. I'm getting confused now. Either this is related to plymouth being taken out and needing several restarts(??) to work or something.

    On 2015-03-13 16:46, wolfi323 wrote:
    >
    > Hm, but this doesn't seem to be a general problem either.
    >
    > I tried now with the following kernel command line (which should trigger
    > the problem AIUI), and resume worked just fine:
    >
    > Code:
    > --------------------
    > BOOT_IMAGE=/boot/vmlinuz-3.16.7-7-desktop root=UUID=e2c9b751-d87b-4dbd-b240-391e01dbd8cd resume=/dev/sdb2 showopts elevator=deadline
    > --------------------
    >
    >
    > Well, let's hope the kernel developers have more ideas what could cause
    > this or what more to investigate...
    >
    >


Page 3 of 3 FirstFirst 123

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •