Results 1 to 2 of 2

Thread: systemd systemctl problem

  1. #1
    Join Date
    Mar 2015
    Location
    Indianapolis area
    Posts
    28

    Default systemd systemctl problem

    I've been troubleshooting a slow ssh logon issue. To facilitate this I ran
    Code:
    systemctl stop sshd.service
    .
    Then i launched sshd manually with debugging turned on
    Code:
    /usr/sbin/sshd -d -D
    . I fixed that issue but something weird showed up in the process. When it tried to run
    Code:
    systemctl start sshd.service
    , i find there is no command.

    I can still run status, but start and stop won't allow sshd.service as an option. I had to run
    Code:
    service sshd start
    . However, after i rebooted, I was able to use systemctl to stop and start sshd. It seems to come and go.

    Any insight into this issue?

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,002

    Default Re: systemd systemctl problem

    1) what openSUSE version?

    2) Sayiing things like "there is no command" are not very usefull. When you get any messages (or even nothing at all) that is best communicated in a post by copy/paste the prompt, the command, the output and the next prompt between the CODE tags. Only in that way we can see what you saw.
    Henk van Velden

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •