Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Skype 4.3 on OpenSUSE 13.1: No microphone input

  1. #1
    Join Date
    Jun 2008
    Location
    Germany
    Posts
    51

    Default Skype 4.3 on OpenSUSE 13.1: No microphone input

    Hello,

    Please let me request your advice to resolve the following issue.

    My system is an OpenSUSE 13.1 64bit on an Aspire E1-572-G laptop. Since the OS was out before I bought the machine, I run a more recent kernel from http://download.opensuse.org/reposit...able/standard/ to make the network card work. Multimedia is installed from Packman repository following https://forums.opensuse.org/entry.ph...allation-Guide . [Remark: At the time of this writing, this page is blocked from public access. Why? This was different only a few weeks ago.] Skype is currently installed by the OpenSUSE 12.1 32bit RPM (ver. 4.3.0.37) from http://www.skype.com/en/download-sky...-for-computer/ . I am aware of https://en.opensuse.org/SDB:Skype ; specifically, I installed various 32bit packages.

    When I do a Skype test call, I hear the announcement loud and clear, yet not my own voice. I found a thread related to my issue, yet it does not help me to resolve the issue. Launching pavucontrol from Skype - Options - Sound Devices shows two entries on the "Input Devices" tab, "Internal Microphone" and "Microphone (unplugged)". The Internal "wiggles" randomly at a slightly higher level than the Unplugged. Playing the output from
    Code:
    arecord -vv -fdat foo.wav
    results in seemingly static noise. From other threads I gather that the output of
    Code:
    /usr/sbin/alsa-info.sh
    may be helpful; here is the listing.

    Two more remarks: 1.) The described behavior seems to be the same when Skype (ver. 4.3.0.37) is installed from homeRevan86:non-free. -- 2.) Using a headset shows the equivalent symptoms for the headset microphone.

    Have I forgotten anything? How can this issue (if necessary to distinguish, considering only the internal microphone) be resolved?

    Please be specific in your instructions since I consider myself rather a high-level Linux user.

    Thank you in advance.

  2. #2

    Default Re: Skype 4.3 on OpenSUSE 13.1: No microphone input

    Go to the sound settings on YaST, and under recording options check the devices priority. I just installed 13.2 this past weekend, and the same issue. I had two input devices, built-in and webcam, webcam is the real one but it was as the second option, so as Skype uses pulseaudio, it tried to record audio with a nonexistent device. Just moving webcam up solved the issue.

  3. #3
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,696

    Default Re: Skype 4.3 on OpenSUSE 13.1: No microphone input

    Also be sure that things are not muted and the volume is up for the mic. Installing and using pavolcontrol can be a large help in fixing this kind of problem

  4. #4
    Join Date
    Jun 2008
    Location
    Germany
    Posts
    51

    Default Re: Skype 4.3 on OpenSUSE 13.1: No microphone input

    Thank you for your quick replies so far.

    Quote Originally Posted by yzT View Post
    Go to the sound settings on YaST, and under recording options check the devices priority.
    When I open Yast - Hardware - Sound, I can see entries that I compiled in a collage. Entry Zero does not play any test sound (button Other - Play Test Sound), whereas entry One does. Clicking on entry One and choosing Other - Set as the Primary Card does not seem to change anything.

    Quote Originally Posted by gogalthorp View Post
    Also be sure that things are not muted and the volume is up for the mic. Installing and using pavolcontrol can be a large help in fixing this kind of problem
    Do you mean pavucontrol? It is installed (as mentioned in my original post), I do not see anything muted.

  5. #5

    Default Re: Skype 4.3 on OpenSUSE 13.1: No microphone input

    Sorry I answered from smartphone earlier xD

    Now checking, I meant KDE's Configure Desktop > Multimedia > Audio and Video Settings

  6. #6

    Default Re: Skype 4.3 on OpenSUSE 13.1: No microphone input

    Quote Originally Posted by paschuller View Post
    Do you mean pavucontrol? It is installed (as mentioned in my original post), I do not see anything muted.
    Open pavucontrol. Verify that your mic is present under Input Devices and that its volume is turned up. Tap on the mic to see (visually) if it is capturing sound. Next, click on the "Recording" tab. Make a Skype test call. When Skype appears in the list, select your input source from the options provided. Things should now work.

  7. #7
    Join Date
    Jun 2008
    Location
    Germany
    Posts
    51

    Default Re: Skype 4.3 on OpenSUSE 13.1: No microphone input

    Quote Originally Posted by yzT View Post
    I meant KDE's Configure Desktop > Multimedia > Audio and Video Settings
    Going there and checking Audio Recording - Communication/ Recording/ Control, all these categories have "Built-in Audio Analog Stereo" as top entry.

    Quote Originally Posted by JJMT View Post
    Open pavucontrol. Verify that your mic is present under Input Devices and that its volume is turned up. Tap on the mic to see (visually) if it is capturing sound. Next, click on the "Recording" tab. Make a Skype test call. When Skype appears in the list, select your input source from the options provided. Things should now work.
    In pavucontrol tab Input Devices, showing All Except Monitors, I see Built-in Audio Analog Stereo. It usually appears with Port: Internal Microphone. Level is at 100% (0dB) and not muted. Tapping just about everywhere on the laptop shows only random wiggles at low level.

    Now this is weird, it used to be different, i.e., before I had to do a complete fresh install after a system crash (see this thread (still unresolved).

    I happened to find an old USB webcam around. When I plug that in, it appears as new input device in the corresponding pavucontrol tab, and Skype can use it properly as well.

    Well, that's nice to know, but I don't usually want to carry that old thing with me...

  8. #8

    Default Re: Skype 4.3 on OpenSUSE 13.1: No microphone input

    you could also use something like Audacity to determine whether or not the built-in device is properly working. Preferences > Device > Recording.

  9. #9

    Default Re: Skype 4.3 on OpenSUSE 13.1: No microphone input

    Quote Originally Posted by paschuller View Post
    Tapping just about everywhere on the laptop shows only random wiggles at low level.
    OK. So it is not a Skype thing at all. Have you configure your internal sound card through Yast->Hardward->Sound? Have you tried setting the volume using "alsamixer -c0" from command line?

  10. #10
    Join Date
    Jun 2008
    Location
    Germany
    Posts
    51

    Default Re: Skype 4.3 on OpenSUSE 13.1: No microphone input

    Quote Originally Posted by JJMT View Post
    Have you configure your internal sound card through Yast->Hardward->Sound? Have you tried setting the volume using "alsamixer -c0" from command line?
    Regarding configuration in Yast, I am repeating an earlier post of mine with minor editing: When I open Yast - Hardware - Sound, I can see entries that I compiled in this collage. Entry "0" does not play any test sound (button Other - Play Test Sound), whereas entry "1" does. Clicking on entry One and choosing Other - Set as the Primary Card does not seem to change anything. I have not done any particular manual configuration.

    Regarding alsamixer, I am not familiar with this tool. How does it relate to the Yast sound configuration? When I launch "alsamixer -c0" in a console, I see a quite empty screen. Choosing sound card "1" by "F6 > 1" shows a very different screen.

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •