openSUSE 13.1 (x86_64); Linux 3.11.10-25-desktop; KDE 4.14.4 nVidia graphics - This is an 'old' system upgraded progressivly from 10.3


I have been experiencing intermittent errors (every few days) with KDE desktop and KDE applications over the past two months. The most common errors are 'unresponsive panel' in KDE desktop and 'unresponsive save dialogue' in kwrite/kate. Both frustrating, especially since my skill level is low. These errors are difficult to reproduce but, of course, they occur when most inconvenient.


This is a non-specific problem and I regret I will need patient help to diagnose it as well as to seek to solve it. My longer term aim is to clean up this system (my main working desktop) so that I can sustain it for a few more years with help from the evergreen project.


zypper repos says I have the following repos set up:
Code:
#  | Alias                           | Name                              | Enabled | Refresh                                                         
---+---------------------------------+-----------------------------------+---------+--------                                                         
 1 | Apps_Geo-openSUSE_12-1          | Apps_Geo-openSUSE_13.1            | Yes     | Yes                                                             
 2 | KDE-Current-openSUSE_13.1       | KDE-Current-openSUSE_13.1         | Yes     | Yes                                                             
 3 | Moka Stable Repository          | Moka Stable Repository            | No      | Yes                                                             
 4 | Network-openSUSE-13.1           | Network-openSUSE-13.1             | Yes     | Yes                                                             
 5 | Razor_Qt_openSUSE_12.3          | Razor Qt openSUSE 13.1            | Yes     | Yes                                                             
 6 | Utilities-openSUSE-13.1         | Utilities-openSUSE-13.1           | Yes     | Yes                                                             
 7 | download.nvidia.com-opensuse    | nVidia Graphics Drivers           | Yes     | Yes    
 8 | download.opensuse.org-Education | openSUSE BuildService - Education | Yes     | Yes    
 9 | download.opensuse.org-Extra     | openSUSE BuildService - KDE:Extra | Yes     | Yes    
10 | google-chrome                   | google-chrome                     | Yes     | Yes    
11 | local-repo                      | local-repo                        | No      | No     
12 | opensuse-guide.org-repo         | libdvdcss repository              | No      | No     
13 | packman.inode.at-suse           | Packman Repository                | Yes     | Yes    
14 | repo-12.3-non-oss               | openSUSE-13.1-Non-Oss             | Yes     | Yes    
15 | repo-12.3-oss                   | openSUSE-13.1-OSS                 | Yes     | Yes    
16 | repo-12.3-update                | openSUSE-13.1 Update-Oss          | Yes     | Yes    
17 | repo-update-non-oss             | openSUSE-13.1-Update-Non-Oss      | Yes     | Yes
zypper verify says "Dependencies of all installed packages are satisfied".


The system logs speak a language that I don't much understand. It would help if I knew what I was looking for.