Results 1 to 7 of 7

Thread: Switch to GNOME from KDE

  1. #1

    Default Switch to GNOME from KDE

    i installed SUSE 12.2 yesterday.
    After overcoming the issues with bootloader installations, i realized i installed KDE instead of GNOME.
    Is there any chance i can switch to GNOME interface without reinstalling the whole thing.
    I don't really want to reinstall as it is installed alongside Win 7.
    Appreciate any advice

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,607
    Blog Entries
    3

    Default Re: Switch to GNOME from KDE

    Yes, you can switch.

    Open Yast software management. Select the "Patterns" view. Then select the Gnome patterns.

    You will probably get a conflict resolution popup about a problem with "patterns-openSUSE-kde4_pure". Tell it to go ahead and delete that (it is harmless to delete it). It should then install Gnome. It probably takes around 500M of additional disk space (a wild guess).

    After you are done with that

    Yast --> System --> /etc/sysconfig editor

    Then, in turn: Desktop --> Display manager --> DISPLAYMANAGER

    and change the value from "kdm" to "gdm".

    If you are configured for auto-login, you will probably want to change that also. It will be the variable DISPLAYMANAGER_AUTOLOGIN which should still be visible in the left column. Change to blank.

    When done, reboot. It should come up with the gdm login screen. Login. You may have to select Gnome (it probably still defaults to KDE). But, once you login to Gnome, it will remember that.

    You could actually continue to use KDM instead of GDM. But then the Gnome keyring will not be automatically unlocked during login, and that can be a problem.

    Oh, you can go back to KDE by just selecting that on the login screen (in case you change your mind).
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  3. #3
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,124

    Default Re: Switch to GNOME from KDE

    Quote Originally Posted by Komprende View Post
    i installed SUSE 12.2 yesterday.
    After overcoming the issues with bootloader installations, i realized i installed KDE instead of GNOME.
    Is there any chance i can switch to GNOME interface without reinstalling the whole thing.
    I don't really want to reinstall as it is installed alongside Win 7.
    Appreciate any advice
    You are a lucky man getting advice to your question. Because you posted this in a forums where it says very clear at the top:
    Please don't ask propduct questions here
    Something that is repeated in other wording a bit further were it says:
    This forum is NOT for asking questions,......

    Please next time wqhen you have a question/probem, ask that in a fitting (sub)forum. Chances that you get an answer are much greater then.

    This is CLOSED for the moment and will be moved to Applications.
    Henk van Velden

  4. #4
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,124

    Default Re: Switch to GNOME from KDE

    Quote Originally Posted by hcvv View Post
    This is CLOSED for the moment and will be moved to Applications.
    Moved from Unreviewed Howto and FAC and open again.
    Henk van Velden

  5. #5

    Default Re: Switch to GNOME from KDE

    Quote Originally Posted by nrickert View Post
    Yes, you can switch.

    Open Yast software management. Select the "Patterns" view. Then select the Gnome patterns.

    You will probably get a conflict resolution popup about a problem with "patterns-openSUSE-kde4_pure". Tell it to go ahead and delete that (it is harmless to delete it). It should then install Gnome. It probably takes around 500M of additional disk space (a wild guess).

    After you are done with that

    Yast --> System --> /etc/sysconfig editor

    Then, in turn: Desktop --> Display manager --> DISPLAYMANAGER

    and change the value from "kdm" to "gdm".

    If you are configured for auto-login, you will probably want to change that also. It will be the variable DISPLAYMANAGER_AUTOLOGIN which should still be visible in the left column. Change to blank.

    When done, reboot. It should come up with the gdm login screen. Login. You may have to select Gnome (it probably still defaults to KDE). But, once you login to Gnome, it will remember that.

    You could actually continue to use KDM instead of GDM. But then the Gnome keyring will not be automatically unlocked during login, and that can be a problem.

    Oh, you can go back to KDE by just selecting that on the login screen (in case you change your mind).

    Thank you. It has worked. I like Open Suse now better than i like Ubuntu...but now when i am using firefox or any other application that works in a window the only button i get in right corner is to close it, no minimise underscore, to minimize i have to right click and then select minimize, i still how to figure out how the whole workspace system works here, it seems to be very different.

  6. #6
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,607
    Blog Entries
    3

    Default Re: Switch to GNOME from KDE

    Quote Originally Posted by Komprende View Post
    ...but now when i am using firefox or any other application that works in a window the only button i get in right corner is to close it, no minimise underscore, to minimize i have to right click and then select minimize, i still how to figure out how the whole workspace system works here, it seems to be very different.
    Welcome to Gnome. And that's why I prefer KDE.

    You can probably setup keyboard shortcuts for some of those things.

    I use Gnome only to familiarize myself with it. I much prefer KDE or even XFCE for my normal use of the system.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  7. #7

    Default Re: Switch to GNOME from KDE

    Quote Originally Posted by Komprende View Post
    but now when i am using firefox or any other application that works in a window the only button i get in right corner is to close it, no minimise underscore, to minimize i have to right click and then select minimize, i still how to figure out how the whole workspace system works here, it seems to be very different.
    You can enable/disable the buttons for minimizing/maximizing windows in gnome-tweak-tool (Windows->Titlebar Buttons).

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •