Results 1 to 5 of 5

Thread: Can't get Diamond Desktop Theme to install

  1. #1

    Default Can't get Diamond Desktop Theme to install

    I click the "Get New Themes" button and recieved a list of desktop themes. I selected the Diamond theme and clicked the install button but nothing seems to happen. When I downloaded it from their website and ran the install from terminal, it said it installed but does not show up in the available themes to select and apply. It only shows the "Air" and "OpenSUSE" themes.
    How do I get this theme to apply?

    Running Linux 3.16.7-7desltop, OpenSUSE 13.2 (Harlequin) x86-64, KDE 4.14.5
    Regards

  2. #2

    Default Re: Can't get Diamond Desktop Theme to install

    Quote Originally Posted by littlegrey View Post
    I click the "Get New Themes" button and recieved a list of desktop themes. I selected the Diamond theme and clicked the install button but nothing seems to happen.
    I just tried that here, and it worked fine. I clicked on "Install", chose the "Diamond" entry (_not_ "Diamond 1.5.6"), it was downloaded and installed fine and was available immediately in the desktop theme settings dialog.

    I'm still on 4.14.4 though, haven't installed the latest KDE update on this machine yet.

    When I downloaded it from their website and ran the install from terminal, it said it installed but does not show up in the available themes to select and apply. It only shows the "Air" and "OpenSUSE" themes.
    How do I get this theme to apply?
    And what exactly did you download and what exactly did you run in the terminal?

    It seems to me that "Diamond 1.5.6" is an older version that probably might not work any more on current KDE releases.
    Last edited by wolfi323; 06-Mar-2015 at 10:12.

  3. #3

    Default Re: Can't get Diamond Desktop Theme to install

    Quote Originally Posted by wolfi323 View Post
    I just tried that here, and it worked fine. I clicked on "Install", chose the "Diamond" entry (_not_ "Diamond 1.5.6"), it was downloaded and installed fine and was available immediately in the desktop theme settings dialog.

    I'm still on 4.14.4 though, haven't installed the latest KDE update on this machine yet.


    And what exactly did you download and what exactly did you run in the terminal?

    It seems to me that "Diamond 1.5.6" is an older version that probably might not work any more on current KDE releases.
    I clicked on details to show the Diamond theme and clicked on "Homepage". There I downloaded the tar file for Diamond and in terminal ran the install script. After that I opened the configure desktop and clicked the desktop themes but it did not show as available to apply.
    When I clicked on show me themes that are installed it showed up as being installed. I was curious if any other themes that downloaded would be available to install so I clicked on one of the others and clicked install. It to showed that it was installed but did not show in the list of available themes. I even logged out and logged back in but no joy.

    One thing I failed to tell you is that I'm running under VirtualBox under Windows 7 since I use Autocad.

    I have and older HP laptop that I'll burn the OpenSUSE iso to cd and load it on that and see if that makes a difference. Will let you know.
    Thanks for your help.
    Regards

  4. #4

    Default Re: Can't get Diamond Desktop Theme to install

    Quote Originally Posted by littlegrey View Post
    I clicked on details to show the Diamond theme and clicked on "Homepage". There I downloaded the tar file for Diamond and in terminal ran the install script. After that I opened the configure desktop and clicked the desktop themes but it did not show as available to apply.
    I tried again now with KDE 4.14.5, and it worked fine as well.
    That's how I did it exactly:
    - click on "Get New Themes" in the desktop theme settings
    - search for the "Diamond" theme
    - click on "Install", in the drop-down list select "Diamond", _not_ "Diamond 1.5.6".
    The theme shows as installed then (after a while) and if I click on "Close", the theme is immediately available for selection.

    But, if I install "Diamond 1.5.6" instead, I experience the same as you describe: the theme shows as "Installed", but it is not available.

    So I would suggest you uninstall the theme, and try again.

    One thing I failed to tell you is that I'm running under VirtualBox under Windows 7 since I use Autocad.

    I have and older HP laptop that I'll burn the OpenSUSE iso to cd and load it on that and see if that makes a difference. Will let you know.
    This should not matter.

  5. #5

    Default Re: Can't get Diamond Desktop Theme to install

    Quote Originally Posted by wolfi323 View Post
    I tried again now with KDE 4.14.5, and it worked fine as well.
    That's how I did it exactly:
    - click on "Get New Themes" in the desktop theme settings
    - search for the "Diamond" theme
    - click on "Install", in the drop-down list select "Diamond", _not_ "Diamond 1.5.6".
    The theme shows as installed then (after a while) and if I click on "Close", the theme is immediately available for selection.

    But, if I install "Diamond 1.5.6" instead, I experience the same as you describe: the theme shows as "Installed", but it is not available.

    So I would suggest you uninstall the theme, and try again.


    This should not matter.
    Ok, here's what I was doing wrong. When I clicked to install, the dropdown wondow showed both versions of Diamond with a check mark on the left. I put my cursor on the check mark at the bottom left thinking it would remove the check mark and only install the top one that still had the check mark. What was happening it assumed that I wanted to install the old version below and that's exactly what it was doing. Once I uninstalled and put the cursor on the top version it installed and applied correctly.

    All's right in the world. Case closed. Thanks for your help.
    Regards

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •