Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: A problem met switching from kde to xfce

  1. #1

    Default A problem met switching from kde to xfce

    Hi, I am new to linux/opensuse. I installed opensuse on my laptop a few days ago with xfce as my default desktop environment. Then I wanted to try kde and see if I am gonna like it, so I install with command "zypper install kde-basics, kde-patterns and kde4-desktop" (the command was kind of like that, but I can't really remember). After trying it out, I switched back to xfce, the window style still keeps the kde oxygen theme with the glowing blue light, and I can't change the theme nor icons back in xfce to what it looked like before. I am really uncomfortable with this. Could anyone teach me how change things back? Thank you for your time!

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,863

    Default Re: A problem met switching from kde to xfce

    There are big signs in this subforums saying things like: "Do not ask product questions here" and "This forum is NOT for asking questions, ......"

    This thread is CLOSED for the moment and will be moved to Applications.
    Last edited by hcvv; 02-Mar-2015 at 01:48.
    Henk van Velden

  3. #3
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,863

    Default Re: A problem met switching from kde to xfce

    Quote Originally Posted by hcvv View Post
    This thread is CLOSED for the moment and will be moved to Applications.
    Moved from Unreviewed Howtos and FAQ and open again.
    Henk van Velden

  4. #4
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,863

    Default Re: A problem met switching from kde to xfce

    When you want to add a further DE to your installation (like KDE in this case), you should NOT install a list of packages (like kde-basics, ....) because it is to easy to forget one (and where did you get that list in the first place). Most easy is YaST > Software > Software Management, then from the View menu choose Patterns. Scroll down and see KDE, check it and install. maybe you should do that first because we are not sure now you have all you need for using KDE.

    Then you say "you switched back to xfce", but that is only a general remark, it is not an exact description of what you did. Remember that with computers, talking loosely about "I did ...", "it does not ....", etc. are just that: loosely talking. But to solve problems one needs hard exact and presice computer facts.
    Henk van Velden

  5. #5

    Default Re: A problem met switching from kde to xfce

    Quote Originally Posted by hcvv View Post
    When you want to add a further DE to your installation (like KDE in this case), you should NOT install a list of packages (like kde-basics, ....) because it is to easy to forget one (and where did you get that list in the first place). Most easy is YaST > Software > Software Management, then from the View menu choose Patterns. Scroll down and see KDE, check it and install. maybe you should do that first because we are not sure now you have all you need for using KDE.

    Then you say "you switched back to xfce", but that is only a general remark, it is not an exact description of what you did. Remember that with computers, talking loosely about "I did ...", "it does not ....", etc. are just that: loosely talking. But to solve problems one needs hard exact and presice computer facts.
    Thank you for replying!

    Sorry, I wasn't reading careful enough~I won't do that next time.

    I found the list on this website https://en.opensuse.org/SDB:KDE_install

    So I tried installing KDE from YaST, but it showed me this three options (if you can see it in the picture) in order to install kde-20141007-5.1.i586 which are deinstallation of patterns-opensuse-xll_yast-20141007-5.1.i586 or do not install kde-20141007-5.1.i586 or break pattern of kde-20141007-5.1.i586 by irgnoring some of its dependencies.


    what should I do next?

    and what I did exactly to "switch" back to xfce was editing file /ect/sysconfig/displaymanager and changed displaymanager="lightdm" from displaymanager="kdm" and change the desktop environment option from KDE Plasma workspace environment to xfce session under where you input the password for accounts on the login screen.

    Is there anything else I should mention?

  6. #6
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,863

    Default Re: A problem met switching from kde to xfce

    Quote Originally Posted by fridayc View Post
    I found the list on this website https://en.opensuse.org/SDB:KDE_install

    So I tried installing KDE from YaST, but it showed me this three options (if you can see it in the picture) in order to install kde-20141007-5.1.i586 which are deinstallation of patterns-opensuse-xll_yast-20141007-5.1.i586 or do not install kde-20141007-5.1.i586 or break pattern of kde-20141007-5.1.i586 by irgnoring some of its dependencies.


    what should I do next?
    It looks as if you tried to add a picture here, but I do not see much.
    Do you mean that you tried to install the KDE pattern (as I suggested) and then got those messages? Hm, it seems that you already introduced something by not installing the pattern from the beginning.
    Let us use zypper to get those messages in a terminal window (for you to copy/paste here between CODE tags):
    Code:
    zypper in -t pattern kde
    Quote Originally Posted by fridayc View Post
    and what I did exactly to "switch" back to xfce was editing file /ect/sysconfig/displaymanager and changed displaymanager="lightdm" from displaymanager="kdm" and change the desktop environment option from KDE Plasma workspace environment to xfce session under where you input the password for accounts on the login screen.

    Is there anything else I should mention?
    This is a bit more clear now. Because you did not switch to XFCE, but you did switch the login manager to XFCE's one (you can use any login manager and still on login decide which DE to use).

    That is quite different from switching back and forth between KDE and XFCE. You can decide on every login which DE to use from the menu on the logiin page. That is not realy switching (you could even be loged in twice at the same moment in time, each login using a diffrent DE).
    Henk van Velden

  7. #7

    Default Re: A problem met switching from kde to xfce

    Quote Originally Posted by fridayc View Post
    and what I did exactly to "switch" back to xfce was editing file /ect/sysconfig/displaymanager and changed displaymanager="lightdm" from displaymanager="kdm" and change the desktop environment option from KDE Plasma workspace environment to xfce session under where you input the password for accounts on the login screen.
    You don't have to change the displaymanager to "switch back to xfce". Just selecting "XFCE" at the login screen should be enough.
    Although you can use lightdm as well if you prefer, regardless whether you want to login to KDE or XFCE.

    Btw, you can set the system-wide default Desktop Environment in /etc/sysconfig/windowmanager (DEFAULT_WM).

    Regarding your "window style": try removing the files ~/.gtkrc-2.0 and ~/.gtkrc-2.0-kde4. This is where KDE sets the GTK2 style to oxygen (or whatever you choose in "Application Appearance"->GTK) to make GTK applications look "native" inside the KDE session.

  8. #8

    Default Re: A problem met switching from kde to xfce

    Quote Originally Posted by hcvv View Post
    It looks as if you tried to add a picture here, but I do not see much.
    Do you mean that you tried to install the KDE pattern (as I suggested) and then got those messages? Hm, it seems that you already introduced something by not installing the pattern from the beginning.
    Let us use zypper to get those messages in a terminal window (for you to copy/paste here between CODE tags):
    Code:
    zypper in -t pattern kde
    This is a bit more clear now. Because you did not switch to XFCE, but you did switch the login manager to XFCE's one (you can use any login manager and still on login decide which DE to use).

    That is quite different from switching back and forth between KDE and XFCE. You can decide on every login which DE to use from the menu on the logiin page. That is not realy switching (you could even be loged in twice at the same moment in time, each login using a diffrent DE).
    so I put zypper in -t pattern kde, and it shows this

    Code:
    linux-krtd:/home/fridayc # zypper in -t pattern kde
    Loading repository data...
    Reading installed packages...
    Resolving package dependencies...
    
    
    Problem: pattern:kde-20141007-5.1.i586 requires patterns-openSUSE-kde, but this requirement cannot be provided
      uninstallable providers: patterns-openSUSE-kde-20141007-2.1.i586[openSUSE-13.2-0]
                       patterns-openSUSE-kde-20141007-2.1.i586[repo-oss]
                       patterns-openSUSE-kde-20141007-5.1.i586[repo-update]
     Solution 1: deinstallation of patterns-openSUSE-x11_yast-20141007-5.1.i586
     Solution 2: do not install pattern:kde-20141007-5.1.i586
     Solution 3: break pattern:kde-20141007-5.1.i586 by ignoring some of its dependencies
    
    
    Choose from above solutions by number or cancel [1/2/3/c] (c):
    and what is really switching back and forth with xfce and kde?

  9. #9

    Default Re: A problem met switching from kde to xfce

    Quote Originally Posted by wolfi323 View Post
    Regarding your "window style": try removing the files ~/.gtkrc-2.0 and ~/.gtkrc-2.0-kde4. This is where KDE sets the GTK2 style to oxygen (or whatever you choose in "Application Appearance"->GTK) to make GTK applications look "native" inside the KDE session.
    If I take these file away, would I be able to add them back and would I be breaking any dependencies with other packages since I have already introduced a pattern problem?
    Thank you for replying!

  10. #10

    Default Re: A problem met switching from kde to xfce

    I just found out one more thing. I can change the appearance of the xfce desktop environment from the KDE settings by logging into kde desktop environment, but no changes happen if I try to alter the the appearance setting when I am logged into xfce.

    and I don't have these files. ~/.gtkrc-2.0 and ~/.gtkrc-2.0-kde4

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •