I'm having an issue with the Cisco Anyconnect VPN client that seems to be related to how openSUSE handles a user opening a new shell. If I create a new shell by (1) starting gnome-terminal, (2) opening a new tab in gnome-terminal, (3) logging in over SSH, or (4) starting XTerm, the VPN client treats this as a user log-out event and disconnects the VPN session. Any action that creates a new shell in the system causes this. Starting a new instance of bash or zsh in an existing terminal does *not* cause this behavior. However, this issue does *not* reproduce on any other distro I've tried, including Fedora, Arch, Debian, and Ubuntu. I can only reproduce it on openSUSE 13.2 and Tumbleweed. Does anyone know the differences between openSUSE and other distros when it comes to handling a new shell instance?

What I've tried:


  • Different shells (bash, sh, zsh, csh)
  • Different GUIs (gnome-terminal, XTerm, VT login)
  • Removing /etc/profile, /etc/profile.d, and /etc/bash.bashrc (to see if it was something with the login scripts)
  • Replacing /bin/bash with a copy from a Ubuntu system that does not have this problem



And yes, I know openconnect is an option, but this issue is bugging me and I want to find a solution.