Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: 13.2: Gnome 3.14.2: Update notification not automatic

  1. #1
    Join Date
    Jul 2014
    Location
    Pennsylvania, USA
    Posts
    101

    Default 13.2: Gnome 3.14.2: Update notification not automatic

    Hello fellow Geekos,

    I apologize if the solution is obvious. I think I looked everywhere, but can't find a solution to my issue. How do I get automatic update notifications in the Gnome DE for 13.2 without actually pressing the Package Updater manually.

    In 13.1 Gnome, system updates will automatically show in notifications and give me a "heads up" that there are some. Is there a setting somewhere that I'm missing? The Notifications setting seems to be turned on. Is there a conflict somewhere? There seems to be so many ways to actually update a system, that I'm wondering that this might be the case.

    Thanks for your time.

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,495
    Blog Entries
    15

    Default Re: 13.2: Gnome 3.14.2: Update notification not automatic

    On Fri 27 Feb 2015 02:36:01 PM CST, Cuttlefish wrote:


    Hello fellow Geekos,

    I apologize if the solution is obvious. I think I looked everywhere,
    but can't find a solution to my issue. How do I get automatic update
    notifications in the Gnome DE for 13.2 without actually pressing the
    Package Updater manually.

    In 13.1 Gnome, system updates will automatically show in notifications
    and give me a "heads up" that there are some. Is there a setting
    somewhere that I'm missing? The Notifications setting seems to be
    turned on. Is there a conflict somewhere? There seems to be so many
    ways to actually update a system, that I'm wondering that this might be
    the case.

    Thanks for your time.


    Hi
    If it's set to notify, then all should be good (you can also set to
    auto download). Fire up gnome-software and check on the updates tab.

    --
    Cheers Malcolm °¿° LFCS, SUSE Knowledge Partner (Linux Counter #276890)
    SUSE Linux Enterprise Desktop 12 GNOME 3.10.1 Kernel 3.12.36-38-default
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!


  3. #3
    Join Date
    Jul 2014
    Location
    Pennsylvania, USA
    Posts
    101

    Default Re: 13.2: Gnome 3.14.2: Update notification not automatic

    Thanks malcolmlewis. I don't understand where to look. Also, I don't use the gnome-software app to update. I use the Package Updater to update( or zypper). As I said, there appear to be multiple ways to update...I guess it is a bit confusing for opensuse noobs like me.

  4. #4
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,495
    Blog Entries
    15

    Default Re: 13.2: Gnome 3.14.2: Update notification not automatic

    Quote Originally Posted by Cuttlefish View Post
    Thanks malcolmlewis. I don't understand where to look. Also, I don't use the gnome-software app to update. I use the Package Updater to update( or zypper). As I said, there appear to be multiple ways to update...I guess it is a bit confusing for opensuse noobs like me.
    Hi
    Press alt+F2 and enter gnome-software <press enter key> or run from a gnome terminal session. I just use zypper, nothing else
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  5. #5
    Join Date
    Jul 2014
    Location
    Pennsylvania, USA
    Posts
    101

    Default Re: 13.2: Gnome 3.14.2: Update notification not automatic

    Yes, but I mean this.

    http://imgur.com/XIuNhGc

    This is an example from my 13.1 installation. This will appear automatically and that is what I would like. On my 13.2 install I must retrive this manually.

    Maybe I'm looking for an auto download? I'm not sure, except that it should look something like this.

    Thanks

  6. #6
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,495
    Blog Entries
    15

    Default Re: 13.2: Gnome 3.14.2: Update notification not automatic

    Hi
    If the notifications are on and 'on' in the list, then it should appear... there is a cron job (packagekit-background.cron) which runs every 24 hours, which starts from ~15 minutes from the last boot. In 13.2 it's off, maybe in 13.1 it's on?

    I see from zypper there are some updates, will reboot my test system and see if it pops up...
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  7. #7
    Join Date
    Jul 2014
    Location
    Pennsylvania, USA
    Posts
    101

    Default Re: 13.2: Gnome 3.14.2: Update notification not automatic

    Thank you for this!

    Although, I'm not really sure what I'm looking for. When I compare the above with the packagekit-background from 13.1, I see that the SLEEP_MAX is different. Could that be a clue?



    packagekit_background from 13.2:

    Code:
    #!/bin/bash
    # Copyright (C) 2008 Richard Hughes <richard@hughsie.com>
    #
    # Some material taken from yum-cron, Copyright 2007 Alec Habig <ahabig@umn.edu>
    #
    # Licensed under the GNU General Public License Version 2
    # This program is free software; you can redistribute it and/or modify
    # it under the terms of the GNU General Public License as published by
    # the Free Software Foundation; either version 2 of the License, or
    # (at your option) any later version.
    
    [ -f /etc/sysconfig/packagekit-background ] && . /etc/sysconfig/packagekit-background
    
    # are we disabled?
    if [ "$ENABLED" = "no" ]; then
        exit 0
    fi
    
    # set default for SYSTEM_NAME
    [ -z "$SYSTEM_NAME" ] && SYSTEM_NAME=$(hostname)
    
    PKTMP=$(mktemp /var/run/packagekit-cron.XXXXXX)
    PKCON_OPTIONS="--background --noninteractive --plain"
    
    # wait a random amount of time to avoid hammering the servers
    [ -z "$SLEEP_MAX" ] && SLEEP_MAX=$RANDOM
    sleep $(( $RANDOM % $SLEEP_MAX + 1 ))
    
    # do action
    if [ "$CHECK_ONLY" = "yes" ]; then
        pkcon $PKCON_OPTIONS get-updates &> $PKTMP
        PKCON_RETVAL=$?
    else
        pkcon $PKCON_OPTIONS update &> $PKTMP
        PKCON_RETVAL=$?
    fi
    
    # this is when seomthing useful was done
    if [ $PKCON_RETVAL -ne 5 ]; then
        # send email
        if [ -n "$MAILTO" ]; then
            mail -s "System updates available: $SYSTEM_NAME" $MAILTO < $PKTMP
        else
            # default behavior is to use cron's internal mailing of output from cron-script
            cat $PKTMP
        fi
    fi
    
    rm -f $PKTMP


    packagekit_background from 13.1:

    [/CODE}#!/bin/bash
    # Copyright (C) 2008 Richard Hughes <richard@hughsie.com>
    #
    # Some material taken from yum-cron, Copyright 2007 Alec Habig <ahabig@umn.edu>
    #
    # Licensed under the GNU General Public License Version 2
    # This program is free software; you can redistribute it and/or modify
    # it under the terms of the GNU General Public License as published by
    # the Free Software Foundation; either version 2 of the License, or
    # (at your option) any later version.

    [ -f /etc/sysconfig/packagekit-background ] && . /etc/sysconfig/packagekit-background

    # are we disabled?
    if [ "$ENABLED" = "no" ]; then
    exit 0
    fi

    # set default for SYSTEM_NAME
    [ -z "$SYSTEM_NAME" ] && SYSTEM_NAME=$(hostname)

    PKTMP=$(mktemp /var/run/packagekit-cron.XXXXXX)
    PKCON_OPTIONS="--background --noninteractive --plain"

    # wait a random amount of time to avoid hammering the servers
    [ -z "$SLEEP_MAX" ] && SLEEP_MAX=$RANDOM
    sleep $(( $RANDOM % $SLEEP_MAX + 1 ))

    # do action
    if [ "$CHECK_ONLY" = "yes" ]; then
    pkcon $PKCON_OPTIONS get-updates &> $PKTMP
    PKCON_RETVAL=$?
    else
    pkcon $PKCON_OPTIONS update &> $PKTMP
    PKCON_RETVAL=$?
    fi

    # this is when seomthing useful was done
    if [ $PKCON_RETVAL -ne 5 ]; then
    # send email
    if [ -n "$MAILTO" ]; then
    mail -s "System updates available: $SYSTEM_NAME" $MAILTO < $PKTMP
    else
    # default behavior is to use cron's internal mailing of output from cron-script
    cat $PKTMP
    fi
    fi

    rm -f $PKTMP[/CODE]
    Last edited by Cuttlefish; 28-Feb-2015 at 06:20. Reason: wrong code

  8. #8
    Join Date
    Jul 2014
    Location
    Pennsylvania, USA
    Posts
    101

    Default Re: 13.2: Gnome 3.14.2: Update notification not automatic

    Sorry about the above post. I used the wrong code. I think 13.1 and 13.2 packagekit-background cron are both the same.

    Moderator: You may delete it if it causes confusion.

    Thanks.

  9. #9

    Default Re: 13.2: Gnome 3.14.2: Update notification not automatic

    Hi,

    Do you find the solution?
    I would like to have automatic update notifications.

    thanks in advance,

    Noyan

  10. #10

    Default Re: 13.2: Gnome 3.14.2: Update notification not automatic

    I answered this question in this similar thread: https://forums.opensuse.org/showthre...n-Gnome-3-14-1

    I recommend distros have only one way to perform graphical updates by default, to avoid weird confusion like this, but openSUSE really likes choice I suppose.

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •