Results 1 to 6 of 6

Thread: Yast2 Software Manegement quits early

  1. #1

    Default Yast2 Software Manegement quits early

    Hello to the forum.
    Beginner with 13.2 installed to a dual boot with Win7.
    Had 13.1 prior which was crippled by the Win7 install from XP.
    Used a 13.2 usb live iso and followed instructions.
    Installation is successful in all functions tested so far (includes wireless and networking) except the following:
    Have been getting pop-up messages -
    • "Problem connecting to a software origin"
    • Empty destination in URI: hd:///?device =/dev/disk/by-id/scsi-1 SanDisk_numbers......

    I assume this is the usb iso ? and reappears at regular intervals.
    And this error is on screen as I type this
    Then -
    Tried to add Scribus DTP without success (similar errors to those described hereafter).
    So tried repeated online udates - each attempt gets errors as follows -
    Software manager will run and download and install to a variable percentage (sometimes as much as 60%).
    But it always quits early without finishing.
    Errors during this process include - with usb inserted and/or removed -
    • Internal error. Please report bug ....
    • Details = undefined method 'include' for ["cd","dvd"]:Array - Caller: /usr/share/Yast2/modules/PackageCallbacks.rb:812:in 'MediaChange'

    And -
    • Failed to initialise -
    • System management is locked .... /usr/lib/Yast2/bin/y2base)
    • Close this app .....


    Clearly I have missed something but do not know how to get out of this loop.
    Do not how to do a bug report and I do not have permission to post attachments .........

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,153

    Default Re: Yast2 Software Manegement quits early

    Use YaST > Software > Repository Management. Look for that repo (starting with hd://), select it and remove the check Enabled below. Finish.
    Henk van Velden

  3. #3
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,628
    Blog Entries
    3

    Default Re: Yast2 Software Manegement quits early

    Quote Originally Posted by 2wing View Post
    I assume this is the usb iso ? and reappears at regular intervals.
    Yes, it is.

    I'm mostly saying the same as hcvv already said. But maybe two people saying it in different ways will help.

    Yast --> Software Repositories

    That will show a list of configured repositories. Look for the line that begins "hd:///?". That will be the USB iso, treated as a repository.

    Click on that line with your mouse (to select it). Then, lower on the screen, there will be a box with the word "enable" next to it. Uncheck that box. That disables this particular repo. Click "Finish" (or "Okay", or whatever is in the bottom right corner). You will never be bothered by this again. Well, you won't be bothered until you do another install. Then you will need to go through the same procedure again.

    My personal practice:- I leave that repo enabled for a few days after install. If I want to do something with software management or online updates, I make sure that the USB is plugged in. That's because I will want to tweak the collection of installed software, and if a package can be installed from the USB, that will be faster. But, after a few days, when I a reasonably satisfied with my setup, I disable that repo. And I usually leave it disabled.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  4. #4

    Default Re: Yast2 Software Manegement quits early

    Thank you Henk.
    Am on WinXp at the moment (second machine with dual XP and OS13.1).
    Will do as suggested with 13.2 qnd report back.
    Paul

  5. #5

    Default Re: Yast2 Software Manegement quits early

    And thank you to "nrickert" too.
    Have unticked "enabled" as you both suggested.
    Tried an online update and got error (advice warning yellow exclamation point) -
    • Failed to initialise
    • System management is locked .... /usr/lib/YaST2/bin/y2base).
    • Close .......

    But - now have a message that there are over 1k3 updates - so it has found something .....
    Doing a test by installing Scribus from the "oneclick" as the software management route still quits early without finishing.
    (Oneclick has been successful on this machine under 13.1)
    While typing this Scribus has correctly installed on the 13.2 machine.
    So thank you both and I suspect that a full update will cure that last warning message.
    Paul

  6. #6
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,744

    Default Re: Yast2 Software Manegement quits early

    You can not have more then one installer running at a time. close all windows then try again

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •