Hi guys, I've configured an installation server on my LAN using HTTP and everything works fine. My problem is now I want announcing the repo over SLP. So, I follow the steps from this manual:


  • I've created the file /etc/slp.d/install.suse.http.reg and added these lines:

description=Local repo


  • Then I load the daemon using "service slpd start".

//Using "service slpd status" I can see the daemon active (running).


  • Finally, I insert the network install CD on another computer and boot up, then I choose SLP and after some delay an error occurs: "Please make sure your installation medium is available".

//If I type again "service slpd status" on the server, now the daemon is stopped. So, both computers have dialogued and something has been broken on the server.

"service slpd status" replies:

slpd.service - OpenSLP daemon for the Service Location Protocol
Loaded: loaded (/usr/lib/systemd/system/slpd.service; enabled)
Active: failed (Result: signal) since Thu 2015-02-26 09:04:28 WET; 58s ago
Process: 1672 ExecStart=/usr/sbin/slpd -d (code=killed, signal=ABRT)
Main PID: 1672 (code=killed, signal=ABRT)

Feb 26 09:04:28 codex slpd[1672]: *** buffer overflow detected ***: /usr/sbin/slpd terminated

and "journalctl -xn" replies:

feb 26 09:04:28 codex slpd[1672]: *** buffer overflow detected ***: /usr/sbin/slpd terminated

I've configured the daemon as Broadcast and as Multicast modes. Same result.
If I choose HTTP as source and type the same URL on the client everything works fine and the installation starts.
Firewall is stopped on the server.
The system is openSUSE 13.2 x86_64 and openslpd-server version is 2.0.0.

What am I doing wrong? Thanks in advance!