Results 1 to 9 of 9

Thread: Thunderbird changing default printing paper size

  1. #1

    Default Thunderbird changing default printing paper size

    I am beginning to think the people who code T'bird are doing it deliberately to wind europeans up as there are hundreds of bugs relating to this from several years ago and history keeps repeating itself.

    Once again, when I try and print from T'bird it calls for letter size paper.

    My HP printer is set for A4, my environment is set as en-uk, I have amended mozilla config to change line print.postscript.papersize to A4. I have found that the config for T'bird is now not as Mozilla so have edited the config file for T'bird to print.postscript.papersize to A4 but still it defaults to letter size.

    There is one line in particular in confg file I do not understand: print.print_paper_name user set string na_letter. What is na_letter all about and is this the problem.

    Else, can anybody tell me where I am going wrong please. All I want is for when I print from T'bird that it prints to A4 which is the printer default.

    Budgie2

    PS since writing I have found na_letter to be north americal letter and the line suggests that I have set it, which I have not intentionally, so where have I set it? Meanwhile I edited it to A4 but T'bird still tries to use letter size. Getting very p----d off.

  2. #2

    Default Re: Thunderbird changing default printing paper size

    On 02/24/2015 07:36 AM, Budgie2 wrote:
    >
    > I am beginning to think the people who code T'bird are doing it
    > deliberately to wind europeans up as there are hundreds of bugs relating
    > to this from several years ago and history keeps repeating itself.
    >
    > Once again, when I try and print from T'bird it calls for letter size
    > paper.
    >
    > My HP printer is set for A4, my environment is set as en-uk, I have
    > amended mozilla config to change line print.postscript.papersize to A4.
    > I have found that the config for T'bird is now not as Mozilla so have
    > edited the config file for T'bird to print.postscript.papersize to A4
    > but still it defaults to letter size.
    >
    > There is one line in particular in confg file I do not understand:
    > print.print_paper_name user set string na_letter. What is na_letter
    > all about and is this the problem.
    >
    > Else, can anybody tell me where I am going wrong please. All I want is
    > for when I print from T'bird that it prints to A4 which is the printer
    > default.
    >
    > Budgie2
    >
    > PS since writing I have found na_letter to be north americal letter and
    > the line suggests that I have set it, which I have not intentionally, so
    > where have I set it? Meanwhile I edited it to A4 but T'bird still tries
    > to use letter size. Getting very p----d off.
    >
    >


    Open a browser and use

    code
    -------------
    http://localhost:631/printers
    ----------------

    Click on the printer and then on the administration pull-down click on
    "Set default options". There you can set the paper size to what you want.

    Ken

  3. #3
    Join Date
    Nov 2009
    Location
    Pennsylvania, USA
    Posts
    405

    Default Re: Thunderbird changing default printing paper size

    Quote Originally Posted by kensch View Post


    Open a browser and use

    code
    -------------
    http://localhost:631/printers
    ----------------

    Click on the printer and then on the administration pull-down click on
    "Set default options". There you can set the paper size to what you want.

    Ken
    Doing that sets
    Code:
    print.print_paper_name;iso_a4
    The postscript paper size is still.

    Code:
    print.postscript.paper_size;letter
    Desktop: AMD Athlon(tm) II X3 455 3.3 Ghz | 4 GB RAM | GeForce GT 630

  4. #4

    Default Re: Thunderbird changing default printing paper size

    Quote Originally Posted by kensch View Post
    On 02/24/2015 07:36 AM, Budgie2 wrote:
    >
    > I am beginning to think the people who code T'bird are doing it
    > deliberately to wind europeans up as there are hundreds of bugs relating
    > to this from several years ago and history keeps repeating itself.
    >
    > Once again, when I try and print from T'bird it calls for letter size
    > paper.
    >
    > My HP printer is set for A4, my environment is set as en-uk, I have
    > amended mozilla config to change line print.postscript.papersize to A4.
    > I have found that the config for T'bird is now not as Mozilla so have
    > edited the config file for T'bird to print.postscript.papersize to A4
    > but still it defaults to letter size.
    >
    > There is one line in particular in confg file I do not understand:
    > print.print_paper_name user set string na_letter. What is na_letter
    > all about and is this the problem.
    >
    > Else, can anybody tell me where I am going wrong please. All I want is
    > for when I print from T'bird that it prints to A4 which is the printer
    > default.
    >
    > Budgie2
    >
    > PS since writing I have found na_letter to be north americal letter and
    > the line suggests that I have set it, which I have not intentionally, so
    > where have I set it? Meanwhile I edited it to A4 but T'bird still tries
    > to use letter size. Getting very p----d off.
    >
    >


    Open a browser and use

    code
    -------------
    http://localhost:631/printers
    ----------------

    Click on the printer and then on the administration pull-down click on
    "Set default options". There you can set the paper size to what you want.

    Ken
    Hi Ken,
    Many thanks for the suggestion but this is where I first looked and these options are already set for A4 for both printers. They are overruled by a setting somewhere in T'bird.

  5. #5

    Default Re: Thunderbird changing default printing paper size

    On 02/24/2015 12:56 PM, Budgie2 wrote:
    >
    > kensch;2696653 Wrote:
    >> On 02/24/2015 07:36 AM, Budgie2 wrote:
    >>>
    >>> I am beginning to think the people who code T'bird are doing it
    >>> deliberately to wind europeans up as there are hundreds of bugs

    >> relating
    >>> to this from several years ago and history keeps repeating itself.
    >>>
    >>> Once again, when I try and print from T'bird it calls for letter size
    >>> paper.
    >>>
    >>> My HP printer is set for A4, my environment is set as en-uk, I have
    >>> amended mozilla config to change line print.postscript.papersize to

    >> A4.
    >>> I have found that the config for T'bird is now not as Mozilla so have
    >>> edited the config file for T'bird to print.postscript.papersize to A4
    >>> but still it defaults to letter size.
    >>>
    >>> There is one line in particular in confg file I do not understand:
    >>> print.print_paper_name user set string na_letter. What is

    >> na_letter
    >>> all about and is this the problem.
    >>>
    >>> Else, can anybody tell me where I am going wrong please. All I want

    >> is
    >>> for when I print from T'bird that it prints to A4 which is the printer
    >>> default.
    >>>
    >>> Budgie2
    >>>
    >>> PS since writing I have found na_letter to be north americal letter

    >> and
    >>> the line suggests that I have set it, which I have not intentionally,

    >> so
    >>> where have I set it? Meanwhile I edited it to A4 but T'bird still

    >> tries
    >>> to use letter size. Getting very p----d off.
    >>>
    >>>

    >>
    >> Open a browser and use
    >>
    >> code
    >> -------------
    >> http://localhost:631/printers
    >> ----------------
    >>
    >> Click on the printer and then on the administration pull-down click on
    >> "Set default options". There you can set the paper size to what you
    >> want.
    >>
    >> Ken

    > Hi Ken,
    > Many thanks for the suggestion but this is where I first looked and
    > these options are already set for A4 for both printers. They are
    > overruled by a setting somewhere in T'bird.
    >
    >


    OK, try

    code
    ---------
    Edit-->Preferences-->Advanced(tab)-->Config Editor
    ---------
    to open the about:config editor and search for "letter" or "na_letter"
    and see what is set for the printer (NOT) the temp printer settings.

    HTH
    Ken

  6. #6
    Join Date
    Aug 2008
    Location
    Brazil
    Posts
    2,844

    Default Re: Thunderbird changing default printing paper size

    Here with oS 13.2 KDE 4.14.4 it seems that all that's necessary is to set the page to A4 in File>Setup Page.

    Advanced Options, filtered by "paper" show a lot of A4-related values, although there are some (default, not bold) letter values.

  7. #7

    Default Re: Thunderbird changing default printing paper size

    Quote Originally Posted by brunomcl View Post
    Here with oS 13.2 KDE 4.14.4 it seems that all that's necessary is to set the page to A4 in File>Setup Page.

    Advanced Options, filtered by "paper" show a lot of A4-related values, although there are some (default, not bold) letter values.
    Intrigued by your first answer. Exactly where are you using File>Setup Page please? Can you give more info?

    Also Advanced Options where exactly?

    Sorry if I appear dumb but I never did solve this problem.
    Budgie2

  8. #8
    Join Date
    Nov 2009
    Location
    Pennsylvania, USA
    Posts
    405

    Default Re: Thunderbird changing default printing paper size

    If you don't see the Menu bar in Thunderbird, right click in the Tab bar, enable the Menu bar, then File > Page Setup, or from the Menu button > Print > Page Setup.
    Desktop: AMD Athlon(tm) II X3 455 3.3 Ghz | 4 GB RAM | GeForce GT 630

  9. #9

    Default Re: Thunderbird changing default printing paper size

    Quote Originally Posted by rafter22 View Post
    If you don't see the Menu bar in Thunderbird, right click in the Tab bar, enable the Menu bar, then File > Page Setup, or from the Menu button > Print > Page Setup.
    Ah, I have it now. Many thanks. Sorry to be so ignorant.
    Budgie2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •