Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: KF5, wolfis repo, fehlende Abhängigkeit: libkscreen2-plugin

  1. #1

    Default KF5, wolfis repo, fehlende Abhängigkeit: libkscreen2-plugin

    Code:
    #### YaST2 conflicts list - generated 2015-02-24 11:07:28 ####
    
    libkscreen2-plugin >= 5.2.0, benötigt von plasma5-session-5.2.0-59.2.x86_64, wird von keinem Repository angeboten
    
        [ ] plasma5-session-5.2.0-59.2.x86_64 nicht installieren
    
        [ ] plasma5-session-5.2.0-59.2.x86_64 beschädigen durch Ignorieren einiger Abhängigkeiten
    
    
    
    
    #### YaST2 conflicts list END ###
    Ich war neugierig genug, KDE 5 ausprobieren zu wollen. Vielleicht klappt es ja in den nächsten Tagen.

  2. #2

    Default Re: KF5, wolfis repo, fehlende Abhängigkeit: libkscreen2-plugin

    Quote Originally Posted by cookie170 View Post
    Ich war neugierig genug, KDE 5 ausprobieren zu wollen. Vielleicht klappt es ja in den nächsten Tagen.
    Es sollte auch jetzt klappen.

    Aber, libkscreen2-plugin gibt es nicht in meinem Repo. Du brauchst zusätzlich das KDE:Frameworks5 repo dafür, dort gibts libkscreen2-plugin-5.2.0 (bzw. bald 5.2.1)...
    Hast du das?

    Ich baue nur die Pakete die mit KDE4 einen Konflikt haben in meinem Repo (aus verschiedenen Gründen... )
    Für den Rest (vor allem KF5 im Allgemeinen, aber auch Teile von Plasma5 wie eben libkscreen) benötigst du KDE:Frameworks5, außer du benutzt Tumbleweed natürlich. Die Versionen in 13.2 sind bereits zu alt und werden wegen der Update Politik (nur Bugfixes, keine neuen Versionen) auch nicht mehr aktualisiert.

    Im Zweifelsfall poste bitte deine Repo-Liste:
    Code:
    zypper lr -d
    Last edited by wolfi323; 24-Feb-2015 at 03:22.

  3. #3

    Default Re: KF5, wolfis repo, fehlende Abhängigkeit: libkscreen2-plugin

    Quote Originally Posted by wolfi323 View Post
    Es sollte auch jetzt klappen.

    Aber, libkscreen2-plugin gibt es nicht in meinem Repo. Du brauchst zusätzlich das KDE:Frameworks5 repo dafür, dort gibts libkscreen2-plugin-5.2.0 (bzw. bald 5.2.1)...
    Hast du das?

    Ich baue nur die Pakete die mit KDE4 einen Konflikt haben in meinem Repo (aus verschiedenen Gründen... )
    Für den Rest (vor allem KF5 im Allgemeinen, aber auch Teile von Plasma5 wie eben libkscreen) benötigst du KDE:Frameworks5, außer du benutzt Tumbleweed natürlich. Die Versionen in 13.2 sind bereits zu alt und werden wegen der Update Politik (nur Bugfixes, keine neuen Versionen) auch nicht mehr aktualisiert.

    Im Zweifelsfall poste bitte deine Repo-Liste:
    Code:
    zypper lr -d
    OK, dass ich noch KDE:Frameworks5 brauche, wusste ich nicht.

    Allerdings bin ich tatsächlich auf 13.2 und nicht auf Tumbleweed. Bedeutet dies, dass ich dein Repo nicht verwenden kann?

    Ach ja, und vielen Dank für die prompte Antwort!

  4. #4

    Default Re: KF5, wolfis repo, fehlende Abhängigkeit: libkscreen2-plugin

    Quote Originally Posted by cookie170 View Post
    Allerdings bin ich tatsächlich auf 13.2 und nicht auf Tumbleweed. Bedeutet dies, dass ich dein Repo nicht verwenden kann?
    Doch, kannst du. Ich benutze es ja selber auf 13.2 und biete es sogar für 13.1 an.
    Nur musst du eben auch KDE:Frameworks5 zu deiner Repo-Liste hinzufügen, und ebenso KDE:Qt5.

    Die URLs für 13.2:
    http://download.opensuse.org/reposit...openSUSE_13.2/
    http://download.opensuse.org/reposit...openSUSE_13.2/

    Gerade auf Tumbleweed ist das nicht notwendig, da Tumbleweed selbst die neuesten Versionen von Qt5, KF5 und Plasma5 enthält.
    Last edited by wolfi323; 24-Feb-2015 at 03:37.

  5. #5

    Default Re: KF5, wolfis repo, fehlende Abhängigkeit: libkscreen2-plugin

    Quote Originally Posted by wolfi323 View Post
    Doch, kannst du. Ich benutze es ja selber auf 13.2 und biete es sogar für 13.1 an. Nur musst du eben auch KDE:Frameworks5 zu deiner Repo-Liste hinzufügen, und ebenso KDE:Qt5. Die URLs für 13.2: http://download.opensuse.org/reposit...openSUSE_13.2/ http://download.opensuse.org/reposit...openSUSE_13.2/ Gerade auf Tumbleweed ist das nicht notwendig, da Tumbleweed selbst die neuesten Versionen von Qt5, KF5 und Plasma5 enthält.
    Ich habe die Repos, aber es stürzt alles ab (krunner, plasmashell, etc.). Also habe ich irgendwo 'was falsch gemacht.
    Code:
    zypper lr -d #  | Alias                        | Name                                    | Enabled | Refresh | Priority | Type   | URI                                                                                                | Service ---+------------------------------+-----------------------------------------+---------+---------+----------+--------+----------------------------------------------------------------------------------------------------+--------  1 | EDITOR                       | EDITOR                                  | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/editors/openSUSE_13.2/                                   |          2 | INFINALITY                   | INFINALITY                              | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/home:/nick31:/INFINALITY-ULTIMATE/openSUSE_13.2/         |          3 | KDE5/wolfi                   | KDE5/wolfi                              | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/home:/wolfi323:/branches:/KDE:/Frameworks5/openSUSE_13.2 |          4 | KDE:Frameworks5              | KDE:Frameworks5                         | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/KDE:/Frameworks5/openSUSE_13.2/                          |          5 | KDE:Qt5                      | KDE:Qt5                                 | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/KDE:/Qt5/openSUSE_13.2/                                  |          6 | PRINTING                     | PRINTING                                | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/Printing/openSUSE_13.2/                                  |          7 | download.nvidia.com-opensuse | nVidia Graphics Drivers                 | Yes     | Yes     |   99     | rpm-md | http://download.nvidia.com/opensuse/13.2/                                                          |          8 | download.opensuse.org-Extra  | openSUSE BuildService - KDE:Extra       | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/KDE:/Extra/openSUSE_13.2/                                |          9 | download.opensuse.org-Wine   | openSUSE BuildService - Wine-CVS-Pakete | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/Emulators:/Wine/openSUSE_13.2/                           |         10 | ftp.gwdg.de-suse             | Packman Repository                      | Yes     | Yes     |   99     | rpm-md | http://ftp.gwdg.de/pub/linux/packman/suse/openSUSE_13.2/                                           |         11 | openSUSE-13.2-0              | openSUSE-13.2-0                         | Yes     | No      |   99     | yast2  | cd:///?devices=/dev/disk/by-id/ata-MATSHITADVD-RAM_UJ8A2_WK49_570145                               |         12 | opensuse-guide.org-repo      | libdvdcss repository                    | Yes     | Yes     |   99     | rpm-md | http://opensuse-guide.org/repo/13.2/                                                               |         13 | repo-debug                   | openSUSE-13.2-Debug                     | No      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/distribution/13.2/repo/oss/                                     |         14 | repo-debug-update            | openSUSE-13.2-Update-Debug              | No      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/update/13.2/                                                    |         15 | repo-debug-update-non-oss    | openSUSE-13.2-Update-Debug-Non-Oss      | No      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/update/13.2-non-oss/                                            |         16 | repo-non-oss                 | openSUSE-13.2-Non-Oss                   | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/13.2/repo/non-oss/                                       |         17 | repo-oss                     | openSUSE-13.2-Oss                       | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/13.2/repo/oss/                                           |         18 | repo-source                  | openSUSE-13.2-Source                    | No      | Yes     |   99     | NONE   | http://download.opensuse.org/source/distribution/13.2/repo/oss/                                    |         19 | repo-update                  | openSUSE-13.2-Update                    | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/update/13.2/                                                          |         20 | repo-update-non-oss          | openSUSE-13.2-Update-Non-Oss            | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/update/13.2-non-oss/
    Aber ich gehe dem mal in Ruhe nach, KDE 4 tut ja noch. Gruß, Alexander

  6. #6

    Default Re: KF5, wolfis repo, fehlende Abhängigkeit: libkscreen2-plugin

    Hm, gibt es eine saubere Art, KF5 zu deinstallieren, einschließlich des Eintrags in KDM?

  7. #7

    Default Re: KF5, wolfis repo, fehlende Abhängigkeit: libkscreen2-plugin

    Hallo, ich hab's. Da waren ein paar rpms aus dem KF5 und dem Qt5 repo nicht mitaktualisiert worden. Erster Eindruck: pervers schnell. Whoa.

  8. #8

    Default Re: KF5, wolfis repo, fehlende Abhängigkeit: libkscreen2-plugin

    Quote Originally Posted by cookie170 View Post
    Ich habe die Repos, aber es stürzt alles ab (krunner, plasmashell, etc.). Also habe ich irgendwo 'was falsch gemacht.
    Vermutlich hast du bereits ältere Pakete aus 13.2 installiert (Qt5 vor allem, das wird ja in 13.2 standardmäßig installiert weil YaST mittlerweile Qt5 verwendet), die jetzt nicht automatisch aktualisiert wurden. Und ein Mix von unterschiedlichen Versionen kann sowieso immer Probleme machen...
    Probier mal folgendes, um eine Aktualisierung aller Pakete zu erzwingen:
    Code:
    sudo zypper dup --from 3 --from 4 --from 5
    Dann sollts eigentlich gehen.

    Quote Originally Posted by cookie170 View Post
    Hm, gibt es eine saubere Art, KF5 zu deinstallieren, einschließlich des Eintrags in KDM?
    Tja, ich würde den Repository-View in YaST verwenden: Auf den "Ansicht"-Knopf klicken und "Installationsquellen" auswählen.
    Dort dann die entsprechenden Repos (also meins und KDE:Frameworks5) auswählen, mit der rechten Maustaste auf die Paketliste klicken und "Alle in dieser Liste"->"Löschen" auswählen.
    Falls du Konflikte bekommst und dir nicht sicher bist, frag bitte nach.

    Wenn du Qt5 auch wieder downgraden willst, musst du das leider händisch machen, mit "Versionen" unter der Paketliste. Obwohl vermutlich reichts sogar _ein_ Paket downzugraden, der Rest sollte dann automatisch nachgezogen werden wegen der Abhängigkeiten...

  9. #9

    Default Re: KF5, wolfis repo, fehlende Abhängigkeit: libkscreen2-plugin

    Quote Originally Posted by cookie170 View Post
    Hallo, ich hab's. Da waren ein paar rpms aus dem KF5 und dem Qt5 repo nicht mitaktualisiert worden.
    Ah ja. Dann war meine Vermutung also richtig...

    Erster Eindruck: pervers schnell. Whoa.
    Tja, hängt natürlich auch von der Hardware ab...

    Übrigens, mein Repo enthält bereits auch eine Menge Vorversionen von KDE-Applikationen. Schau einfach in YaST's Repository-Ansicht, was vorhanden ist und installier die gewünschten Pakete manuell. Momentan kommt da immer wieder noch was dazu, je nach upstream Verfügbarkeit...

    Z.B. kmix5 ist ein Must-Have (und soweit ich mich erinnere wird das noch nicht automatisch mitinstalliert), damit du einen Lautstärkeregler hast.
    Last edited by wolfi323; 24-Feb-2015 at 04:13.

  10. #10

    Default Re: KF5, wolfis repo, fehlende Abhängigkeit: libkscreen2-plugin

    Ja danke, Lautstärkeregler wäre nicht schlecht. Wie kriege ich denn die Kontrollleiste wieder transparent?

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •