Results 1 to 2 of 2

Thread: K3b can't seem to burn BD50 ISO images

  1. #1

    Default K3b can't seem to burn BD50 ISO images

    I have an LG Blu-ray burner HL-DT-ST - BD-RE BH12LS30 (hw identical to BH10LS30), with the latest firmware (VER. 1.01-C0), and I've tried to burn several BD50 ISO images using K3b without success. K3b recognizes the drive and empty media but when I open 'Burn image' dialog and select a path to a BD50 ISO image message box reads: 'Seems not to be a usable image'. I've tried changing 'Image type' but it doesn't seem to matter. I can however make data compilation and burn that onto BD25 media (didn't tested BD50 yet). I strongly suspect K3b's 'Burn image' tool/dialog is at fault, because it doesn't even try to initialize the whole process.


    I'm using openSUSE 13.2 x86-64, KDE 4.14.4 and the latest K3b from Packman repo (k3b-2.0.80+git20150209.2250-1.1.x86_64.rpm). I've updated all relevant burning programs and libraries using openSUSE's Multimedia:apps and Multimedia:libs repos.


    I've also tried using openSUSE's stock (OSS) version of K3b (k3b-2.0.2-33.1.8.x86_64.rpm), as well as the one from KDE:Extra (k3b-2.0.3-25.1.x86_64.rpm), and tried many different BD50 ISO images with all three K3b version but it always ends with: Seems not to be a usable image. I should also mention that I've added my user account to 'cdrom' group and changed permissions on relevant programs through K3b Settings dialog.


    Finally, I've rebooted to WinXP and burned those images using ImgBurn without any troubles. I've also verified burned disks and tested them in a standalone BD player. They are fine.


    I like K3b very much and I had been using it since ever, but problem with BD50 ISO image burning is really a showstopper for me.


    In the meantime I obtained evaluation copy of Nero for Linux 4.0 and it burned the ISO images that K3b wouldn't even touch. Disks are playing just fine both in VLC and on the standalone player. I didn't tried yet ImgBurn under Wine, nor any other burning app because BD50 coasters are not cheap.


    Any ideas what might be the problem?


    I have the original cdrtools (cdda2wav, cdrecord and mkisofs ver. 3.01a27) from Multimedia:apps. I didn't installed cdrkit-cdrtools-compat, wodim nor icedax, but I did zypper duped form openSUSE 13.1 couple of months ago, only I wasn't using BD burner back then and I believe that I didn't had any of those packages installed so it shouldn't be relevant to this problem. As I've said, I strongly suspect it's K3b's 'Burn image' tool/dialog fault.


    P.S. Here's a list of all relevant programs and their versions that I have on my system.


    Code:
    openSUSE 13.2 (x86_64), kernel version 3.16.7-7-desktop
    
    /usr/bin/cdrdao         1.2.3-14.1
    /usr/bin/cdrecord       3.01~a27-34.1
    /usr/bin/dvd+rw-format  7.1-63.1
    /usr/bin/growisofs      7.1-63.1
    /usr/bin/mkisofs        3.01~a27-34.1
    /usr/bin/normalize      0.7.7-1.1
    /usr/bin/readcd         3.01~a27-34.1
    /usr/bin/sox            14.4.1-38.2
    /usr/bin/transcode      1.1.5-110.1
    /usr/bin/vcdxbuil       0.7.24cvs-12.1.2
    /usr/bin/vcdxminfo      0.7.24cvs-12.1.2
    /usr/bin/vcdxrip        0.7.24cvs-12.1.2

  2. #2

    Default Re: K3b can't seem to burn BD50 ISO images

    I've tried mounting some BD50 ISOs using Silicon Mounter and the program halted with an error message:


    Can't complete the mount operation


    init: wrong standard identifier in volume descriptor 0, skipping..
    ...
    init: wrong standard identifier in volume descriptor 16, skipping..
    init: wrong standard identifier in volume descriptor 17, exiting..

    I suspect that most of burning programs still expect ISO9660 and return error when confronted with an ISO image containing IEC 13346 (UDF) structure.


    However, I've successfully mounted the image using loop device.


    Code:
    sudo mount -o loop -t udf /path/to/image.iso /path/to/mount/point

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •