Results 1 to 6 of 6

Thread: gnome3 topbar altijd op het verkeerde scherm na startup (nvidia)

  1. #1

    Default gnome3 topbar altijd op het verkeerde scherm na startup (nvidia)

    ik heb 2 schermen, na het opstarten staat de gnomeshell topbar altijd op het 2de scherm ipv op het 1ste scherm. als ik het aanpas in nvidiasettings als root staat het wel juist maar na startup staat alles weer fout. het lijkt erop dat de nvidia settings configfile niet geladen wordt bij het opstarten ofzo. heeft er iemand een oplossing hiervoor?

  2. #2
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,905
    Blog Entries
    14

    Default Re: gnome3 topbar altijd op het verkeerde scherm na startup (nvidia)

    Quote Originally Posted by seven View Post
    ik heb 2 schermen, na het opstarten staat de gnomeshell topbar altijd op het 2de scherm ipv op het 1ste scherm. als ik het aanpas in nvidiasettings als root staat het wel juist maar na startup staat alles weer fout. het lijkt erop dat de nvidia settings configfile niet geladen wordt bij het opstarten ofzo. heeft er iemand een oplossing hiervoor?
    Hey, welkom

    Welke openSUSE versie hebben we 't over?

    Ik werk zelf niet met twee (of meer) schermen, maar dit zijn dingen die je volgens mij tegenwoordig op gebruikersniveau regelt, dwz. in de GNOME configuratie. Met nvidia-settings maak je een xorg.conf aan voor zover ik weet, en die wordt hoe dan ook ingelezen. Ik zou die /etc/X11/xorg.conf eerst 's weer wegmikken, en het systeem zelf de boel laten uitzoeken. Inloggen op GNOME, en dan in de GNOME configuratie - Display en monitor kijken wat daar niet goed staat. Waarschijnlijk "ziet" het systeem de schermen net andersom dan jij.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  3. #3

    Default Re: gnome3 topbar altijd op het verkeerde scherm na startup (nvidia)

    hoi, dank je voor de snelle respons

    ik gebruik 13.2 met gnomeshell met de nvidiadriver 340.76. ik verander de scherm volgorde met de nvidia tool en met de gnome display tool. de gnome displaytool heeft geen effect. de nvidia tool lost het op voor de huidige sessie en ik save alles met de xorg.conf file maar na een herstart staat alles terug op het verkeerde scherm. tis alsof de xorg.conf file niet gelezen wordt bij het opstarten.

  4. #4
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,905
    Blog Entries
    14

    Default Re: gnome3 topbar altijd op het verkeerde scherm na startup (nvidia)

    Quote Originally Posted by seven View Post
    hoi, dank je voor de snelle respons

    ik gebruik 13.2 met gnomeshell met de nvidiadriver 340.76. ik verander de scherm volgorde met de nvidia tool en met de gnome display tool. de gnome displaytool heeft geen effect. de nvidia tool lost het op voor de huidige sessie en ik save alles met de xorg.conf file maar na een herstart staat alles terug op het verkeerde scherm. tis alsof de xorg.conf file niet gelezen wordt bij het opstarten.
    Mmmm. Kun je 's output posten ( tussen CODE tags, gebruik daarvoor het # uit de opmaakknoppen :
    Code:
    cat /etc/X11/xorg.conf
    ls -l /etc/X11/xorg.conf.d
    ls -l /root
    Al jaren geleden werd aangekondigd dat xorg.conf "deprecated" werd ( op de lijst om afgeschaft te worden ). Als je dan toch Xorg handmatig aan wilt sturen, zou je dat moeten doen via .conf bestanden in /etc/X11/xorg.conf.d
    Volgens de docs zou echter xorg.conf nog steeds ingelezen moeten worden. Het lijkt er dus op, dat die niet daar terecht komt waar-ie zou moeten staan, vandaar dat ik ook om de inhoud van /root vraag.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  5. #5

    Default Re: gnome3 topbar altijd op het verkeerde scherm na startup (nvidia)

    cat /etc/X11/xorg.conf
    seven@linux-tb0u:~> cat /etc/X11/xorg.conf
    # nvidia-settings: X configuration file generated by nvidia-settings
    # nvidia-settings: version 340.76 (buildmeister@swio-display-x86-rhel47-01) Thu Jan 22 12:12:09 PST 2015




    Section "ServerLayout"
    Identifier "Layout0"
    Screen 0 "Screen0" 0 0
    InputDevice "Keyboard0" "CoreKeyboard"
    InputDevice "Mouse0" "CorePointer"
    Option "Xinerama" "0"
    EndSection


    Section "Files"
    EndSection


    Section "Module"
    Load "dbe"
    Load "extmod"
    Load "type1"
    Load "freetype"
    Load "glx"
    EndSection


    Section "InputDevice"


    # generated from data in "/etc/sysconfig/mouse"
    Identifier "Mouse0"
    Driver "mouse"
    Option "Protocol" "IMPS/2"
    Option "Device" "/dev/input/mice"
    Option "Emulate3Buttons" "yes"
    Option "ZAxisMapping" "4 5"
    EndSection


    Section "InputDevice"


    # generated from default
    Identifier "Keyboard0"
    Driver "kbd"
    EndSection


    Section "Monitor"


    # HorizSync source: edid, VertRefresh source: edid
    Identifier "Monitor0"
    VendorName "Unknown"
    ModelName "Medion MD 20430"
    HorizSync 29.0 - 81.0
    VertRefresh 55.0 - 76.0
    Option "DPMS"
    EndSection


    Section "Monitor"


    # HorizSync source: edid, VertRefresh source: edid
    Identifier "Monitor1"
    VendorName "Unknown"
    ModelName "Medion MD 20430"
    HorizSync 29.0 - 81.0
    VertRefresh 55.0 - 76.0
    Option "DPMS"
    EndSection


    Section "Device"
    Identifier "Device0"
    Driver "nvidia"
    VendorName "NVIDIA Corporation"
    BoardName "GeForce GTX 760"
    EndSection


    Section "Device"
    Identifier "Device1"
    Driver "nvidia"
    VendorName "NVIDIA Corporation"
    BoardName "GeForce GTX 760"
    BusID "PCI:1:0:0"
    Screen 1
    EndSection


    Section "Screen"
    Identifier "Screen0"
    Device "Device0"
    Monitor "Monitor0"
    DefaultDepth 24
    Option "Stereo" "0"
    Option "nvidiaXineramaInfoOrder" "DFP-0"
    Option "metamodes" "DVI-I-1: nvidia-auto-select +0+0, DVI-D-0: nvidia-auto-select +1920+0"
    Option "SLI" "Off"
    Option "MultiGPU" "Off"
    Option "BaseMosaic" "off"
    SubSection "Display"
    Depth 24
    EndSubSection
    EndSection


    Section "Screen"
    Identifier "Screen1"
    Device "Device1"
    Monitor "Monitor1"
    DefaultDepth 24
    Option "Stereo" "0"
    Option "metamodes" "DVI-D-0: nvidia-auto-select +0+0"
    Option "SLI" "Off"
    Option "MultiGPU" "Off"
    Option "BaseMosaic" "off"
    SubSection "Display"
    Depth 24
    EndSubSection
    EndSection

    ls -l /root
    -rw------- 1 root root 205 Feb 20 18:49 .bash_history
    drwxr-xr-x 2 root root 4096 Sep 25 10:12 bin
    drwx------ 4 root root 4096 Feb 20 18:47 .cache
    drwxr-xr-x 8 root root 4096 Feb 20 18:46 .config
    drwx------ 3 root root 4096 Feb 19 05:49 .dbus
    drwxr-xr-x 2 root root 4096 Feb 20 18:46 Desktop
    drwx------ 2 root root 4096 Sep 25 10:12 .gnupg
    drwxr-xr-x 4 root root 4096 Feb 19 11:40 inst-sys
    drwxr-xr-x 3 root root 4096 Feb 19 11:00 .local
    -rw-r--r-- 1 root root 2276 Feb 20 00:14 .nvidia-settings-rc
    -rw------- 1 root root 110 Feb 20 18:57 .xauthvzYV3x




    ls -l /etc/X11/xorg.conf.d

    total 44
    -rw-r--r-- 1 root root 320 Feb 19 11:02 00-keyboard.conf
    -rw-r--r-- 1 root root 320 Feb 19 05:51 00-keyboard.conf.backup
    -rw-r--r-- 1 root root 1099 Dec 18 15:09 10-evdev.conf
    -rw-r--r-- 1 root root 509 Feb 4 19:04 10-libvnc.conf
    -rw-r--r-- 1 root root 484 Oct 6 22:49 11-evdev.conf
    -rw-r--r-- 1 root root 529 Jul 1 2011 50-device.conf
    -rw-r--r-- 1 root root 527 Jul 1 2011 50-monitor.conf
    -rw-r--r-- 1 root root 491 Jul 1 2011 50-screen.conf
    -rw-r--r-- 1 root root 1913 Oct 6 22:50 50-synaptics.conf
    -rw-r--r-- 1 root root 115 Oct 7 02:43 50-vmmouse.conf
    -rw-r--r-- 1 root root 858 Oct 7 02:43 50-wacom.conf

  6. #6
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,905
    Blog Entries
    14

    Default Re: gnome3 topbar altijd op het verkeerde scherm na startup (nvidia)

    Dank je, maar graag tussen CODE tags, het "#" teken in de opmaakknoppen.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •