Results 1 to 10 of 10

Thread: Kstars and telescope control - Ekos and INDI

  1. #1

    Default Kstars and telescope control - Ekos and INDI

    I seem to have a problem. I have installed Kstars and the INDI library however I find no signs of Ekos. I gained the impression that Ekos is part of Kstars but I can't see any signs of it.

    John
    -

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,977

    Default Re: Kstars and telescope control - Ekos and INDI

    Do you mind at least telling us what version of openSUSE you use.

    And I assume that a bit more explanation about what you do, what you expected to happen and what happened instead, might help your potential helpers getting a bit of an idea what your problem is.
    Henk van Velden

  3. #3

    Default Re: Kstars and telescope control - Ekos and INDI

    And in addition to your openSUSE version, you should also tell which version of kstars you are using (and maybe even from what repo).

    The latest version is actually compiled _without_ INDI support at all.
    From the build log of the package in KDE:Current e.g.:
    Code:
    [  138s] -- checking for module 'libindi>=0.9.8'
    [  138s] --   package 'libindi>=0.9.8' not found
    [  138s] -- Could NOT find INDI (missing:  INDI_INCLUDE_DIR INDI_LIBRARIES INDI_DRIVER_LIBRARIES INDI_MAIN_LIBRARIES INDI_CLIENT_LIBRARIES) (Required is at least version "0.9.8")
    The problem is that openSUSE's libindi is too old.
    13.2 ships with 0.9.7, and that's also the version in Factory/Tumbleweed.

    You probably should file a bug report about that...

    The older kstars (4.11.5) package that's included in 13.1 OTOH still has INDI support.
    Last edited by wolfi323; 18-Feb-2015 at 14:07.

  4. #4

    Default Re: Kstars and telescope control - Ekos and INDI

    Sorry about that. I'm trying to set it up on 13.2. Does this mean that 13.1 would run on 13.2? Kstars is the one for 13.2.

    John
    -

  5. #5

    Default Re: Kstars and telescope control - Ekos and INDI

    Quote Originally Posted by John_82 View Post
    Does this mean that 13.1 would run on 13.2?
    Hm? What does that mean? Of course 13.1 wouldn't run on 13.2, that doesn't make sense...

    But yes, you should be able to install and run kstars 4.11.5 from openSUSE 13.1 on openSUSE 13.2.
    But you would need to install libcfitsio1 from 13.1 as well to fulfill the dependencies. 13.2 only comes with libcfitsio2.

    I don't know whether libindi-0.9.7 (from 13.2) and libindi-0.9.6 (from 13.1) are compatible enought to run kstars built against 0.9.6 with 0.9.7 though, or whether there might be problems because other libraries are a different version. But I'd suppose it should work.
    I just tried and it starts at least (and shows INDI and Ekos in the settings).

    To install it, run this:
    Code:
    sudo rpm -Uvh --oldpackage http://download.opensuse.org/repositories/openSUSE:/13.1:/Update/standard/x86_64/kstars-4.11.5-226.3.x86_64.rpm http://download.opensuse.org/repositories/openSUSE:/13.1/standard/x86_64/libcfitsio1-3.350-2.1.2.x86_64.rpm
    And better lock kstars afterwards...

    But again, you should report this, so that it could be fixed for Tumbleweed and 13.3 at least. No idea whether an update of libindi to 0.9.8 (or higher) is acceptable for 13.2 though.

  6. #6

    Default Re: Kstars and telescope control - Ekos and INDI

    I've found a src rpm here

    http://rpmfind.net/linux/RPM/opensus...-8.8.i586.html

    However when i try and install it I get a back end doesn't support installation message ??????????????

    I have used YAST and the package search without any problems but haven't had need to install an rpm directly yet. In the past that has just worked anyway but I can't recollect ever installing a src rpm. I have installed the usual C C++ stuff.

    INDI have just released Version 1 but I suspect that is a feature increase.

    I'm hampered a little at the moment, typing on a 12.3 desktop and installing on an HP netbook running 13.2. I wish there was a 13.3 beta about, I've held on for too long on 12.3 expecting 13.3.

    John
    -

  7. #7

    Default Re: Kstars and telescope control - Ekos and INDI

    I found the answer to installing src rpm's. Rpmbuild - but YAST shows it as rpm-build, the command is rpmbuild and for some reason needs the path from // to the src rpm.

    This rpm mentions Ekos so may include it. The depend's suggest it might too.

    John
    -

  8. #8

    Default Re: Kstars and telescope control - Ekos and INDI

    Quote Originally Posted by John_82 View Post
    I found the answer to installing src rpm's. Rpmbuild - but YAST shows it as rpm-build, the command is rpmbuild and for some reason needs the path from // to the src rpm.

    This rpm mentions Ekos so may include it. The depend's suggest it might too.
    But you need to install libindi-devel>=0.9.8 before you build kstars. Otherwise it will again be built without libindi support. As I already wrote, the libindi in openSUSE (even in Factory) is too old for current kstars versions (the KDE4 version needs 0.9.8 at least, whereas the KF5 version even requires 1.0.0 already).

    And yes, libindi 1.0 is a major version increase (and the installed file is named libindi.so.1 instead of libindi.so.0), so rather not an option for an official update for 13.2 (although 0.9.8 might be).
    Last edited by wolfi323; 19-Feb-2015 at 05:40.

  9. #9

    Default Re: Kstars and telescope control - Ekos and INDI

    Thanks Wolfi I have just compiled the original KDE 4.14 Kstars source without any problems but looks like i should now try the same with the lNDI libs and doing it again. Rushing I missed your comment about the version of that needed.

    I didn't watch all of the output as it took some time but did see some not 64 bit errors early on. I assume that was just configuration doing it's thing.

    I will bug report this problem later.

    John
    -

  10. #10

    Default Re: Kstars and telescope control - Ekos and INDI

    FYI, libindi has been updated to 1.0.0 in Factory/Tumbleweed last weekend.
    I am building it in my KDE:Frameworks5 repo for 13.2, to be able to provide kstars5 with indi support:
    http://software.opensuse.org/package/libindi1

    If you want to build kstars with indi support yourself, you need to install libindi-devel of course.
    And I would use the src.rpm to rebuild it, this should automatically install all build dependencies.

    If you don't succeed, I could build you a kstars 14.12.x against libindi-1.0.0 on OBS...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •