Page 3 of 5 FirstFirst 12345 LastLast
Results 21 to 30 of 49

Thread: Can't install opensuse 13.2 with UEFI boot mode

  1. #21
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,760

    Default Re: Can't install opensuse 13.2 with UEFI boot mode

    Odd it does not appear to be GPT formatted. That may be where the trouble is.

  2. #22
    Join Date
    Feb 2015
    Location
    Brazil
    Posts
    15

    Default Re: Can't install opensuse 13.2 with UEFI boot mode

    Quote Originally Posted by gogalthorp View Post
    Odd it does not appear to be GPT formatted. That may be where the trouble is.
    How do I fix it?

  3. #23
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,760

    Default Re: Can't install opensuse 13.2 with UEFI boot mode

    Re do the drive and make it GPT I think you can use gdisk

    do
    man gdisk for info

  4. #24
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,755
    Blog Entries
    3

    Default Re: Can't install opensuse 13.2 with UEFI boot mode

    Quote Originally Posted by walter_white View Post
    After creating the bootable usb, if I choose legacy boot the installation screen shows up just OK.
    If I choose UEFI boot, the grub prompt is what I get. It's frustrating.
    A grub prompt is normal on UEFI boot. There should still be a menu with an option to choose "Installation". Or are you saying that there is no grub2 menu? If there is no grub2 menu, then something is wrong with that flash drive.

    After doing the "dd" to copy the iso to the flash drive, try rebooting to make sure that all buffers have been flushed to the devices. Don't unplug the USB until you see the boot splash screen. This should not be necessary, but you could try it.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  5. #25
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,760

    Default Re: Can't install opensuse 13.2 with UEFI boot mode

    I think an EFI install on a non GPT drive may be the problem ie hi i'm install EFI mode where is the GPT partition table oops is none drop to prompt

  6. #26
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,755
    Blog Entries
    3

    Default Re: Can't install opensuse 13.2 with UEFI boot mode

    Quote Originally Posted by gogalthorp View Post
    Odd it does not appear to be GPT formatted. That may be where the trouble is.
    That's normal. The opensuse install isos are using legacy MBR hybrid partition, with a partition type code of "ef" to indicate an EFI partition. That seems to work.

    As I recall, they used "GPT" for the 12.3 Beta, then changed to the current format after that. I think I know why. Once you use GPT partitioning on a drive, it leaves traces behind that makes it hard to use that drive for anything else.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  7. #27
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,760

    Default Re: Can't install opensuse 13.2 with UEFI boot mode

    Not the install media the hard drive target. It is not GPT but has EFI partition. My supposition is that the installer thinking it is installing to a GPT drive looks for the GPT partition table and does not find it and chocks. The OP says that booting the installer in legacy mode gets him to the menu. Booting in EFI mode and noda. But the Drive does have an EFI boot partition but fdisk does not say it is GPT

  8. #28
    Join Date
    Feb 2015
    Location
    Brazil
    Posts
    15

    Post Re: Can't install opensuse 13.2 with UEFI boot mode

    Quote Originally Posted by gogalthorp View Post
    Re do the drive and make it GPT I think you can use gdisk
    I just did what you told me. Using ImageWriter from openSUSE.

    Code:
     sudo fdisk -l /dev/sdb
    [sudo] password for paludo: 
    
    
    Disk /dev/sdb: 8019 MB, 8019509248 bytes
    64 heads, 32 sectors/track, 7648 cylinders, total 15663104 sectors
    Units = sectors of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    Disk identifier: 0x10ce3e4f
    
    
       Device Boot      Start         End      Blocks   Id  System
    /dev/sdb1            3584       11647        4032   ef  EFI (FAT-12/16/32)
    /dev/sdb2   *       11648     9138175     4563264   17  Hidden HPFS/NTFS
    Same thing as before, if it is an issue is with ImageWriter, right?

    Code:
    $ sudo gdisk /dev/sdb
    GPT fdisk (gdisk) version 0.8.8
    
    
    Partition table scan:
      MBR: MBR only
      BSD: not present
      APM: not present
      GPT: not present
    
    
    
    
    ***************************************************************
    Found invalid GPT and valid MBR; converting MBR to GPT format
    in memory. THIS OPERATION IS POTENTIALLY DESTRUCTIVE! Exit by
    typing 'q' if you don't want to convert your MBR partitions
    to GPT format!
    ***************************************************************
    
    
    
    
    Command (? for help): r
    
    
    Recovery/transformation command (? for help): g
    
    
    Warning: 0xEE partition doesn't start on sector 1. This can cause problems
    in some OSes.
    
    
    MBR command (? for help): w
    
    
    Converted 2 partitions. Finalize and exit? (Y/N): Y
    GPT data structures destroyed! You may now partition the disk using fdisk or
    other utilities.
    
    
    Warning: 0xEE partition doesn't start on sector 1. This can cause problems
    in some OSes.
    After using gdisk. No luck at all.

    Code:
    $ sudo fdisk -l /dev/sdb
    
    
    Disk /dev/sdb: 8019 MB, 8019509248 bytes
    247 heads, 62 sectors/track, 1022 cylinders, total 15663104 sectors
    Units = sectors of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    Disk identifier: 0x00000000
    
    
       Device Boot      Start         End      Blocks   Id  System
    /dev/sdb1            3584       11647        4032   ef  EFI (FAT-12/16/32)
    /dev/sdb2           11648     9138175     4563264    7  HPFS/NTFS/exFAT
    I don't know what else to do. I just want to install openSUSE using UEFI boot mode.
    I'm kind of stubborn, I'll keep trying till I got this thing working.

  9. #29
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,760

    Default Re: Can't install opensuse 13.2 with UEFI boot mode

    no no no no

    Want to se the info from the drive you are installing to. I thought that is what you gave me but you gave me the USB info not the HD info. Arg

    Re image the USB it was OK it is the HD that is of interest not the USB

  10. #30
    Join Date
    Feb 2015
    Location
    Brazil
    Posts
    15

    Default Re: Can't install opensuse 13.2 with UEFI boot mode

    Quote Originally Posted by nrickert View Post
    A grub prompt is normal on UEFI boot. There should still be a menu with an option to choose "Installation". Or are you saying that there is no grub2 menu? If there is no grub2 menu, then something is wrong with that flash drive.

    After doing the "dd" to copy the iso to the flash drive, try rebooting to make sure that all buffers have been flushed to the devices. Don't unplug the USB until you see the boot splash screen. This should not be necessary, but you could try it.
    What I see is this: http://imgur.com/p5aqJvL

    Generally I do "dd" and "sync" command after.

Page 3 of 5 FirstFirst 12345 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •