Results 1 to 10 of 10

Thread: LibreOffice Base Issues with 13.2

  1. #1

    Default LibreOffice Base Issues with 13.2

    I recently migrated to 13.2 from 13.1 (clean install new drive) previously running LO 4.1.6.2 Build ID: 410m0(Build:2) and now running LO 4.3.5.2.0+ Build ID: 430m0(Build:2). Running the new LO Base I see two issues:

    First - Base wizards do not run in tables, query, forms or reports
    Second - Creation of table, query, form or reports in design view work fine.
    Third - When I try to run a report I get the following message

    the document report 1 could not be opened
    javaloader error - could not find class
    com/sun/star/comp/loader/JavaLoader

    I would appreciate guidance or direction to handle these issues since the pevious LO Base served my needs but the present one does not

  2. #2

    Default Re: LibreOffice Base Issues with 13.2

    See http://bugzilla.opensuse.org/show_bug.cgi?id=906688
    https://forums.opensuse.org/showthre...2-installation
    https://forums.opensuse.org/showthre...uting-a-report

    Install libreoffice from the LibreOffice:4.3 repo (add the repo in YaST's Community Repositories and switch libreoffice (all packages to be sure) to the version from this repo: https://en.opensuse.org/SDB:Vendor_change_update), and it should work.
    You also need the package pentaho-reporting-flow-engine for opening reports, this is probably not installed automatically.

  3. #3

    Default Re: LibreOffice Base Issues with 13.2

    Quote Originally Posted by wolfi323 View Post
    See http://bugzilla.opensuse.org/show_bug.cgi?id=906688
    https://forums.opensuse.org/showthre...2-installation
    https://forums.opensuse.org/showthre...uting-a-report

    Install libreoffice from the LibreOffice:4.3 repo (add the repo in YaST's Community Repositories and switch libreoffice (all packages to be sure) to the version from this repo: https://en.opensuse.org/SDB:Vendor_change_update), and it should work.
    You also need the package pentaho-reporting-flow-engine for opening reports, this is probably not installed automatically.
    Thanks for your note and suggestions. Looking at Yast and alternative build services repro the replacement I see for LO installed is 4.3.5.2-18.1-x86_64. All the others are lesser numbers of the sequence. Is this correct? The pento package installed without incident.

  4. #4

    Default Re: LibreOffice Base Issues with 13.2

    Quote Originally Posted by newbuilder View Post
    Looking at Yast and alternative build services repro the replacement I see for LO installed is 4.3.5.2-18.1-x86_64
    Yes, this is indeed the package from LibreOffice:4.3.
    Just installing that should solve the problem.

    But I'd still recommend to switch all libreoffice packages to the versions from that repo, otherwise you might (will) get problems whenever there is an update. And the repo contains slightly newer versions of most things, where additional bugs might be fixed.
    See https://en.opensuse.org/SDB:Vendor_c..._Vendor_change in particular for an easy way to do that.
    Last edited by wolfi323; 14-Feb-2015 at 10:43.

  5. #5

    Default Re: LibreOffice Base Issues with 13.2

    Quote Originally Posted by wolfi323 View Post
    Yes, this is indeed the package from LibreOffice:4.3.
    Just installing that should solve the problem.

    But I'd still recommend to switch all libreoffice packages to the versions from that repo, otherwise you might (will) get problems whenever there is an update. And the repo contains slightly newer versions of most things, where additional bugs might be fixed.
    See https://en.opensuse.org/SDB:Vendor_c..._Vendor_change in particular for an easy way to do that.
    Thank you again for your help. I have switched all LibreOffice packages to the build service version. All parts of the Base package work as expected.

  6. #6
    Join Date
    Oct 2009
    Location
    Sweden
    Posts
    1,015

    Default Re: LibreOffice Base Issues with 13.2

    Quote Originally Posted by wolfi323 View Post
    Yes, this is indeed the package from LibreOffice:4.3.
    Just installing that should solve the problem.

    But I'd still recommend to switch all libreoffice packages to the versions from that repo, otherwise you might (will) get problems whenever there is an update. And the repo contains slightly newer versions of most things, where additional bugs might be fixed.
    See https://en.opensuse.org/SDB:Vendor_c..._Vendor_change in particular for an easy way to do that.
    Dident Help me.. Libreoffice latest repo? Yast2 Repo? and..

    regards?
    I'm shameless like others in the forum -was I to any help or made sense? If yes: click the on the star below to the left. Written whit a ;-) in my eye.

  7. #7

    Default Re: LibreOffice Base Issues with 13.2

    Quote Originally Posted by jonte1 View Post
    Dident Help me.. Libreoffice latest repo? Yast2 Repo? and..
    Open YaST->Software Repositories, click on "Add", choose "Community Repositories", and click on "Next". Add the "openSUSE BuildService - LibreOffice" repo there.
    Then enter YaST->Software Management, click on "View"->Repositories, select the newly added "openSUSE BuildService - LibreOffice" repo and do a "full repository vendor change update" as explained in the link I posted.
    And you should also install the package "pentaho-reporting-flow-engine".

    Or just run this:
    Code:
    sudo zypper ar  http://download.opensuse.org/repositories/LibreOffice:/4.3/openSUSE_13.2/ LO
    sudo zypper dup --from LO
    sudo zypper in pentaho-reporting-flow-engine

  8. #8
    Join Date
    Oct 2009
    Location
    Sweden
    Posts
    1,015

    Default Re: LibreOffice Base Issues with 13.2

    Quote Originally Posted by jonte1 View Post
    Dident Help me.. Libreoffice latest repo? Yast2 Repo? and..

    regards?
    What is? "https://en.opensuse.org/SDB:Vendor_change_update#Full_repository_Vendor_change"

    I prefer Os native.

    regards
    I'm shameless like others in the forum -was I to any help or made sense? If yes: click the on the star below to the left. Written whit a ;-) in my eye.

  9. #9
    Join Date
    Oct 2009
    Location
    Sweden
    Posts
    1,015

    Default Re: LibreOffice Base Issues with 13.2

    or "https://forums.opensuse.org/showthread.php/504072-No-access-to-LibreOffice-Stable-repository"

    and no functions for LO Base and reports?

    regards
    I'm shameless like others in the forum -was I to any help or made sense? If yes: click the on the star below to the left. Written whit a ;-) in my eye.

  10. #10

    Default Re: LibreOffice Base Issues with 13.2

    Quote Originally Posted by jonte1 View Post
    What is? "https://en.opensuse.org/SDB:Vendor_change_update#Full_repository_Vendor_change"
    Yes.

    I prefer Os native.
    That repo _is_ "Os native".
    If you don't want to add additional repos, well. As you noticed yourself, this is broken in the packages included in 13.2. So you cannot use reports.

    If you want this fixed in the standard packages, find out what goes wrong during build, fix it, and submit an update.
    I suppose you can't?
    Well, I haven't found out why this is broken yet either.

    So use the additional repo or just don't use reports at all.

    Quote Originally Posted by jonte1 View Post
    or "https://forums.opensuse.org/showthread.php/504072-No-access-to-LibreOffice-Stable-repository"

    and no functions for LO Base and reports?
    What do you mean with that question?

    There is no LibreOffice:Stable any more, yes. But there is LibreOffice:4.3, available in the Community Repositories list as mentioned. And reports do work with those packages.
    Last edited by wolfi323; 14-Feb-2015 at 13:04.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •