Results 1 to 5 of 5

Thread: VirtualBox doesn't run

  1. #1

    Default VirtualBox doesn't run

    Hi
    I've recently installed VirtualBox on openSuSE 13.2, but this application doesn't start and shows me the following error messages :
    Code:
    /usr/lib/python2.7/site-packages/vboxgtk/iface.py:74: Warning: The property GtkButton:use-stock is deprecated and shouldn't be used anymore. It will be removed in a future version.
      builder.add_from_file(os.path.join(paths.data_path, f))
    /usr/lib/python2.7/site-packages/vboxgtk/iface.py:74: Warning: The property GtkSettings:gtk-button-images is deprecated and shouldn't be used anymore. It will be removed in a future version.
      builder.add_from_file(os.path.join(paths.data_path, f))
    /usr/lib/python2.7/site-packages/vboxgtk/iface.py:74: Warning: The property GtkAlignment:top-padding is deprecated and shouldn't be used anymore. It will be removed in a future version.
      builder.add_from_file(os.path.join(paths.data_path, f))
    /usr/lib/python2.7/site-packages/vboxgtk/iface.py:74: Warning: The property GtkAlignment:bottom-padding is deprecated and shouldn't be used anymore. It will be removed in a future version.
      builder.add_from_file(os.path.join(paths.data_path, f))
    /usr/lib/python2.7/site-packages/vboxgtk/iface.py:74: Warning: The property GtkAlignment:left-padding is deprecated and shouldn't be used anymore. It will be removed in a future version.
      builder.add_from_file(os.path.join(paths.data_path, f))
    /usr/lib/python2.7/site-packages/vboxgtk/iface.py:74: Warning: The property GtkAlignment:right-padding is deprecated and shouldn't be used anymore. It will be removed in a future version.
      builder.add_from_file(os.path.join(paths.data_path, f))
    /usr/lib/python2.7/site-packages/vboxgtk/iface.py:74: Warning: The property GtkButton:xalign is deprecated and shouldn't be used anymore. It will be removed in a future version.
      builder.add_from_file(os.path.join(paths.data_path, f))
    /usr/lib/python2.7/site-packages/vboxgtk/iface.py:74: Warning: The property GtkImage:stock is deprecated and shouldn't be used anymore. It will be removed in a future version.
      builder.add_from_file(os.path.join(paths.data_path, f))
    /usr/lib/python2.7/site-packages/vboxgtk/iface.py:74: Warning: The property GtkTreeView:rules-hint is deprecated and shouldn't be used anymore. It will be removed in a future version.
      builder.add_from_file(os.path.join(paths.data_path, f))
    Traceback (most recent call last):
      File "/usr/bin/vboxgtk", line 94, in <module>
        vboxgtk.main()
      File "/usr/lib/python2.7/site-packages/vboxgtk/iface.py", line 47, in call_with_method
        return func(self,*args,**kwargs)
      File "/usr/lib/python2.7/site-packages/vboxgtk/iface.py", line 74, in main
        builder.add_from_file(os.path.join(paths.data_path, f))
    GLib.Error: gtk-builder-error-quark: Invalid property: GtkGrid.n_rows on line 1564 (11)
    Please guide me
    Tnx

  2. #2
    Join Date
    May 2012
    Location
    Finland
    Posts
    2,004

    Default Re: VirtualBox doesn't run

    Edit:
    Come to think of it, where did you install VirtualBox from? The packages that come with the system?

    Please post the output of: zypper se -si -v virtualbox

    Wrap it in code tags, like this:
    Code:
    Whee!
    .: miuku #suse @ irc.freenode.net
    :: miuku@opensuse.org

    .: h​ttps://download.opensuse.org/repositories/home:/Miuku/

  3. #3

    Default Re: VirtualBox doesn't run

    You installed and try to run vboxgtk. This doesn't work at all!
    Remove it and install virtualbox-qt instead, which is the official GUI.

    A side-note: vboxgtk is a GTK based replacement for the standard GUI by a third party. It doesn't fully work with VirtualBox>4.2 any more, and in 13.2 it doesn't even start any more. As there also seems to be no upstream activity any more (the last change has been made in 2012 IIRC), it has been dropped from the distribution completely 2 months ago. But unfortunately it's still included in 13.2...

  4. #4

    Default Re: VirtualBox doesn't run

    also is VB is not a MUST USE
    and you only need a virtual environment

    KVM is already ready to install from the gui Yast

    a few mouse clicks and it is installed



  5. #5

    Default Re: VirtualBox doesn't run

    Quote Originally Posted by JohnVV View Post
    also is VB is not a MUST USE
    and you only need a virtual environment
    Well, I don't want to start a discussion here whether KVM or VirtualBox is "better".
    But, KVM requires hardware virtualization support, whereas VirtualBox runs fine without (as long as you don't want to use 64bit guests). So depending on your system, KVM might not even be an option (my Athlon64 e.g. doesn't support AMD-V yet).
    And VirtualBox might support guests or might have features that are not supported/possible with KVM (or maybe not).

    KVM is already ready to install from the gui Yast

    a few mouse clicks and it is installed
    Just like VirtualBox, no?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •