Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Using KDE/Plasma 5 on Tumbleweed?

  1. #1

    Default Using KDE/Plasma 5 on Tumbleweed?

    I read this, and it only seems to list packages for 13.1, 13.2, and Factory. Somewhere else I read claimed that Tumbleweed should have the packages in it's standard repos, and you could just install the plasma5 package to get it.

    I'm not sure on what the proper naming scheme is or anything, but I'd like to install the complete KDE5 Desktop Environment. I'm not certain if it's a selectable choice during install-time or if I have to install it post-install with some command(s) (still downloading the image), but what would I have to do to get the complete KDE5 DE?

  2. #2

    Default AW: Using KDE/Plasma 5 on Tumbleweed?

    Quote Originally Posted by Espionage724 View Post
    I read this, and it only seems to list packages for 13.1, 13.2, and Factory. Somewhere else I read claimed that Tumbleweed should have the packages in it's standard repos, and you could just install the plasma5 package to get it.
    Yes, Tumbleweed does contain the latest (stable) KF5/Plasma 5 packages in its standard repo. No need to add any additional repo.
    KDE:Frameworks5 is a devel repo for Factory, all packages in there get submitted to Factory and appear in Tumbleweed soon after when all tests are passed.

    I'm not sure on what the proper naming scheme is or anything, but I'd like to install the complete KDE5 Desktop Environment. I'm not certain if it's a selectable choice during install-time or if I have to install it post-install with some command(s) (still downloading the image), but what would I have to do to get the complete KDE5 DE?
    There is no "complete KDE5 Desktop Environment". Most applications have not even released a KF5 version yet.

    To install Plasma 5 (the desktop), install the package plasma5-session. This should install all necessary packages and add an option for "Plasma 5" to your login screen. It will also remove KDE4's desktop (* see below).
    There's also a Plasma 5 pattern, see YaST->Software Management->View->Patterns.

    You might want to install some additional KF5 applications (I don't think they are pulled in by default yet), like kmix5 in particular (otherwise you won't have a volume control in the system tray...).
    Basically, all KF5 based applications included in KDE 14.12 should be available in Tumbleweed as well, with a '5' added to the package name.
    E.g. kate5, kig5, ...
    See also KDE 14.12's release announcement for a list of all KF5 based apps included:
    https://www.kde.org/announcements/an...ns-14.12.0.php
    The release includes the first KDE Frameworks 5-based versions of Kate and KWrite, Konsole, Gwenview, KAlgebra, Kanagram, KHangman, Kig, Parley, KApptemplate and Okteta. Some libraries are also ready for KDE Frameworks 5 use: analitza and libkeduvocdocument.
    (*) PS: I do maintain a repo with Plasma5/KF5 packages that are co-installable with KDE4. This repo also contains development snapshots of many more "KDE5" (KF5 actually ) applications, also co-installable with their KDE4 counterparts. Add this repo to your Tumbleweed installation (with a higher priority/lower priority number) and run "zypper dup" to be sure you use my packages, something like this:
    Code:
    sudo zypper ar -f http://download.opensuse.org/repositories/home:/wolfi323:/branches:/KDE:/Frameworks5/openSUSE_Tumbleweed KF5_wolfi323
    sudo zypper mr -p 97 KF5_wolfi323
    sudo zypper dup
    sudo zypper in plasma5-session
    If you use my repo, please check in YaST->Software Management->View->Repositories which apps are available and install them as you like.
    And re-check regularly, I add applications as they get ported...
    Last edited by wolfi323; 12-Feb-2015 at 07:15.

  3. #3

    Default Re: Using KDE/Plasma 5 on Tumbleweed?

    I have tried to install your's plasma5 compilation, but while selecting plasma5-session from your repo, there's error occurred. The massage say there's missing kscreen2-plugins package.

  4. #4

    Default Re: Using KDE/Plasma 5 on Tumbleweed?

    I must ask simple question: when the compliance of Plasma5.3 will be present?

  5. #5
    Join Date
    Sep 2013
    Location
    Eastern US
    Posts
    78

    Default Re: Using KDE/Plasma 5 on Tumbleweed?

    Here is a little info re: Plasma5 as default KDE DE on TW/etc:

    Factory ML Thread

    Edit:
    Also, right now, there is a conflict with Fact/KF5/kwin and TW final. Basically, Factory kwin wants mesa 10.5.4 but TW final only has 10.5.3. So in the midst of them getting Plasma5 repos set up and the default DE in TW, they are also probably going to update mesa to 10.5.4. In addition, the 4.0.x series kernel is in the mix as well, most likely. I would venture that the next TW "release" is going to be hefty.

  6. #6

    Default Re: Using KDE/Plasma 5 on Tumbleweed?

    Quote Originally Posted by Lachu View Post
    I have tried to install your's plasma5 compilation, but while selecting plasma5-session from your repo, there's error occurred. The massage say there's missing kscreen2-plugins package.
    Then install it? Although it should get installed by default.

    If there's anything wrong, I need more information. Like what repos are you exactly using, the exact error message,...

    Quote Originally Posted by Lachu View Post
    I must ask simple question: when the compliance of Plasma5.3 will be present?
    Plasma 5.3 final is already in my repo (and in KF5) since Tuesday. Today even some bugfixes from the upcoming 5.3.1 got added.
    But that only applies for my repos for 13.1, 13.2 and Factory, not Tumbleweed.

    For Tumbleweed, I have to wait with publishing until 5.3 is in the standard repo. Otherwise it won't be installable anyway because of conflicts.
    5.3 is currently in staging/testing, that takes a while.

    If you want to install 5.3 _now_ use my Factory repo and KF5 for Factory.

    Quote Originally Posted by noee View Post
    Also, right now, there is a conflict with Fact/KF5/kwin and TW final. Basically, Factory kwin wants mesa 10.5.4 but TW final only has 10.5.3. So in the midst of them getting Plasma5 repos set up and the default DE in TW, they are also probably going to update mesa to 10.5.4.
    This is all done already. Plasma 5.3 just has to go through staging/testing and it will replace KDE4 (the desktop) then.
    The packages are build automatically against the other packages in Tumbleweed then, so there should not be any conflict.

    Mesa will be updated when Mesa will be updated. That's completely independent of Plasma5.

    But AFAICS, Mesa 10.5.4 is already in the Tumbleweed repo as of this moment:
    http://download.opensuse.org/tumblew...2.1.x86_64.rpm

    In addition, the 4.0.x series kernel is in the mix as well, most likely. I would venture that the next TW "release" is going to be hefty.
    Kernel 4.0 is already in Tumbleweed as well.
    But there shouldn't be big problems because of that.
    The 4.0 is rather cosmetic. It could just have been called 3.20 as well.
    Last edited by wolfi323; 02-May-2015 at 06:59.

  7. #7
    Join Date
    Sep 2013
    Location
    Eastern US
    Posts
    78

    Default Re: Using KDE/Plasma 5 on Tumbleweed?

    Yeah, I see kernel and mesa just caught up in TW. Very good so far.

    Yes, while the "4.0" kernel is just the next in the series, there is a huge drm update for AMD APU Laptop users re: the backlight problems that have plagued those of us using the OSS driver. They found a fix for the bridge-chip set up that many of these system use (Toshiba, etc.) and it's a tremendous fix for the suspend/resume backlight issue.

  8. #8

    Default Re: Using KDE/Plasma 5 on Tumbleweed?

    Ok. I have installed Plasma 5.3 and KDE4 is untouched (thanks wolfi323!), but krunner doesn't display on alt+f2 key press and on alt+space key press. Krunner reside in /opt/kf5/bin.

  9. #9

    Default Re: Using KDE/Plasma 5 on Tumbleweed?

    Quote Originally Posted by Lachu View Post
    Ok. I have installed Plasma 5.3 and KDE4 is untouched (thanks wolfi323!), but krunner doesn't display on alt+f2 key press and on alt+space key press. Krunner reside in /opt/kf5/bin.
    You mean in Plasma5?
    Try Alt+Space too. (edit: sorry, didn't notice, you tried already... but the rest below applies anyway... )
    And/or if that doesn't work, please check in systemsettings5->Shortcuts->Global Shortcuts (component "KRunner") what's set there...

    That said, both shortcuts work fine here without manually changing anything, but I did upgrade since the first beta versions of 5.0. It might be a new issue that the shortcut isn't set correctly on new installations now (which of course would be a bug and nice to know too).
    Last edited by wolfi323; 04-May-2015 at 04:00.

  10. #10

    Default Re: Using KDE/Plasma 5 on Tumbleweed?

    Thanks for replying. In Global Shortucts Krunner have assigned ALT+SPACE to action Run Command and ALT+SHIFT+F2 to action Run Command On Clipboard Content.

    I must tell I was using kwin 5.2.2. Maybe this is problem?

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •