Results 1 to 10 of 10

Thread: openSUSE logo missing in LXDE 13.2 and mounting before login

  1. #1

    Default openSUSE logo missing in LXDE 13.2 and mounting before login

    Hi,

    now that I've fixed the most critical problems, I bring forth the lesser, appearance related "problems". These are not really making a problem, just looks funky.

    The first contender is the missing openSUSE logo, which disappeared when I upgraded openSUSE from 13.1 to 13.2. As you can see, under LXDE it shows only a red X. I've tried the lxde-common-branding-openSUSE package from Yast, but it says there is no possible update for that. (However it suggests a "fallback" to 12.x, but I really don't like the idea of installing some older software.)


    Also, the other partitions are not mounted before login, which makes the wallpaper disappear, until I manually reenable. Also Desktop icons don't work. Is there a way to make it run automatically before I login, so the Desktop loads properly?

  2. #2
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,700

    Default Re: openSUSE logo missing in LXDE 13.2 and mounting before login

    You seem to be missing some stuff so how did you "upgrade"

    mounting is done via the /etc/fstab file anything in there gets mounted before login.

    So really have no idea how you have your machine configured or why it is not working as you think it should.

    perhaps you need to share a bit more info with us.

  3. #3

    Default Re: openSUSE logo missing in LXDE 13.2 and mounting before login

    Hi,

    the mounting now works. I have no idea how I didn't think of it before, I wanted to make a script that runs mounting at start.

    For the upgrade, I used this:
    https://en.opensuse.org/SDB:System_upgrade
    The command line part with the zypper. It worked for everything except the logo and the GRUB. But I don't care about the GRUB, that can stay 13.1 style.

    perhaps you need to share a bit more info with us.
    I have no idea what you mean. What further information you need? I know it's hard to fix the problem without having enough information, but you could ask which information do you want.

    desktop-data-openSUSE 13.2-3.1.4
    lxappearance 0.5.6-1.2
    lxappearance-obconf 0.2.2-2.1
    lxcc 0.1.0+svn733-20.1.6
    lxde-common 0.5.5-42.1.4
    lxde-common-branding-openSUSE 12.1-33.2.2
    lxdm 0.4.1-1.8
    lxmenu-data 0.1.4-1.2
    lxpanel 0.7.1-1.6
    lxsession 0.4.9.3.git20130914-5.1.5

    These are the softwares I have installed, and I think might cause the problem. Just noticed the common branding is at 12.1.

  4. #4

    Default Re: openSUSE logo missing in LXDE 13.2 and mounting before login

    Actually, cancel that. I replaced the /home/kry with an another partition, and the system load the defaults, and now the icons are at their correct places.

    One last thing. For now. I used LXDE, and made a link for the Steam. But I need the link to set SDL_AUDIODRIVER=alsa before running Steam, because now it loads Steam without sounds. When I load with SDL... it works, but I need the terminal to run all the time for it. Currently it runs the command "/usr/bin/steam %U", but when I change it to something else, it reverts to the original one.

  5. #5
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,700

    Default Re: openSUSE logo missing in LXDE 13.2 and mounting before login

    You weren’t trying to use a NTFS/FAT partition for home?? Don't it won't work things will break.

  6. #6

    Default Re: openSUSE logo missing in LXDE 13.2 and mounting before login

    I'm using NTFS. But now it works.

  7. #7
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,700

    Default Re: openSUSE logo missing in LXDE 13.2 and mounting before login

    NTFS home will cause you problems sooner then later. Windows file system are not 100% compatible with Linux file systems. It is a terrible idea and don't say I did not warn you

    When you mount a Windows partition the permissions are faked. Windows does not understand Linux permissions.

    If you need to share data use a mount point that is NOT your home. Home has to be a Linux compatible file system.

  8. #8

    Default Re: openSUSE logo missing in LXDE 13.2 and mounting before login

    But as I noted before in the other topic, Steam won't work then.

  9. #9
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,117
    Blog Entries
    2

    Default Re: openSUSE logo missing in LXDE 13.2 and mounting before login

    Quote Originally Posted by Kry View Post
    One last thing. For now. I used LXDE, and made a link for the Steam. But I need the link to set SDL_AUDIODRIVER=alsa before running Steam, because now it loads Steam without sounds. When I load with SDL... it works, but I need the terminal to run all the time for it. Currently it runs the command "/usr/bin/steam %U", but when I change it to something else, it reverts to the original one.
    Would there be any downside to making this setting system-wide and enabled on boot?
    Although I haven't checked specifically, it would seem to me that this type of setting can be configured in the YAST sysconfig editor.
    Or, in the YAST sound system applet.

    TSU

  10. #10
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,700

    Default Re: openSUSE logo missing in LXDE 13.2 and mounting before login

    Well Linux won't work right with a Windows formatted home.

    I don't run steam but others don't seem to have a problem. As I recall your problem was the amount of space you gave to Linux not enough for gaming.

    I suggest you put your steam stuff someplace other then your home if you must use Windows partitions. Over the years I have seen people try a NTFS home and it always ends in tears.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •