Results 1 to 3 of 3

Thread: Yast Only Works When Installation USB Is Plugged In

  1. #1

    Default Yast Only Works When Installation USB Is Plugged In

    When I attempt to software to my system without my installation USB plugged in, it sends me an error saying "Yast cannot find installation media."

    Any help is appreciated.

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,519
    Blog Entries
    15

    Default Re: Yast Only Works When Installation USB Is Plugged In

    Hi
    After install, you need to disable the install media. Either via YaST -> Software Repositories, or via zypper from the command line;

    To identify (probably 1)
    Code:
    zypper lr -d
    Then once identified which is the usb device;
    Code:
    zypper mr -d -R -p 101 <number from above>
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. #3

    Default Re: Yast Only Works When Installation USB Is Plugged In

    Hi,

    you can try to filter most of them.

    Code:
    zypper lr -u | awk '$NF ~ /cd|dir|hd|usb|iso/ {printf("%-3d %s\n", $1, $NF)}'
    The number in the first column is the one you are after which you can disable with zypper as well

    Code:
    zypper mr -d «number-from-previous-output»
    "Unfortunately time is always against us" -- [Morpheus]

    .:https://github.com/Jetchisel:.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •