Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: disk always busy

  1. #1

    Default disk always busy

    Hi, I opened system monitor and found out gvfsd-metadata was writing huge amount of data. I ended the process and disk stopped spinning.
    How can I prevent it from running again?
    Thanks in advance.

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,853

    Default Re: disk always busy

    I may assume that this happens on openSUSE (but even that is not sure, we had at least two SLES users who got lost and landed here today). But please also tell your openSUSE version.
    Henk van Velden

  3. #3

    Default Re: disk always busy

    openSUSE 13.1...but all updates installed.

  4. #4
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,646

    Default Re: disk always busy

    Well that is the gnome virtual file system

    It seems to go off the deep end occasioanly

    this is supposed to fix it when it does

    rm -rf ~/.local/share/gvfs-metadata

    Though that is old info and maybe they moved the file(s). Seems to be a lot of moving things in Gnome and KDE as of late.

  5. #5

    Default Re: disk always busy

    thanks gogalthorp.
    I have KDE and hapenning when the computer goes idle...

  6. #6
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: disk always busy

    you might be on kde but a gnome app is eating resources, a quick google revealed a possible fault and fix
    it looks like the metadata store is corrupted, a simple fix is to delete the old metadata store
    run this from a terminal in your $HOME
    Code:
    cd $HOME
    pkill gvfsd-metadata 
    rm -rf .local/share/gvfs-metadata

  7. #7

    Default Re: disk always busy

    thanks I_A, nice to see you again.
    I did gogalthorp's fix killing it from the system monitor's GUI first.
    It's OK now, yet didn't leave the computer for a long time so that I could check if starting again.

  8. #8

    Default Re: disk always busy

    your fix is good, it stops the load but sometimes the problem re-occurs.
    I've noticed it starts even the computer is not idle.
    Isn't there a solution to prevent it from starting or it is a needed process...

  9. #9
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: disk always busy

    On 2015-02-07 01:16, intzepatorii wrote:
    >
    > your fix is good, it stops the load but sometimes the problem re-occurs.
    > I've noticed it starts even the computer is not idle.
    > Isn't there a solution to prevent it from starting or it is a needed
    > process...


    It is needed by some gnome application that you are still running.


    --
    Cheers / Saludos,

    Carlos E. R.

    (from 13.1 x86_64 "Bottle" (Minas Tirith))

  10. #10

    Default Re: disk always busy

    can you detail please.. after a little search I found out the settings for directory windows and desktop icon positions depend on it.
    Icons on desktop wouldn't be a problem as I don't have any and I could cope with default directory windows

    is it something else?

    It's very annoying to leave the computer running and when returning to see tons of unnecessary writes on disk.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •