Page 1 of 3 123 LastLast
Results 1 to 10 of 27

Thread: How to get cube animation in KDE?

Hybrid View

  1. #1

    Default How to get cube animation in KDE?

    I've intalled openSuSE 13.2 using KDE on my desktop PC. I'd like to have cube animation which switching virtual desktops (as I have on my laptop PC using 12.2), but when I try to apply that option from my system settings I get told it's not possible without OpenGL. I've been into YaST and installed every likely thing I can find that comes up when I search for OpenGL and rebooted, but no luck.

    So how do I get cube animation working.

  2. #2
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: How to get cube animation in KDE?

    What kind of graphic card and driver do you have, compiz needs 3d acceleration aka a propitiatory driver (Nouveau will work for nvidia cards)
    see this page
    https://en.opensuse.org/SDB:Configuring_graphics_cards
    and get the proper video driver

  3. #3

    Default Re: How to get cube animation in KDE?

    I have an nVidia GTE550 graphics cardm, and I'm using the nVidia driver, from the nVidia repository.

  4. #4
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: How to get cube animation in KDE?

    Quote Originally Posted by johngwalker View Post
    I have an nVidia GTE550 graphics cardm, and I'm using the nVidia driver, from the nVidia repository.
    what about compiz, compiz-plugins, compizconfig-settings-manager and compiz-kde4?
    run nvidia-settings and see if 3d acceleration is enabled.

  5. #5
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    4,311

    Default AW: How to get cube animation in KDE?

    I have an nVidia GTE550 graphics cardm, and I'm using the nVidia driver, from the nVidia repository.
    Please post in Code-Tags:
    Code:
    /sbin/lspci -nnk | grep -E -iA2 'Display|VGA|3D'
    @I_A:
    what about compiz, compiz-plugins and compiz-kde4?
    Why compiz? It is not necessary.

  6. #6

    Default Re: AW: How to get cube animation in KDE?

    Quote Originally Posted by Sauerland View Post
    Please post in Code-Tags:
    Code:
    /sbin/lspci -nnk | grep -E -iA2 'Display|VGA|3D'
    Code:
    0:02.0 Display controller [0380]: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0102] (rev 09)
            Subsystem: Dell Device [1028:0527]
            Kernel modules: i915
    --
    01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GF114 [GeForce GTX 555] [10de:1206] (rev a1)
            Subsystem: NVIDIA Corporation Device [10de:0958]
            Kernel driver in use: nvidia

  7. #7
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: AW: How to get cube animation in KDE?

    Quote Originally Posted by johngwalker View Post
    Code:
    0:02.0 Display controller [0380]: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0102] (rev 09)
            Subsystem: Dell Device [1028:0527]
            Kernel modules: i915
    --
    01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GF114 [GeForce GTX 555] [10de:1206] (rev a1)
            Subsystem: NVIDIA Corporation Device [10de:0958]
            Kernel driver in use: nvidia
    You have 2 video cards I think you need bumblebee not the vanilla nvidia drivers
    ask in the hardware forums, another option is to disable the build-in intel (it's not a card it's part of the cpu) graphic support
    ps. I'm not quite sure about this but if your monitor connects via the nvidia card does the build-in intel hardware do any video decoding, does it pass decoded data streams to nvidia, you might be better of turning it off in bios

  8. #8

    Default Re: How to get cube animation in KDE?

    I have "nomodeset" on the kernel command line parameter. I was told that would disable the built-in chip.

    What are you suggesting that I ask in the hardware forum?

  9. #9

    Default Re: How to get cube animation in KDE?

    A further piece of information: I used to run openSuSE 12.2 on the same machine using slide for virtual desktop switching. This now will not work under 13.2 for, system settigs tells me, the same rewason as cube animation won't work. This is why I suspect this is a software problem.

  10. #10

    Default AW: Re: How to get cube animation in KDE?

    Quote Originally Posted by johngwalker View Post
    I have "nomodeset" on the kernel command line parameter. I was told that would disable the built-in chip.
    No, it doesn't.
    It just prevents the loading of the intel driver.

    On a hybrid system, KDE runs on the intel chip, if you disable the intel driver, there is no sufficient OpenGL support (only Mesa's software renderer, if you use that KDE automatically disables most desktop effects as they would be sloooow...).

    You need to install Bumblebee to be able to use the nvidia driver without breaking the intel driver on such a hybrid system.

    But just because there is a intel chip, doesn't mean that this is a hybrid system.
    Can you please post /var/log/Xorg.0.log to see which graphics card is actually used?

    And another thing: for the desktop cube you need to enable Desktop Effects (Configure Desktop->Desktop Effects), and the "Compositing Type" has to be set to "OpenGL" in Configure Desktop->Desktop Effects->Advanced.

    What are you suggesting that I ask in the hardware forum?
    This might be a graphics driver problem, so hardware related.

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •