Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 27

Thread: How to get cube animation in KDE?

  1. #11

    Default Re: How to get cube animation in KDE?

    I have "nomodeset" on the kernel command line parameter. I was told that would disable the built-in chip.

    What are you suggesting that I ask in the hardware forum?

  2. #12

    Default Re: How to get cube animation in KDE?

    A further piece of information: I used to run openSuSE 12.2 on the same machine using slide for virtual desktop switching. This now will not work under 13.2 for, system settigs tells me, the same rewason as cube animation won't work. This is why I suspect this is a software problem.

  3. #13

    Default AW: Re: How to get cube animation in KDE?

    Quote Originally Posted by johngwalker View Post
    I have "nomodeset" on the kernel command line parameter. I was told that would disable the built-in chip.
    No, it doesn't.
    It just prevents the loading of the intel driver.

    On a hybrid system, KDE runs on the intel chip, if you disable the intel driver, there is no sufficient OpenGL support (only Mesa's software renderer, if you use that KDE automatically disables most desktop effects as they would be sloooow...).

    You need to install Bumblebee to be able to use the nvidia driver without breaking the intel driver on such a hybrid system.

    But just because there is a intel chip, doesn't mean that this is a hybrid system.
    Can you please post /var/log/Xorg.0.log to see which graphics card is actually used?

    And another thing: for the desktop cube you need to enable Desktop Effects (Configure Desktop->Desktop Effects), and the "Compositing Type" has to be set to "OpenGL" in Configure Desktop->Desktop Effects->Advanced.

    What are you suggesting that I ask in the hardware forum?
    This might be a graphics driver problem, so hardware related.

  4. #14

    Default Re: AW: Re: How to get cube animation in KDE?

    Quote Originally Posted by wolfi323 View Post
    No, it doesn't.
    It just prevents the loading of the intel driver.

    On a hybrid system, KDE runs on the intel chip, if you disable the intel driver, there is no sufficient OpenGL support (only Mesa's software renderer, if you use that KDE automatically disables most desktop effects as they would be sloooow...).

    You need to install Bumblebee to be able to use the nvidia driver without breaking the intel driver on such a hybrid system.

    But just because there is a intel chip, doesn't mean that this is a hybrid system.
    Can you please post /var/log/Xorg.0.log to see which graphics card is actually used?

    And another thing: for the desktop cube you need to enable Desktop Effects (Configure Desktop->Desktop Effects), and the "Compositing Type" has to be set to "OpenGL" in Configure Desktop->Desktop Effects->Advanced.


    This might be a graphics driver problem, so hardware related.
    I had already enabled Desktop Effects, so setting "Compositing Type" in Configure Desktop->Desktop Effects->Advanced to "OpenGL" seemed like the easiest thing to do, so I tried that first. Setting it to "OpenGL 3.1" sorted it. So thank you very much.

    Bumblebee is already installed, so thanks also for the information as to what that is about.

  5. #15

    Default Re: How to get cube animation in KDE?

    Quote Originally Posted by johngwalker View Post
    I had already enabled Desktop Effects, so setting "Compositing Type" in Configure Desktop->Desktop Effects->Advanced to "OpenGL" seemed like the easiest thing to do, so I tried that first. Setting it to "OpenGL 3.1" sorted it. So thank you very much.
    Well, if KDE detects graphics driver problems it automatically switches back to "XRender" (which does not support the desktop cube in particular), and keeps that even if the driver is working again.
    So maybe that caused your "problem". (normally OpenGL should be used by default, if possible)

    You probably should also verify that "Qt graphicssystem" is set to "Raster". Especially with OpenGL this is faster than "Native"...
    Last edited by wolfi323; 01-Feb-2015 at 06:19.

  6. #16

    Default Re: How to get cube animation in KDE?

    Quote Originally Posted by wolfi323 View Post
    You probably should also verify that "Qt graphicssystem" is set to "Raster". Especially with OpenGL this is faster than "Native"...
    I tried that and an errors message popped up telling me that 21 desktop effects could not be loaded. So do I need to do soemthing else as well for raster to work? Faster is always better.

  7. #17
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,893

    Default Re: How to get cube animation in KDE?

    If yours is an optimus system you will not get as fast as the same chip set without Optimus. Optimus is a hardware kludge neither beast nor fowl. It is still uncertain to me exactly what your system is. NSA confiscated my crystal ball

    ANother point is if Optimus you must NOT ever install the normal NVIDIA driver you must use only the NVIDIA-bumblebee package. If you installed the regular drivers and did NOT uninstall them before bumblebee you can have a mess to clean up

  8. #18

    Default Re: How to get cube animation in KDE?

    It's not an Optimus system.

  9. #19
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,893

    Default Re: How to get cube animation in KDE?

    Then you do NOT want bumblebee

    Disable the Intel GPU in the BIOS

    Remove bumblebee ( it is only for optimus systems special hardware)

    If you installed the NVIDIA-bumblebee package remove that too.

    Install the normal NVIDIA package

  10. #20

    Default Re: How to get cube animation in KDE?

    gogalthorp, I don't understand what you're saying. I have the GO3 driver installed and its working. What problems do you think will happen if I have bumblebee installed? Are you saying that's the reson I can't choose Raster as my graphics system?

Page 2 of 3 FirstFirst 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •