Results 1 to 5 of 5

Thread: Gtk WARNING! Why am I getting this?

  1. #1

    Question Gtk WARNING! Why am I getting this?

    Hello!

    I have just installed the OpenSUSE 13.2 in my desktop. Because I had elementary OS installed, I did the partitioning myself. I deleted the former primary partitions from Elementary OS and left the extended with 60 GiB; inside the Extended I've separated in 4 other: / (root), boot, home and Swap. I dont know if it's right and this maybe the reason why I'm not able to install Popcorn Time now. I downloaded a script from this site: . When I try to execute that from the terminal, I get this message:

    >lucas@linux-019v:~/Downloads> gnomesu ./popcorn-installer.sh

    (gnomesu:2225): GLib-GObject-WARNING **: The property GtkButton:use-stock is deprecated and shouldn't be used anymore. It will be removed in a future version.

    (gnomesu:2225): GLib-GObject-WARNING **: The property GtkSettings:gtk-button-images is deprecated and shouldn't be used anymore. It will be removed in a future version.

    (gnomesu:2225): Gtk-WARNING **: gtk_window_set_titlebar() called on a realized window
    Gtk-Message: GtkDialog mapped without a transient parent. This is discouraged.

    I'm using gnomesu command because in other situations Gtk was giving the following message: Gtk-WARNING **: cannot open display. And I was able to get over this issue by executing gnomesu. It appears to be linked with security, but it's giving me a lot of trouble.

    Thanks in advance!

    Ps: Sorry, I've posted w/o the "code" window for the code and wasn't able to edit later.

  2. #2
    Join Date
    Jul 2008
    Location
    Seattle, WA
    Posts
    17,079

    Default Re: Gtk WARNING! Why am I getting this?

    On Sat, 31 Jan 2015 16:06:01 +0000, lucasvam wrote:

    > Hello!
    >
    > I have just installed the OpenSUSE 13.2 in my desktop. Because I had
    > elementary OS installed, I did the partitioning myself. I deleted the
    > former primary partitions from Elementary OS and left the extended with
    > 60 GiB; inside the Extended I've separated in 4 other: / (root), boot,
    > home and Swap. I dont know if it's right and this maybe the reason why
    > I'm not able to install Popcorn Time now. I downloaded a script from
    > this site: . When I try to execute that from the
    > terminal, I get this message:
    >
    >
    >
    >>lucas@linux-019v:~/Downloads> gnomesu ./popcorn-installer.sh

    >
    > (gnomesu:2225): GLib-GObject-WARNING **: The property
    > GtkButton:use-stock is deprecated and shouldn't be used anymore. It
    > will be removed in a future version.
    >
    > (gnomesu:2225): GLib-GObject-WARNING **: The property
    > GtkSettings:gtk-button-images is deprecated and shouldn't be used
    > anymore. It will be removed in a future version.
    >
    > (gnomesu:2225): Gtk-WARNING **: gtk_window_set_titlebar() called on a
    > realized window Gtk-Message: GtkDialog mapped without a transient
    > parent. This is discouraged.
    >
    >
    >
    >
    >
    > I'm using gnomesu command because in other situations Gtk was giving the
    > following message: -Gtk---WARNING **: cannot open display. -And I was
    > able to get over this issue by executing gnomesu. It appears to be
    > linked with security, but it's giving me a lot of trouble.
    >
    > Thanks in advance!


    These messages are nothing to worry about - they're really for the
    developer of the software you're using to let them know that functions
    they're using are going to be removed from the libraries they're using in
    the future.


    Jim



    --
    Jim Henderson
    openSUSE Forums Administrator
    Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

  3. #3

    Default Re: Gtk WARNING! Why am I getting this?

    These messages are nothing to worry about - they're really for the
    developer of the software you're using to let them know that functions
    they're using are going to be removed from the libraries they're using in
    the future.


    Jim



    --
    Jim Henderson
    openSUSE Forums Administrator
    Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C
    Ok, but the thing is that I am not being able to install Popcorn and the system gives me this message whenever I try to execute a .sh file from the terminal.

    Thanks in advance!

  4. #4

    Default Re: Gtk WARNING! Why am I getting this?

    Quote Originally Posted by lucasvam View Post
    Ok, but the thing is that I am not being able to install Popcorn and the system gives me this message whenever I try to execute a .sh file from the terminal.
    Try with sudo instead of gnomesu, or run "su -" first and then just ./popcorn-installer.sh.
    popcorn-installer.sh is a shell script, not a GUI application. And you shouldn't need a display for installing an application anyway (even if you do, it should work with "su -").

  5. #5

    Default Re: Gtk WARNING! Why am I getting this?

    also be aware that Popcorn Time has only one use
    and the MPAA can and WILL come after you
    or
    one of there troll lawyers might

    so

    be prepared for that .You might receive a few extortion notices from lawyers
    and some isp's ARE forwarding the 6 strike notices ( Comcast WILL!!!!! )



Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •