Results 1 to 6 of 6

Thread: Errors during boot..

  1. #1
    Join Date
    Feb 2009
    Location
    UK
    Posts
    1,085

    Default Errors during boot..

    I recently upgraded my PC, with some new parts, and re-installed openSuse 13.2. All has gone well, but some slightly worrying messages come up in the boot process.
    The new parts are Mainboard and GPU, The new MB is an ASRock 960GC-GS FX (which has and AMD HD3000 igp on board) and a Radeon R9 270.
    The new MB has AFAICS the newest BIOS ver. 1.6

    There seems to be no option in the BIOS settings to explicilty turn OFF the IGP. I am currently using the opensource driver for graphics..

    Now; on boot I get these messages:

    Code:
    2.527205] radeon 0000:01:05.0: enabling device (0000 -> 0003)
    [    2.527640] [drm] initializing kernel modesetting (RS780 0x1002:0x9616 0x1849:0x9616).
    [    2.527656] [drm] register mmio base: 0xFE9F0000
    [    2.527657] [drm] register mmio size: 65536
    [    2.527682] radeon 0000:01:05.0: BAR 6: can't assign [??? 0x00000000 flags 0x20000000] (bogus alignment)
    [    2.527689] [drm:radeon_get_bios] *ERROR* Unable to locate a BIOS ROM
    [    2.527883] radeon 0000:01:05.0: Fatal error during GPU init
    [    2.528076] [drm] radeon: finishing device.
    [    2.528079] [TTM] Memory type 2 has not been initialized
    [    2.529838] radeon: probe of 0000:01:05.0 failed with error -22
    [    2.529865] checking generic (d0000000 6f0000) vs hw (d0000000 10000000)
    [    2.529866] fb: switching to radeondrmfb from VESA VGA
    [    2.529907] Console: switching to colour dummy device 80x25
    [    2.530222] [drm] initializing kernel modesetting (PITCAIRN 0x1002:0x6811 0x1458:0x226C).
    [    2.530235] [drm] register mmio base: 0xFEAC0000
    [    2.530236] [drm] register mmio size: 262144
    [    2.530268] radeon 0000:02:00.0: Invalid ROM contents
    [    2.530987] ATOM BIOS: GV
    [    2.531085] radeon 0000:02:00.0: VRAM: 2048M 0x0000000000000000 - 0x000000007FFFFFFF (2048M used)
    [    2.531087] radeon 0000:02:00.0: GTT: 512M 0x0000000080000000 - 0x000000009FFFFFFF
    [    2.531088] [drm] Detected VRAM RAM=2048M, BAR=256M
    [    2.531090] [drm] RAM width 256bits DDR
    [    2.531155] [TTM] Zone  kernel: Available graphics memory: 1010026 kiB
    [    2.531156] [TTM] Initializing pool allocator
    [    2.531161] [TTM] Initializing DMA pool allocator
    [    2.531189] [drm] radeon: 2048M of VRAM memory ready
    [    2.531190] [drm] radeon: 512M of GTT memory ready.
    [    2.531206] [drm] Loading PITCAIRN Microcode
    [    2.531344] [drm] radeon/PITCAIRN_mc2.bin: 31100 bytes
    [    2.531408] [drm] Internal thermal controller with fan control
    [    2.531506] [drm] probing gen 2 caps for device 1022:9603 = 300d02/0
    [    2.541557] [drm] radeon: dpm initialized
    [    2.541818] [drm] GART: num cpu pages 131072, num gpu pages 131072
    [    2.543598] [drm] probing gen 2 caps for device 1022:9603 = 300d02/0
    [    2.543608] [drm] PCIE gen 2 link speeds already enabled
    [    2.560539] [drm] PCIE GART of 512M enabled (table at 0x0000000000276000).
    [    2.560689] radeon 0000:02:00.0: WB enabled
    [    2.560693] radeon 0000:02:00.0: fence driver on ring 0 use gpu addr 0x0000000080000c00 and cpu addr 0xffff88003687bc00
    [    2.560695] radeon 0000:02:00.0: fence driver on ring 1 use gpu addr 0x0000000080000c04 and cpu addr 0xffff88003687bc04
    [    2.560697] radeon 0000:02:00.0: fence driver on ring 2 use gpu addr 0x0000000080000c08 and cpu addr 0xffff88003687bc08
    [    2.560699] radeon 0000:02:00.0: fence driver on ring 3 use gpu addr 0x0000000080000c0c and cpu addr 0xffff88003687bc0c
    [    2.560701] radeon 0000:02:00.0: fence driver on ring 4 use gpu addr 0x0000000080000c10 and cpu addr 0xffff88003687bc10
    [    2.561692] radeon 0000:02:00.0: fence driver on ring 5 use gpu addr 0x0000000000075a18 and cpu addr 0xffffc90011235a18
    [    2.561698] [drm] Supports vblank timestamp caching Rev 2 (21.10.2013).
    [    2.561699] [drm] Driver supports precise vblank timestamp query.
    [    2.561721] radeon 0000:02:00.0: irq 42 for MSI/MSI-X
    [    2.561736] radeon 0000:02:00.0: radeon: using MSI.
    [    2.561767] [drm] radeon: irq initialized.
    Can someone advise me on this?

    Also, later, I get these:
    Code:
    [    6.437781] powernow_k8: [Firmware Bug]: No compatible ACPI _PSS objects found.
    [Firmware Bug]: First, make sure Cool'N'Quiet is enabled in the BIOS.                                                                    
    [Firmware Bug]: If that doesn't help, try upgrading your BIOS.
    As mentioned, the BIOS is the latest avalable. There seems to be no option to en/disable Cool 'n' Quiet.
    Here is the whole DMESG:

    http://paste.opensuse.org/34110976

    Tumbleweed/KDE/Ati Radeon R9 270/AMD FX-6300/8Gb DDR3

  2. #2
    Join Date
    Feb 2009
    Location
    UK
    Posts
    1,085

    Default Re: Errors during boot..

    ps here is: lspci |grep Radeon

    Code:
    linux-walo:~ # lspci |grep Radeon
    01:05.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] RS780L [Radeon 3000]
    02:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Curacao PRO [Radeon R9 270]
    02:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Cape Verde/Pitcairn HDMI Audio [Radeon HD 7700/7800 Series]
    So the on-board is still 'live' and not disabled by plugging in the PCIE card?

    (The ref to HD 7780 series is the audio handling of the card, which IIRC is based on the 7800)

    Tumbleweed/KDE/Ati Radeon R9 270/AMD FX-6300/8Gb DDR3

  3. #3
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,748

    Default Re: Errors during boot..

    There always may be failures reported because the software probes many thing some may not be present or active. Does every thing work?? seems like the driver does start even though it is missing things at first. SO is all working or not?

  4. #4
    Join Date
    Feb 2009
    Location
    UK
    Posts
    1,085

    Default Re: Errors during boot..

    Thanks, gogalthorp. AFAICS everything is working. I do not have much experience with the opensource drivers, or indeed with AMD, as I have always until now used NVidia MoBo with on board IGP. I find it very odd that the IGP cannot be switched OFF, and that there is no mention of 'Cool'n' Quiet' in the new MoBo's BIOS.

    Tumbleweed/KDE/Ati Radeon R9 270/AMD FX-6300/8Gb DDR3

  5. #5
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,748

    Default Re: Errors during boot..

    Different BIOS different options.

  6. #6
    Join Date
    Feb 2009
    Location
    UK
    Posts
    1,085

    Default Re: Errors during boot..

    Terrible BIOS, fewer options, less info. (I had had the previous MB for 10 years, it was not a very good one but it was better than this new one)

    Tumbleweed/KDE/Ati Radeon R9 270/AMD FX-6300/8Gb DDR3

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •