Results 1 to 6 of 6

Thread: YAST says "nothing provides appdata(firefox.appdata.xml)

  1. #1
    Join Date
    Dec 2009
    Location
    Sunnyvale CA
    Posts
    103

    Default YAST says "nothing provides appdata(firefox.appdata.xml)

    Apparently the latest versions of Firefox and Thunderbird no longer include appdata. Is there anyway to turn off this check? FIrefox and Thunderbird opperate fine and there is no correct way to respond to YAST error message.
    ASUS F2A85-M, AMD A10 4.1Ghz 4 Core, 8GB RAM, 250GB SSD Samsung 850, Radeon HD 6970, Open GL 2.1, Kernel 3.16.7-29-desktop, openSUSE 13.2, KDE 4.14.9

  2. #2
    Join Date
    Aug 2008
    Location
    San Francisco
    Posts
    400

    Default Re: YAST says "nothing provides appdata(firefox.appdata.xml)

    Quote Originally Posted by 2fry View Post
    Apparently the latest versions of Firefox and Thunderbird no longer include appdata. Is there anyway to turn off this check? FIrefox and Thunderbird operate fine and there is no correct way to respond to YAST error message.
    With openSUSE 13.1 KDE 32-bit, Firefox 35.0-1.1 installed from http://download.opensuse.org/reposit...openSUSE_13.1/ contains the file /usr/share/appdata/firefox.appdata.xml

    What version are you trying to install, and from where?


    Howard

  3. #3

    Default Re: YAST says "nothing provides appdata(firefox.appdata.xml)

    Quote Originally Posted by 2fry View Post
    Apparently the latest versions of Firefox and Thunderbird no longer include appdata.
    They do. But the package dependencies are apparently wrong, i.e. the packages do not specify that they provide the appdata:
    https://bugzilla.opensuse.org/show_bug.cgi?id=905558

    (those packages have autogeneration of the dependencies turned off, and that triggers this problem)

    Is there anyway to turn off this check?
    Turn off the option "Autocheck" in YaST's "Dependencies" menu.

    Btw, even if the appdata was missing, this would not affect the applications/packages themselves. Appdata is just some additional information about the packages/applications, which is actually only used/shown by gnome-software at the moment AFAIK.

  4. #4
    Join Date
    Dec 2009
    Location
    Sunnyvale CA
    Posts
    103

    Default Re: YAST says "nothing provides appdata(firefox.appdata.xml)

    I reinstalled OpenSUSE and this problem disappeared. Thanks for the information.
    ASUS F2A85-M, AMD A10 4.1Ghz 4 Core, 8GB RAM, 250GB SSD Samsung 850, Radeon HD 6970, Open GL 2.1, Kernel 3.16.7-29-desktop, openSUSE 13.2, KDE 4.14.9

  5. #5

    Cool Re: YAST says "nothing provides appdata(firefox.appdata.xml)

    Try to run " zypper verify " to make sure the problem is no longer there. I'm trying too to figure out what to do. I could remove Firefox and use SeaMonkey. My thinking is if there is really a cyber war using firefox would be dangerous as probably targeted would be internet explorer and firefox the two most widely used browsers. I'm still searching for answeres on this.

  6. #6
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,288

    Default Re: YAST says "nothing provides appdata(firefox.appdata.xml)

    When you have a problem, please create a new thread in the correct (sub)forums with a good informative title. Do not hang your unclear remarks at the end of long solved problems. That is in effective for you and for us.

    This thread is CLOSED.
    Henk van Velden

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •