Results 1 to 4 of 4

Thread: Realtek 8188EE. Connection drops and reconnect again

  1. #1

    Default Realtek 8188EE. Connection drops and reconnect again

    Hi to all.

    I recently bought a HP Pavilion laptop with a Realtek RTl8188EE wireless card. I installed openSUSE 13.2 and every went fine. Card was detected and configured properly. But sometimes, the connection drops, I mean, I can't ping to the router.

    This is the result of a lspci -nn

    Code:
    0a:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8188EE Wireless Network Adapter [10ec:8179] (rev 01)
    I changed my router to have WPA-AES and set my card to disable powersave as I read in some other forums but still having the same issue.

    Does anybody have had this problem?. Did he managed to sort it out?.

    Thanks in advance.

  2. #2
    Join Date
    Jun 2008
    Location
    Skogås Sweden
    Posts
    638

    Default Re: Realtek 8188EE. Connection drops and reconnect again

    Quote Originally Posted by dhouard View Post
    Hi to all.

    I recently bought a HP Pavilion laptop with a Realtek RTl8188EE wireless card. I installed openSUSE 13.2 and every went fine. Card was detected and configured properly. But sometimes, the connection drops, I mean, I can't ping to the router.

    This is the result of a lspci -nn

    Code:
    0a:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8188EE Wireless Network Adapter [10ec:8179] (rev 01)
    I changed my router to have WPA-AES and set my card to disable powersave as I read in some other forums but still having the same issue.

    Does anybody have had this problem?. Did he managed to sort it out?.

    Thanks in advance.
    I have another RTL chip, RTL8723BE, which had the same problem. Surfing the net about it suggested that those chips have a power problem in linux. As I don't need bluetooth I switched it off in the BIOS settings and that solved the problem for me. Possibly a newer kernel would solve the problem too.

  3. #3

    Default Re: Realtek 8188EE. Connection drops and reconnect again

    Quote Originally Posted by hank_se View Post
    I have another RTL chip, RTL8723BE, which had the same problem. Surfing the net about it suggested that those chips have a power problem in linux. As I don't need bluetooth I switched it off in the BIOS settings and that solved the problem for me. Possibly a newer kernel would solve the problem too.
    I don't have bluetooth in my computer so, I went into BIOS and saw "Card reader power saving", which is strange because I don't have a card reader either. Anyway, I disabled and now I'm testing if this works. If so, I'll let you know.

    Thanks for the advice.

  4. #4

    Default Re: Realtek 8188EE. Connection drops and reconnect again

    Unforntunately, looks that I could sort the problem out with your solution. I guess the olny answers is to wait for a new kernel version that solves this issue.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •