Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: My clock displays 2 hours more than the local time (in 1 user only)

  1. #1
    Join Date
    Dec 2008
    Location
    Montevideo, Uruguay
    Posts
    451

    Question My clock displays 2 hours more than the local time (in 1 user only)

    Hi,

    Recently I noticed that mu clock in my agunet user displays 2 hours more. I thouth It was a general problem but recently I created a new user, and in the new user the time shows ok.
    Do you know why possibly my clock is showing 15:26 instead og 13:26 (the correct time now) ?

    Thanks in advance for any feeback

    regards

    Agunet74.
    agunet74

  2. #2
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: My clock displays 2 hours more than the local time (in 1 useronly)

    On 2015-01-20 16:36, agunet74 wrote:
    >
    > Hi,
    >
    > Recently I noticed that mu clock in my agunet user displays 2 hours
    > more. I thouth It was a general problem but recently I created a new
    > user, and in the new user the time shows ok.
    > Do you know why possibly my clock is showing 15:26 instead og 13:26 (the
    > correct time now) ?


    Would that be the KDE applet clock?

    Try opening a terminal and issue "date". Is the hour correct?



    --
    Cheers / Saludos,

    Carlos E. R.
    (from 13.1 x86_64 "Bottle" at Telcontar)

  3. #3
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,356
    Blog Entries
    3

    Default Re: My clock displays 2 hours more than the local time (in 1 user only)

    If it does not affect a new user, then it is probably in your environment.

    At a terminal,
    Code:
    echo $TZ
    For me, that's undefined, so "bash" just outputs an empty line. What output do you see?

    If I am traveling with my laptop, I set that to the local timezone where I am visiting.

    Hmm, you should tell us which desktop you are running. Perhaps there's another way of setting timezone for your particular desktop. And which version of opensuse are you running?
    openSUSE Leap 15.1; KDE Plasma 5;

  4. #4

    Default Re: My clock displays 2 hours more than the local time (in 1 user only)

    Quote Originally Posted by agunet74 View Post
    Do you know why possibly my clock is showing 15:26 instead og 13:26 (the correct time now) ?
    Maybe it shows the wrong timezone? (UTC instead of local time e.g.)
    That's likely the case if it is off by a certain amount of hours.

    You do not say which desktop environment you use, so I assume it's KDE.
    The following will not apply if you use something else.

    What does the clock show when you hover your mouse over it?

    You can configure which time zone(s) it should show by right-clicking on it and choosing "Digital Clock Settings" and then clicking on "Time Zones".

    Hint: if you move the mousewheel over the clock, the time zone is switched between the activated ones. On a default configuration this is UTC and local time...

    Another thing to check would be "Configure Desktop"->Locale->Country.
    Last edited by wolfi323; 20-Jan-2015 at 09:15.

  5. #5
    Join Date
    Dec 2008
    Location
    Montevideo, Uruguay
    Posts
    451

    Default Re: My clock displays 2 hours more than the local time (in 1 user only)

    agunet@agunet:~> date
    Tue Jan 20 14:11:50 UYST 2015


    (The correct date/time)

    agunet@agunet:~> echo $TZ

    agunet@agunet:~>

    the echo $TZ doesn't show anything

    I think is kde clock like Carlos Says.
    agunet74

  6. #6
    Join Date
    Dec 2008
    Location
    Montevideo, Uruguay
    Posts
    451

    Default Re: My clock displays 2 hours more than the local time (in 1 user only)

    I'm using KDE and in both and I have 2 users (apart from root):

    agunet (displays a wrong time)
    tuti displays a correct time

    In both users time is set tu UTC and the region is set to UTC
    agunet74

  7. #7
    Join Date
    Dec 2008
    Location
    Montevideo, Uruguay
    Posts
    451

    Default Re: My clock displays 2 hours more than the local time (in 1 user only)

    You do not say which desktop environment you use, so I assume it's KDE.
    It's KDE

    What does the clock show when you hover your mouse over it?
    IT shows the correct date/time


    You can configure which time zone(s) it should show by right-clicking on it and choosing "Digital Clock Settings" and then clicking on "Time Zones".

    Hint: if you move the mousewheel over the clock, the time zone is switched between the activated ones. On a default configuration this is UTC and local time...
    Another thing to check would be "Configure Desktop"->Locale->Country
    I Have in both users set the same country _(uruguay) and in one works, and in the other does no.
    agunet74

  8. #8

    Default AW: Re: My clock displays 2 hours more than the local time (in 1 user only)

    Quote Originally Posted by agunet74 View Post
    IT shows the correct date/time
    Hm?
    It shows the wrong time, and when you move the mouse over it the time is suddenly correct?
    Or does it only show the correct time in the popup? If that's the case, what else does it show?
    E.g. here it looks like this:

    So it shows UTC _and_ local time, and I can switch which one of those should actually be shown by the clock by scrolling with the mousewheel.

    As I already wanted to indicate, enter the "Digital Clock Settings" and make sure that it's set to show "Local Time". Maybe try to switch to "UTC", press OK and switch back.
    Also check that

    And try to move the mousewheel when over the clock.

  9. #9
    Join Date
    Dec 2008
    Location
    Montevideo, Uruguay
    Posts
    451

    Default Re: AW: Re: My clock displays 2 hours more than the local time (in 1 user only)

    Quote Originally Posted by wolfi323 View Post
    Hm?
    It shows the wrong time, and when you move the mouse over it the time is suddenly correct?
    Or does it only show the correct time in the popup? If that's the case, what else does it show?
    E.g. here it looks like this:

    So it shows UTC _and_ local time, and I can switch which one of those should actually be shown by the clock by scrolling with the mousewheel.
    Yes looks exactly as there

    As I already wanted to indicate, enter the "Digital Clock Settings" and make sure that it's set to show "Local Time". Maybe try to switch to "UTC", press OK and switch back.
    Also check that

    And try to move the mousewheel when over the clock.
    And I I scroll the mousewheel and it works fine !!!!

    Thanks a lot !!!
    agunet74

  10. #10

    Default Re: My clock displays 2 hours more than the local time (in 1 user only)

    Quote Originally Posted by agunet74 View Post
    And I I scroll the mousewheel and it works fine !!!!
    Well, then probably you did that before by mistake?
    You might want to check anyway whether the default is correctly set to "Local Time" in the settings.

    To prevent from changing accidentally with the mouse wheel, you could just untick UTC in the list I suppose...

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •