Results 1 to 2 of 2

Thread: Gnome app "the-board" no longer supported in openSUSE 13.x?

  1. #1
    Join Date
    Jan 2015
    Location
    Austria
    Posts
    19

    Default Gnome app "the-board" no longer supported in openSUSE 13.x?

    Hello!

    I was wondering, whether the app Gnome "the-board", which was officially part in openSUSE12.x (and so seemed to work fine with Gnome-3) will be supported in 13.x too in some time?

    Trying to install the 12.x packages from the openSUSE package search didn't work and also installing it from source failed. There are some dependencies that cannot be resolved and the openSUSE-installer resists all my attempts to install the missing packages. Running ./configure gives the following error message:

    configure: error: Package requirements (glib-2.0 >= 2.27.3
    gobject-introspection-1.0 >= 0.9.6
    gjs-1.0 >= 0.7.7
    gjs-dbus-1.0 >= 0.7.7
    gobject-2.0 >= 2.27.3
    clutter-1.0 >= 1.5.8
    mx-1.0 >= 1.1.1
    gtk+-3.0 >= 2.91.7
    clutter-gtk-1.0 >= 0.91.6
    clutter-gst-1.0 >= 1.3.2) were not met:
    No package 'gjs-1.0' found
    No package 'gjs-dbus-1.0' found
    No package 'clutter-gst-1.0' found
    Consider adjusting the PKG_CONFIG_PATH environment variable if you
    installed software in a non-standard prefix.
    Alternatively, you may set the environment variables THE_BOARD_CFLAGS
    and THE_BOARD_LIBS to avoid the need to call pkg-config.
    See the pkg-config man page for more details.

    Are there probably any alternative libraries to gjs and clutter-gst that work with SUSE that would allow the installation of that app?
    There is an Ubuntu ppa for the-board and also Fedora supports it. It's somehow a pity if that app would never work again on a current version of SUSE, this was just such a great piece of software. Is there probably any other way to get that run by emulating the app (without installing a full ubuntu as a virtual machine just to get access to a single app)?

    Many thanks in advance!

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,519
    Blog Entries
    15

    Default Re: Gnome app "the-board" no longer supported in openSUSE 13.x?

    On Thu 15 Jan 2015 06:36:02 PM CST, suse fan wrote:


    Hello!

    I was wondering, whether the app Gnome "the-board", which was officially
    part in openSUSE12.x (and so seemed to work fine with Gnome-3) will be
    supported in 13.x too in some time?

    Trying to install the 12.x packages from the openSUSE package search
    didn't work and also installing it from source failed. There are some
    dependencies that cannot be resolved and the openSUSE-installer resists
    all my attempts to install the missing packages. Running ./configure
    gives the following error message:

    configure: error: Package requirements (glib-2.0 >= 2.27.3
    gobject-introspection-1.0 >= 0.9.6
    gjs-1.0 >= 0.7.7
    gjs-dbus-1.0 >= 0.7.7
    gobject-2.0 >= 2.27.3
    clutter-1.0 >= 1.5.8
    mx-1.0 >= 1.1.1
    gtk+-3.0 >= 2.91.7
    clutter-gtk-1.0 >= 0.91.6
    clutter-gst-1.0 >= 1.3.2) were not met:
    No package 'gjs-1.0' found
    No package 'gjs-dbus-1.0' found
    No package 'clutter-gst-1.0' found
    Consider adjusting the PKG_CONFIG_PATH environment variable if you
    installed software in a non-standard prefix.
    Alternatively, you may set the environment variables THE_BOARD_CFLAGS
    and THE_BOARD_LIBS to avoid the need to call pkg-config.
    See the pkg-config man page for more details.

    Are there probably any alternative libraries to gjs and clutter-gst that
    work with SUSE that would allow the installation of that app?
    There is an Ubuntu ppa for the-board and also Fedora supports it. It's
    somehow a pity if that app would never work again on a current version
    of SUSE, this was just such a great piece of software. Is there probably
    any other way to get that run by emulating the app (without installing a
    full ubuntu as a virtual machine just to get access to a single app)?

    Many thanks in advance!


    Hi
    By the looks old code that has not caught up with the changes is the
    gnome-shell.
    https://git.gnome.org/browse/the-board/

    Maybe contact the author and ask if their are any plans to update.

    --
    Cheers Malcolm °¿° LFCS, SUSE Knowledge Partner (Linux Counter #276890)
    SUSE Linux Enterprise Desktop 12 GNOME 3.10.1 Kernel 3.12.28-4-default
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!


Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •