Results 1 to 4 of 4

Thread: 146 packages wont update?

  1. #1
    Join Date
    Jul 2008
    Location
    Narvik, Norway
    Posts
    393

    Question 146 packages wont update?

    Hi!
    I try to run updates in terminal as sudo;

    HTML Code:
    linux-7v2w:/home/ronsim # zypper refresh
    Pakkebrønnen 'openSUSE BuildService - LibreOffice' er oppdatert.
    Pakkebrønnen 'openSUSE BuildService - KDE:Extra' er oppdatert.
    Pakkebrønnen 'openSUSE BuildService - Virtualisering (VirtualBox)' er oppdatert.
    Pakkebrønnen 'openSUSE BuildService - Spill' er oppdatert.
    Pakkebrønnen 'openSUSE BuildService - Mozilla' er oppdatert.
    Pakkebrønnen 'Hovedarkiv (Kilder)' er oppdatert.
    Pakkebrønnen 'openSUSE BuildService - Java:packages' er oppdatert.
    Pakkebrønnen 'Packman Repository' er oppdatert.
    Pakkebrønnen 'AMD/ATI Graphics Drivers' er oppdatert.
    Pakkebrønnen 'openSUSE-13.2-0' er oppdatert.
    Pakkebrønnen 'openSUSE-13.2-Non-Oss' er oppdatert.
    Pakkebrønnen 'openSUSE-13.2-Oss' er oppdatert.
    Pakkebrønnen 'openSUSE-13.2-Update' er oppdatert.
    Pakkebrønnen 'openSUSE-13.2-Update-Non-Oss' er oppdatert.
    Pakkebrønnen 'utilities' er oppdatert.
    Alle pakkebrønner er oppdatert.
    
    linux-7v2w:/home/ronsim # zypper update
    Laster pakkebrønndata...
    Leser installerte pakker...
    
    The following 149 package updates will NOT be installed:  
    amarok apper appmenu-qt bluedevil bluedevil-lang choqok cln digikam digikam-doc ed fdupes gstreamer   gstreamer-0_10 gstreamer-0_10-plugin-esd gstreamer-0_10-plugins-base gstreamer-0_10-plugins-good   gstreamer-plugins-base gstreamer-plugins-good gstreamer-plugins-qt gtk2-engine-oxygen gtk2-theme-oxygen   javapackages-tools kaffeine kde-gtk-config kio_iso kipi-plugins kipi-plugins-acquireimage   kipi-plugins-geolocation kipi-plugins-lang konversation konversation-lang ksshaskpass ktorrent kvkbd lensfun-data   libabw-0_1-1 libbluedevil2 libcap-ng0 libcdr-0_1-1 libe-book-0_1-1 libepub0 libetonyek-0_1-1 libexttextcat   libexttextcat-2_0-0 libfbembed2_5 libfreebl3 libfreehand-0_1-1 libgltf-0_0-0 libgraphite2-3 libgraphite2-3-32bit   libgstallocators-1_0-0 libgstapp-0_10-0 libgstapp-1_0-0 libgstaudio-1_0-0 libgstfft-1_0-0 libgstinterfaces-0_10-0   libgstpbutils-1_0-0 libgstreamer-0_10-0 libgstreamer-1_0-0 libgstriff-1_0-0 libgstrtp-1_0-0 libgstrtsp-1_0-0   libgstsdp-1_0-0 libgsttag-1_0-0 libgstvideo-1_0-0 libhyphen0 libixion-0_8-0 libkgeomap-lang liblangtag1   liblensfun0 liblpsolve55-0 libmediawiki1 libmjpegutils-2_0-0 libmspub-0_1-1 libmwaw-0_3-3 libmysqlcppconn6   libmythes-1_2-0 libnuma1 libodfgen-0_1-1 libopencv2_4 liborcus-0_8-0 libqalculate5 libquicktime0 libraw10   libreoffice libreoffice-base libreoffice-base-drivers-mysql libreoffice-branding-openSUSE libreoffice-calc   libreoffice-calc-extensions libreoffice-draw libreoffice-filters-optional libreoffice-icon-theme-galaxy   libreoffice-icon-theme-hicontrast libreoffice-icon-theme-oxygen libreoffice-icon-theme-sifr libreoffice-impress   libreoffice-kde4 libreoffice-l10n-en libreoffice-l10n-nb libreoffice-mailmerge libreoffice-math libreoffice-pyuno   libreoffice-templates-en libreoffice-templates-labels-a4 libreoffice-templates-labels-letter   libreoffice-templates-presentation-layouts libreoffice-writer libreoffice-writer-extensions librevenge-0_0-0   libSDL-1_2-0 libSDL_gfx15 libSDL_net-1_2-0 libSDL_sound-1_0-1 libsoftokn3 libsox2 libssh4 libstreamanalyzer0   libtag-extras1 libtelepathy-qt4-2 libvisio-0_1-1 libwpd-0_10-10 libwpg-0_3-3 libwps-0_3-3 libxine2 libxine2-pulse   lsof mjpegtools moodbar MozillaFirefox MozillaFirefox-translations-common mozilla-kde4-integration mozilla-nss   mozilla-nss-certs mozilla-nss-tools myspell-dictionaries myspell-en myspell-lightproof-en myspell-no numactl   pm-utils prctl python3-setuptools python-setuptools skanlite skanlite-doc skanlite-lang sox synaptiks 
    
    Nothing to do.
    linux-7v2w:/home/ronsim #
    My repos is:
    HTML Code:
    linux-7v2w:/home/ronsim # zypper repos
    #  | Alias                                                | Navn                                                                        | aktivert | Oppdater
    ---+-------------------------------------------------------+-------------------------------------------------------------------------------+-----------+--------- 
    1 | download.opensuse.org-4.3                | openSUSE BuildService - LibreOffice                           | Ja        | Ja       
    2 | download.opensuse.org-Extra             | openSUSE BuildService - KDE:Extra                           | Ja        | Ja       
    3 | download.opensuse.org-Virtualization  | openSUSE BuildService - Virtualisering (VirtualBox)      | Ja       | Ja       
    4 | download.opensuse.org-games          | openSUSE BuildService - Spill                                     | Ja       | Ja       
    5 | download.opensuse.org-mozilla         | openSUSE BuildService - Mozilla                                  | Ja       | Ja       
    6 | download.opensuse.org-oss               | Hovedarkiv (Kilder)                                                      | Ja       | Ja       
    7 | download.opensuse.org-packages      | openSUSE BuildService - Java:packages                     | Ja       | Ja       
    8 | ftp.gwdg.de-suse                              | Packman Repository                                                  | Ja       | Ja       
    9 | geeko.ioda.net-amd-fglrx                   | AMD/ATI Graphics Drivers                                           | Ja       | Ja      
    10 | openSUSE-13.2-0                          | openSUSE-13.2-0                                                       | Ja       | Nei     
    11 | repo-debug                                     | openSUSE-13.2-Debug                                               | Nei      | Ja      
    12 | repo-debug-update                          | openSUSE-13.2-Update-Debug                                   | Nei      | Ja      
    13 | repo-debug-update-non-oss              | openSUSE-13.2-Update-Debug-Non-Oss                     | Nei      | Ja      
    14 | repo-non-oss                                  | openSUSE-13.2-Non-Oss                                           | Ja       | Ja      
    15 | repo-oss                                        | openSUSE-13.2-Oss                                                  | Ja       | Ja      
    16 | repo-source                                   | openSUSE-13.2-Source                                              | Nei      | Ja      
    17 | repo-update                                   | openSUSE-13.2-Update                                              | Ja       | Ja      
    18 | repo-update-non-oss                       | openSUSE-13.2-Update-Non-Oss                                | Ja       | Ja      
    19 | utilities                                          | utilities                                                                      | Ja       | Ja      
    linux-7v2w:/home/ronsim #
    Why is it like this?
    OpenSUSE 13.2 64bits KDE

  2. #2

    Default Re: 146 packages wont update?

    Quote Originally Posted by ronnys View Post
    Why is it like this?
    Because openSUSE's package management tools do _not_ switch packages to versions from other repos by default.
    That message means a higher version/revision is available from another repo, but not installed because of that.

    To switch packages to the versions from a certain repo, see here:
    https://en.opensuse.org/SDB:Vendor_change_update

  3. #3
    Join Date
    Jul 2008
    Location
    Narvik, Norway
    Posts
    393

    Default Re: 146 packages wont update?

    Ok thanks!
    I have fixed this now and i don't have any packages that is not updated.
    Somtime it work to change default Repos, but sometimes it get conflict with Kernel-installation. Then i only choose to install latest version without changing default Repos.

    RS

    Quote Originally Posted by wolfi323 View Post
    Because openSUSE's package management tools do _not_ switch packages to versions from other repos by default.
    That message means a higher version/revision is available from another repo, but not installed because of that.

    To switch packages to the versions from a certain repo, see here:
    https://en.opensuse.org/SDB:Vendor_change_update

  4. #4

    Default AW: Re: 146 packages wont update?

    Quote Originally Posted by ronnys View Post
    Ok thanks!
    I have fixed this now and i don't have any packages that is not updated.
    No. You did not fix anything, as there was nothing to "fix".
    Your packages were being updated, that message only informs you that a package with a higher version/revision number was available from a different repo (which doesn't mean it is really a higher version or even preferable).

    If you have a package xxx-1.2-3.1, and a package xxx-1.2-4.1, zypper will take the later as being a higher version. But it is not. It is the same version, only the number of rebuilds is different (which has absolutely no meaning when comparing

    You can only decide yourself on a case-by-case basis, there is no way to "fix" this in general (other than to remove all additional repos from your system...).
    E.g. you might want to keep a package from Packman even though there is a higher/newer version available from somewhere else, because only the Packman version has full multimedia support.
    And just switching all packages to the "highest" available versions might even break your system, if packages that belong together/depend on each other come from different repos then.

    As far as I can judge from your repo list, you do want to have the latest versions of the mentioned packages, although I'm not really sure about the utilities repo.
    And the Mozilla repo is probably not really necessary as you get the latest Firefox and Thunderbird versions via the standard update repo anyway. (the same is true for LibreOffice, but the standard packages have a problem that does not exist in the version from LibreOffice:4.3, namely https://bugzilla.opensuse.org/show_bug.cgi?id=906688)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •