I get an error message saying that my "current backend does not support installing files"

What does this mean, and how do I get it to support installing files?