Results 1 to 9 of 9

Thread: Skype from another user

  1. #1

    Unhappy Skype from another user

    Hello.
    Please tell me what I'm doing wrong?


    My action:

    Create user:

    Code:
    # useradd -m -g skype -G audio,video -s /bin/bash skype
    I write in /home/skype/.bashrc:


    Code:
    export DISPLAY=":0.0"
    and then


    Code:
    $ xhost +local: && su skype -c skype
    Sound does not work!








    How to fix it?
    Thanks for you answer.

  2. #2
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: Skype from another user

    skype does not work well with pulse audio, disable it via yast or uninstall it (is pulse really needed?)

    see this suse wiki page for more info
    https://en.opensuse.org/Skype#Usage_without_PulseAudio

    I had the same problem a few months ago, I removed pulse audio (I'm not sure how it got installed in the first place) via yast and all was well, if you really need pulse see the skype wiki (above link)

  3. #3
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,743

    Default Re: Skype from another user

    Also check the UID you screen shot seems to indicate you are running as user ID 1000 which is the default first user UID. A new user should have a different UID .
    Also it is just plain easier to add the new user from Yast since it crosses all the T's and dots all the I's

  4. #4

    Default Re: Skype from another user

    Quote Originally Posted by I_A View Post
    skype does not work well with pulse audio, disable it via yast or uninstall it (is pulse really needed?)

    see this suse wiki page for more info
    https://en.opensuse.org/Skype#Usage_without_PulseAudio

    I had the same problem a few months ago, I removed pulse audio (I'm not sure how it got installed in the first place) via yast and all was well, if you really need pulse see the skype wiki (above link)

    Hi,

    Not according to this site

    http://blogs.skype.com/2014/06/18/skype-4-3-for-linux/

    It is the other way around
    "Unfortunately time is always against us" -- [Morpheus]

    .:https://github.com/Jetchisel:.

  5. #5
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: Skype from another user

    Quote Originally Posted by jetchisel View Post
    Hi,

    Not according to this site

    http://blogs.skype.com/2014/06/18/skype-4-3-for-linux/

    It is the other way around
    Happened to me the same pulse error on a 32bit 13.2, from the image he posted his issues are with pulse.
    Code:
    failed to create secure directory /run/user/1000/pulse/
    first I disabled then I completely removed pulse, I have no audio issues, there might be a missing pulse package causing the issue or a bad compile from microsoft but if you don't need pulse (for a particular app or game) just remove it.

  6. #6
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: Skype from another user

    did a little googling and it seams pulse audio server would refuse to start if the user's home directory was owned by root and give the above error, the best fix would be to do a console login (Ctrl+alt+F1) and change the user's home owner
    Code:
    sudo chown -R user:user /home/user
    still if the above doesn't work removing pulse is faster

  7. #7
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: Skype from another user

    from here
    another way to fix pulse audio problems would be to run a single pulse audio deamon instead of a per logged in user:


    • add to every user on the system the groups 'pulse' and 'pulse-access'
    • edit /etc/pulse/deamon.conf
    • change 'deamonize = no' to 'deamonize = yes'
    • change 'system-instance = no' to 'system-instance= yes'
    • edit etc/default/pulseaudio
    • change 'PULSEAUDIO_SYSTEM_START=0' to 'PULSEAUDIO_SYSTEM_START=1'
    • delete .pulse in your home directory and do the same fore other users
    • reboot the system


    it would be good to know if we helped or not talking to the wind is not that fun

  8. #8

    Default Re: Skype from another user

    Code:
    useradd -m -g skype -G audio,video -s /bin/bash skype
    Prints an error

    Code:
    useradd: group 'skype' does not exist
    Better use

    Code:
    yast2 users
    for creating user unless you have read and understand

    Code:
    man useradd
    Unless of course there is an existing skype group ...

    "Unfortunately time is always against us" -- [Morpheus]

    .:https://github.com/Jetchisel:.

  9. #9

    Default Re: Skype from another user

    Quote Originally Posted by I_A View Post
    it would be good to know if we helped or not talking to the wind is not that fun
    Of course, of course.

    Quote Originally Posted by jetchisel View Post
    Code:
    useradd -m -g skype -G audio,video -s /bin/bash skype
    Prints an error

    Excuse Me. I use OpenSuse and Fedora. For Fedora this syntax works. Many years ago I worked also on Mandriva, but today, I think, this distribution is dead... too bad.


    Thanks a lot for your advice, but it does not work. Really, I tested it all.
    I propose another way, it works for OpenSuse13.2 and Fedora21.
    Ok, step-by-step:


    # groupadd skype


    Then we have to add the new user:
    # useradd -m -g skype -G audio,video -s /bin/bash skype
    # passwd skype

    (or Yast )


    Now add the following line to /home/skype/.bashrc:


    Code:
    export DISPLAY=":0.0"
    At last we define the alias (e.g. in ~/.bashrc):


    Code:
    alias skype='xhost +local: && su skype -c skype'
    As the "main-user" copy /etc/pulse/default.pa to ~/.pulse/default.pa and add:


    Code:
    load-module module-native-protocol-tcp auth-ip-acl=127.0.0.1
    As the skype user, create ~/.pulse/client.conf and add:


    Code:
    default-server = 127.0.0.1
    Now we can start Skype as the newly created user simply by running skype from the command line and entering the password of the user skype. Or:


    Code:
    [aleksej@localhost ~]$ su -l skype
    Пароль: 
    [skype@localhost ~]$ skype
    Pulseaudio problem for Skype 4.3 is solved. I used this great article. This works for OpenSuse and Fedora.



Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •