Results 1 to 9 of 9

Thread: I get no updates to Tumbleweed

  1. #1

    Default I get no updates to Tumbleweed

    I ahd it installed for ~3weeks. As TW is a 'bleeding edge' distro i am surprised that no upgrades arrived.

    I have the repo settings:

    > zypper repos
    # | Alias | Name | Enabled | Refresh
    --+---------------------------+---------------------------+---------+--------
    1 | MariaDB_repo_for_OpenSuSE | MariaDB repo for OpenSuSE | Yes | Yes
    2 | packman-essentials | packman-essentials | Yes | Yes
    3 | repo-debug | repo-debug | Yes | Yes
    4 | repo-non-oss | repo-non-oss | Yes | Yes
    5 | repo-oss | repo-oss | Yes | Yes
    6 | repo-src-non-oss | repo-src-non-oss | No | Yes
    7 | update | update | Yes | Yes


    Am I missing somethng? Or is there a problem with Yast 'Online Update' GUI/applet in Tumbleweed? I notice that every time I start it, it complains that "no update source was configured" and I will have to click OK it the dialog that opens next.
    Last edited by malcolmlewis; 10-Jan-2015 at 09:00.

  2. #2
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: I get no updates to Tumbleweed

    On 2015-01-10 15:16, jazcykel wrote:

    > Am I missing somethng? Or is there a problem with Yast 'Online Update'
    > GUI/applet in Tumbleweed? I notice that every time I start it, it
    > complains that "no update source was configured" and I will have to
    > click OK it the dialog that opens next.


    You are missing something: that there are no updates to TW. Not via YOU,
    that is. Instead, you have to use, as documented, "zypper dup".

    If you have further questions, please request a moderator to move your
    post to the tumbleweed forum.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 13.1 x86_64 "Bottle" at Telcontar)

  3. #3

    Default Re: I get no updates to Tumbleweed

    Quote Originally Posted by jazcykel View Post
    Am I missing somethng? Or is there a problem with Yast 'Online Update' GUI/applet in Tumbleweed? I notice that every time I start it, it complains that "no update source was configured" and I will have to click OK it the dialog that opens next.
    YaST->Online Update only installs updates from the update repo.
    As Tumbleweed is a rolling distribution, you get updates via the main repo instead. (there is an update repo for critical security fixes in emergency cases, but that is empty at the moment)

    Use "zypper dup" to keep your system up-to-date, that always was and still is the only supported way to update Tumbleweed.

    You can also use YaST->Software Management or the desktop's updater applet, but the first is rather manual, and the latter cannot cope well (or at all) with package renames/drops and downgrades as can happen in Factory/Tumbleweed.

    PS, OOC: What do you need that MariaDB repo for? Shouldn't the latest mariadb be included in Tumbleweed anyway?

  4. #4

    Default Re: I get no updates to Tumbleweed

    hmm "suddo zypper up" found 179 packages. So the problem is with YaST "Online Upgrade" GUI applet, it seems

  5. #5
    Join Date
    Aug 2008
    Location
    SouthWest part Netherlands
    Posts
    81

    Default Re: I get no updates to Tumbleweed

    Hello,

    I think that you have the wrong repositories.

    Have a look at openSUSE:Tumbleweed installation - openSUSE and look at repositories under upgrade.

    On my system I have removed the old repositories and added the new ones as described in the referenced URL

    Regards, Frans

  6. #6

    Default Re: I get no updates to Tumbleweed

    Quote Originally Posted by fleerink View Post
    I think that you have the wrong repositories.
    Actually that is totally unclear from the information posted so far.

    The posted repo list only shows the repo _names_ which could be anything.

    Please post the output of "zypper lr -d" for clarification.

    But as has been mentioned already, YaST->"Online Update" will not find any updates on Tumbleweed as there are no updates in the update repo.
    That's not how Tumbleweed works.

    And to repeat again: you should use "zypper dup" to update your system, or at least call it from time to time.

    PS: I requested this thread to be moved to the Tumbleweed forum...
    Last edited by wolfi323; 10-Jan-2015 at 08:41.

  7. #7
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: I get no updates to Tumbleweed

    On 2015-01-10 15:36, jazcykel wrote:
    >
    > hmm "suddo zypper up" found 179 packages. So the problem is with YaST
    > "Online Upgrade" GUI applet, it seems


    There is no problem at all with it. It is working as intended.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 13.1 x86_64 "Bottle" at Telcontar)

  8. #8
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,311
    Blog Entries
    15

    Default Re: I get no updates to Tumbleweed

    Closing thread temporarily to move, nntp users hold off replies.
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  9. #9
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,311
    Blog Entries
    15

    Default Re: I get no updates to Tumbleweed

    Quote Originally Posted by jazcykel View Post
    I ahd it installed for ~3weeks. As TW is a 'bleeding edge' distro i am surprised that no upgrades arrived.

    I have the repo settings:

    > zypper repos
    # | Alias | Name | Enabled | Refresh
    --+---------------------------+---------------------------+---------+--------
    1 | MariaDB_repo_for_OpenSuSE | MariaDB repo for OpenSuSE | Yes | Yes
    2 | packman-essentials | packman-essentials | Yes | Yes
    3 | repo-debug | repo-debug | Yes | Yes
    4 | repo-non-oss | repo-non-oss | Yes | Yes
    5 | repo-oss | repo-oss | Yes | Yes
    6 | repo-src-non-oss | repo-src-non-oss | No | Yes
    7 | update | update | Yes | Yes


    Am I missing somethng? Or is there a problem with Yast 'Online Update' GUI/applet in Tumbleweed? I notice that every time I start it, it complains that "no update source was configured" and I will have to click OK it the dialog that opens next.
    Thread moved and opened for consumption.
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •