Page 1 of 3 123 LastLast
Results 1 to 10 of 22

Thread: Kodi 14 not available. Reason?

Hybrid View

  1. #1

    Question Kodi 14 not available. Reason?

    I have been waiting since 23rd of December for Kodi (new name of XBMC) to show up in OpenSUSE but nothing has happened. Does anyone know why it hasn't been added or if it will be? Regards

  2. #2
    Join Date
    Jul 2008
    Location
    Seattle, WA
    Posts
    17,083

    Default Re: Kodi 14 not available. Reason?

    On Mon, 05 Jan 2015 22:16:02 +0000, opensuse38 wrote:

    > I have been waiting since 23rd of December for Kodi (new name of XBMC)
    > to show up in OpenSUSE but nothing has happened. Does anyone know why it
    > hasn't been added or if it will be? Regards


    Where are you looking, and what version of openSUSE?

    Jim



    --
    Jim Henderson
    openSUSE Forums Administrator
    Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

  3. #3

    Default Re: Kodi 14 not available. Reason?

    Hi hendersj,
    I have searched the standard repositories included in 13.2 x64, Packman and also using Google. It seems that almost every major distro has it in repositories but not OpenSuse and I can't find a precompiled tar to download. Regards.

  4. #4
    Join Date
    Jul 2008
    Location
    Seattle, WA
    Posts
    17,083

    Default Re: Kodi 14 not available. Reason?

    On Tue, 06 Jan 2015 07:36:01 +0000, opensuse38 wrote:

    > Hi hendersj,
    > I have searched the standard repositories included in 13.2 x64, Packman
    > and also using Google. It seems that almost every major distro has it in
    > repositories but not OpenSuse and I can't find a precompiled tar to
    > download. Regards.


    As Sagemta indicates, this is hosted by Packman (it wouldn't be hosted by
    the project itself on software.opensuse.org because of codec licensing
    issues - same reason other proprietary multimedia codecs aren't part of
    the stock distro). Sounds like the Packman folks are working on it.

    I wouldn't expect a precompiled tar to be produced.

    Jim
    --
    Jim Henderson
    openSUSE Forums Administrator
    Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

  5. #5

    Thumbs up Re: Kodi 14 not available. Reason?

    Kodi 14 is available now! Thank you guys!

    I was not criticising any of you with my question. I was just curious and anxious.

  6. #6

    Default Re: Kodi 14 not available. Reason?

    Update:

    Kodi doesn't start. I get almost the same error (just different paths and lines) as in this post but it doesn't get solved by installing xdpyinfo. Any idea what might be the problem? I am using OpenSUSE 13.2 x64.

  7. #7
    Join Date
    May 2012
    Location
    Finland
    Posts
    2,012

    Default Re: Kodi 14 not available. Reason?

    Quote Originally Posted by opensuse38 View Post
    Update:

    Kodi doesn't start. I get almost the same error (just different paths and lines) as in this post but it doesn't get solved by installing xdpyinfo. Any idea what might be the problem? I am using OpenSUSE 13.2 x64.
    Since I didn't have a 13.2 installation, I set it up in a VM and installed Kodi. After the installation and upon launch it complained about UnboundLocalError: local variable 'bitDepth' referenced before assignment. Simply installing xdpyinfo resolved this problem.

    What error message does it output upon launching it (kodi) from a terminal?
    .: miuku #suse @ irc.freenode.net
    :: miuku@opensuse.org

    .: h​ttps://download.opensuse.org/repositories/home:/Miuku/

  8. #8

    Default Re: Kodi 14 not available. Reason?

    Quote Originally Posted by Miuku View Post
    Since I didn't have a 13.2 installation, I set it up in a VM and installed Kodi. After the installation and upon launch it complained about UnboundLocalError: local variable 'bitDepth' referenced before assignment. Simply installing xdpyinfo resolved this problem.

    What error message does it output upon launching it (kodi) from a terminal?
    Hi Miuku,
    I also get the UnboundLocalError even though I have reinstalled xdpyinfo.

  9. #9
    Join Date
    May 2012
    Location
    Finland
    Posts
    2,012

    Default Re: Kodi 14 not available. Reason?

    Could you run this command from a terminal and copy paste the output here, enclose it in code blocks, like this:
    Code:
    Cats are cute!
    The command being: strace -e open kodi

    You can run it as your normal user, no root privileges necessary nor sudo.
    .: miuku #suse @ irc.freenode.net
    :: miuku@opensuse.org

    .: h​ttps://download.opensuse.org/repositories/home:/Miuku/

  10. #10

    Default Re: Kodi 14 not available. Reason?

    Here you go:

    Code:
    strace -e open kodiopen("/lib64/bash/4.2/tls/x86_64/libreadline.so.6", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
    open("/lib64/bash/4.2/tls/libreadline.so.6", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
    open("/lib64/bash/4.2/x86_64/libreadline.so.6", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
    open("/lib64/bash/4.2/libreadline.so.6", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
    open("/etc/ld.so.cache", O_RDONLY|O_CLOEXEC) = 3
    open("/lib64/libreadline.so.6", O_RDONLY|O_CLOEXEC) = 3
    open("/lib64/libtinfo.so.5", O_RDONLY|O_CLOEXEC) = 3
    open("/lib64/libdl.so.2", O_RDONLY|O_CLOEXEC) = 3
    open("/lib64/libc.so.6", O_RDONLY|O_CLOEXEC) = 3
    open("/dev/tty", O_RDWR|O_NONBLOCK)     = 3
    open("/usr/lib/locale/locale-archive", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
    open("/usr/share/locale/locale.alias", O_RDONLY|O_CLOEXEC) = 3
    open("/usr/lib/locale/en_US.utf8/LC_IDENTIFICATION", O_RDONLY|O_CLOEXEC) = 3
    open("/usr/lib64/gconv/gconv-modules.cache", O_RDONLY) = 3
    open("/usr/lib/locale/en_US.utf8/LC_MEASUREMENT", O_RDONLY|O_CLOEXEC) = 3
    open("/usr/lib/locale/en_US.utf8/LC_TELEPHONE", O_RDONLY|O_CLOEXEC) = 3
    open("/usr/lib/locale/en_US.utf8/LC_ADDRESS", O_RDONLY|O_CLOEXEC) = 3
    open("/usr/lib/locale/en_US.utf8/LC_NAME", O_RDONLY|O_CLOEXEC) = 3
    open("/usr/lib/locale/en_US.utf8/LC_PAPER", O_RDONLY|O_CLOEXEC) = 3
    open("/usr/lib/locale/en_US.utf8/LC_MESSAGES", O_RDONLY|O_CLOEXEC) = 3
    open("/usr/lib/locale/en_US.utf8/LC_MESSAGES/SYS_LC_MESSAGES", O_RDONLY|O_CLOEXEC) = 3
    open("/usr/lib/locale/en_US.utf8/LC_MONETARY", O_RDONLY|O_CLOEXEC) = 3
    open("/usr/lib/locale/en_US.utf8/LC_COLLATE", O_RDONLY|O_CLOEXEC) = 3
    open("/usr/lib/locale/en_US.utf8/LC_TIME", O_RDONLY|O_CLOEXEC) = 3
    open("/usr/lib/locale/en_US.utf8/LC_NUMERIC", O_RDONLY|O_CLOEXEC) = 3
    open("/usr/lib/locale/en_US.utf8/LC_CTYPE", O_RDONLY|O_CLOEXEC) = 3
    open("/proc/meminfo", O_RDONLY|O_CLOEXEC) = 3
    open("/usr/bin/kodi", O_RDONLY)         = 3
    --- SIGCHLD {si_signo=SIGCHLD, si_code=CLD_EXITED, si_pid=22932, si_status=0, si_utime=0, si_stime=0} ---
    xdpyinfo: error while loading shared libraries: libXxf86dga.so.1: cannot open shared object file: No such file or directory
    Traceback (most recent call last):
      File "/usr/share/kodi/FEH.py", line 174, in <module>
        if (1 == 1 and badColorDepth()):
      File "/usr/share/kodi/FEH.py", line 153, in badColorDepth
        return bitDepth
    UnboundLocalError: local variable 'bitDepth' referenced before assignment
    --- SIGCHLD {si_signo=SIGCHLD, si_code=CLD_EXITED, si_pid=22933, si_status=1, si_utime=7, si_stime=2} ---
    +++ exited with 1 +++

Page 1 of 3 123 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •